rules 823 B

123456789101112131415161718192021222324252627282930
  1. #!/usr/bin/make -f
  2. # Uncomment this to turn on verbose mode.
  3. #export DH_VERBOSE=1
  4. INSTALL := install -o root -g root -m 755
  5. CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
  6. CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
  7. version=$(shell dpkg-parsechangelog | grep urgency | awk '{ print $$2; }'| \
  8. sed -e s/"("// -e s/")"// | cut -d"-" -f1)
  9. %:
  10. dh $@
  11. override_dh_auto_build:
  12. dh_auto_build -- CFLAGS="$(CFLAGS) $(CPPFLAGS) -std=c99 -fomit-frame-pointer -pedantic -D_BSD_SOURCE \
  13. -DFWCUTTER_VERSION_=`echo $(version) | cut -d: -f2`"
  14. override_dh_auto_clean:
  15. rm -f b43-fwcutter
  16. rm -rf $(CURDIR)/debian/b43-fwcutter/usr/man
  17. override_dh_installchangelogs:
  18. dh_installchangelogs $(CURDIR)/debian/b43-fwcutter.upstream-changelog
  19. override_dh_auto_install:
  20. $(INSTALL) b43-fwcutter $(CURDIR)/debian/b43-fwcutter/usr/bin