wdiff.scm 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
  3. ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages wdiff)
  20. #:use-module (guix licenses)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (gnu packages texinfo)
  25. #:use-module (gnu packages screen)
  26. #:use-module (gnu packages base))
  27. (define-public wdiff
  28. (package
  29. (name "wdiff")
  30. (version "1.2.2")
  31. (source
  32. (origin
  33. (method url-fetch)
  34. (uri (string-append "mirror://gnu/wdiff/wdiff-"
  35. version ".tar.gz"))
  36. (sha256
  37. (base32
  38. "0sxgg0ms5lhi4aqqvz1rj4s77yi9wymfm3l3gbjfd1qchy66kzrl"))))
  39. (build-system gnu-build-system)
  40. (arguments
  41. `(#:phases (modify-phases %standard-phases
  42. (add-before 'check 'fix-sh
  43. (lambda _
  44. (substitute* "tests/testsuite"
  45. (("#! /bin/sh")
  46. (string-append "#!" (which "sh")))))))))
  47. (native-inputs
  48. `(("which" ,which)
  49. ;; For some reason wdiff.info gets rebuilt.
  50. ("texinfo" ,texinfo)))
  51. (home-page "https://www.gnu.org/software/wdiff/")
  52. (synopsis "Word difference finder")
  53. (description
  54. "GNU Wdiff is a front-end to the diff program from Diffutils that
  55. allows you to compare files on a word-by-word basis, where a word is anything
  56. between whitespace.")
  57. (license gpl3+)))