visidata.scm 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages visidata)
  19. #:use-module (gnu packages check)
  20. #:use-module (gnu packages time)
  21. #:use-module (gnu packages python-web)
  22. #:use-module (gnu packages python-xyz)
  23. #:use-module (gnu packages xml)
  24. #:use-module (guix build-system python)
  25. #:use-module (guix build utils)
  26. #:use-module (guix download)
  27. #:use-module ((guix licenses) #:prefix license:)
  28. #:use-module (guix packages))
  29. (define-public visidata
  30. (package
  31. (name "visidata")
  32. (version "2.5")
  33. (source
  34. (origin
  35. (method url-fetch)
  36. (uri (pypi-uri "visidata" version))
  37. (sha256
  38. (base32
  39. "19fbjr9j91pcazcz0bqx3qrasmr8xdsb13haf5lfbpyxj23f7f1j"))))
  40. (build-system python-build-system)
  41. (arguments
  42. '(#:phases
  43. (modify-phases %standard-phases
  44. (replace 'check
  45. (lambda* (#:key tests? #:allow-other-keys)
  46. (when tests? (invoke "pytest"))
  47. #t)))))
  48. (inputs
  49. `(("dateutil" ,python-dateutil)
  50. ("requests" ,python-requests)
  51. ("lxml" ,python-lxml)
  52. ("openpyxl" ,python-openpyxl)
  53. ("xlrd" ,python-xlrd)))
  54. (native-inputs
  55. `(("pytest" ,python-pytest)))
  56. (synopsis "Terminal spreadsheet multitool for discovering and arranging data")
  57. (description
  58. "VisiData is an interactive multitool for tabular data. It combines the
  59. clarity of a spreadsheet, the efficiency of the terminal, and the power of
  60. Python, into a lightweight utility which can handle millions of rows.")
  61. (home-page "https://www.visidata.org/")
  62. (license license:gpl3)))