tv.scm 2.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015, 2016, 2017, 2018 Alex Kost <alezost@gmail.com>
  3. ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages tv)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu)
  23. #:use-module ((guix licenses) #:prefix license:)
  24. #:use-module (gnu packages)
  25. #:use-module (gnu packages compression)
  26. #:use-module (gnu packages fontutils)
  27. #:use-module (gnu packages image)
  28. #:use-module (gnu packages linux)
  29. #:use-module (gnu packages pkg-config)
  30. #:use-module (gnu packages xml)
  31. #:use-module (gnu packages xorg))
  32. (define-public tvtime
  33. (package
  34. (name "tvtime")
  35. (version "1.0.11")
  36. (source (origin
  37. (method url-fetch)
  38. (uri (string-append
  39. "https://linuxtv.org/downloads/tvtime/tvtime-"
  40. version ".tar.gz"))
  41. (sha256
  42. (base32
  43. "1367rl3n6qxwf30lqyz234zpb43s9xjhig3hrvbg7cbqcl8g4fs0"))))
  44. (build-system gnu-build-system)
  45. (arguments
  46. '(#:phases
  47. (modify-phases %standard-phases
  48. (add-after 'unpack 'fix-glibc-compatability
  49. (lambda _
  50. (substitute* "src/get_media_devices.c"
  51. (("<sys/stat.h>")
  52. "<sys/stat.h>\n#include <sys/sysmacros.h>"))
  53. #t)))))
  54. (inputs
  55. `(("alsa-lib" ,alsa-lib)
  56. ("libx11" ,libx11)
  57. ("libxext" ,libxext)
  58. ("libxt" ,libxt)
  59. ("libxtst" ,libxtst)
  60. ("libxinerama" ,libxinerama)
  61. ("libxv" ,libxv)
  62. ("libxxf86vm" ,libxxf86vm)
  63. ("libpng" ,libpng)
  64. ("libxml2" ,libxml2)
  65. ("freetype" ,freetype)
  66. ("zlib" ,zlib)))
  67. (native-inputs
  68. `(("pkg-config" ,pkg-config)))
  69. (home-page "http://tvtime.sourceforge.net")
  70. (synopsis "Television viewer")
  71. (description
  72. "Tvtime processes the input from your video capture card and
  73. displays it on a monitor. It focuses on a high visual quality.")
  74. (license license:gpl2+)))