tryton.scm 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
  3. ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
  4. ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
  5. ;;; Copyright © 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages tryton)
  22. #:use-module ((guix licenses) #:prefix license:)
  23. #:use-module (gnu packages)
  24. #:use-module (gnu packages check)
  25. #:use-module (gnu packages databases)
  26. #:use-module (gnu packages finance)
  27. #:use-module (gnu packages glib)
  28. #:use-module (gnu packages gnome)
  29. #:use-module (gnu packages gtk)
  30. #:use-module (gnu packages python)
  31. #:use-module (gnu packages python-crypto)
  32. #:use-module (gnu packages python-web)
  33. #:use-module (gnu packages python-xyz)
  34. #:use-module (gnu packages time)
  35. #:use-module (gnu packages xml)
  36. #:use-module (guix packages)
  37. #:use-module (guix download)
  38. #:use-module (guix utils)
  39. #:use-module (guix build-system python))
  40. (define-public trytond
  41. (package
  42. (name "trytond")
  43. (version "6.0.6")
  44. (source
  45. (origin
  46. (method url-fetch)
  47. (uri (pypi-uri "trytond" version))
  48. (sha256
  49. (base32 "1jp5cadqpwkcnml8r1hj6aak5kc8an2d5ai62p96x77nn0dp3ny4"))))
  50. (build-system python-build-system)
  51. (propagated-inputs
  52. `(("python-dateutil" ,python-dateutil)
  53. ("python-genshi" ,python-genshi)
  54. ("python-lxml" ,python-lxml)
  55. ("python-magic" ,python-magic)
  56. ("python-passlib" ,python-passlib)
  57. ("python-polib" ,python-polib)
  58. ("python-psycopg2" ,python-psycopg2)
  59. ("python-relatorio" ,python-relatorio)
  60. ("python-sql" ,python-sql)
  61. ("python-werkzeug" ,python-werkzeug)
  62. ("python-wrapt" ,python-wrapt)))
  63. (native-inputs
  64. `(("python-mock" ,python-mock)
  65. ("python-pillow" ,python-pillow)))
  66. (arguments
  67. `(#:phases
  68. (modify-phases %standard-phases
  69. (add-before 'check 'preparations
  70. (lambda _
  71. (setenv "DB_NAME" ":memory:")
  72. (setenv "HOME" "/tmp")
  73. #t)))))
  74. (home-page "https://www.tryton.org/")
  75. (synopsis "Tryton Server")
  76. (description "Tryton is a three-tier high-level general purpose
  77. application platform using PostgreSQL as its main database engine. It is the
  78. core base of a complete business solution providing modularity, scalability
  79. and security.")
  80. (license license:gpl3+)))
  81. (define-public python-trytond
  82. (deprecated-package "python-trytond" trytond))
  83. (define-public tryton
  84. (package
  85. (name "tryton")
  86. (version "6.0.5")
  87. (source
  88. (origin
  89. (method url-fetch)
  90. (uri (pypi-uri "tryton" version))
  91. (sha256
  92. (base32 "15cbp2r25pkr7lp4yliqgb6d0n779z70d4gckv56bx5aw4z27f66"))))
  93. (build-system python-build-system)
  94. (arguments
  95. `(#:phases
  96. (modify-phases %standard-phases
  97. (add-before 'check 'change-home
  98. (lambda _
  99. ;; Change from /homeless-shelter to /tmp for write permission.
  100. (setenv "HOME" "/tmp")))
  101. (add-after 'install 'wrap-gi-python
  102. (lambda* (#:key inputs outputs #:allow-other-keys)
  103. (let ((out (assoc-ref outputs "out"))
  104. (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
  105. (wrap-program (string-append out "/bin/tryton")
  106. `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
  107. #t)))))
  108. (native-inputs
  109. `(("glib-compile-schemas" ,glib "bin")
  110. ("gobject-introspection" ,gobject-introspection)))
  111. (propagated-inputs
  112. `(("gdk-pixbuf" ,gdk-pixbuf+svg)
  113. ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
  114. ("gtk+" ,gtk+)
  115. ("python-dateutil" ,python-dateutil)
  116. ("python-pycairo" ,python-pycairo)
  117. ("python-pygobject" ,python-pygobject)))
  118. (home-page "https://www.tryton.org/")
  119. (synopsis "Tryton Client")
  120. (description
  121. "This package provides the Tryton GTK client.")
  122. (license license:gpl3+)))
  123. (define-public python-proteus
  124. (package
  125. (name "python-proteus")
  126. (version "6.0.2")
  127. (source
  128. (origin
  129. (method url-fetch)
  130. (uri (pypi-uri "proteus" version))
  131. (sha256
  132. (base32 "0qr7rir7ysxvy2kyfzp2d2kcw9qzq4vdkddbwswzgddxjpycksdh"))))
  133. (build-system python-build-system)
  134. ;; Tests require python-trytond-party which requires python-proteus.
  135. (arguments
  136. `(#:tests? #f))
  137. (propagated-inputs
  138. `(("python-dateutil" ,python-dateutil)))
  139. (home-page "http://www.tryton.org/")
  140. (synopsis "Library to access a Tryton server as a client")
  141. (description
  142. "This package provides a library to access Tryton server as a client.")
  143. (license license:lgpl3+)))
  144. (define (tryton-phases module . extra-arguments)
  145. "Return the phases for building and testing a Tryton module named MODULE.
  146. If present, pass EXTRA-ARGUMENTS to runtest as well."
  147. `(modify-phases %standard-phases
  148. (replace 'check
  149. (lambda* (#:key inputs outputs tests? #:allow-other-keys)
  150. (let ((runtest
  151. (string-append
  152. (assoc-ref inputs "trytond")
  153. "/lib/python"
  154. ,(version-major+minor (package-version python))
  155. "/site-packages/trytond/tests/run-tests.py")))
  156. (when tests?
  157. (add-installed-pythonpath inputs outputs)
  158. (invoke "python" runtest "-m" ,module ,@extra-arguments)))))))
  159. (define (tryton-arguments module . extra-arguments)
  160. "Like ’tryton-phases’, but directly return all arguments for
  161. the build system."
  162. `(#:phases ,(apply tryton-phases module extra-arguments)))
  163. ;;;
  164. ;;; Tryton modules - please sort alphabetically
  165. ;;;
  166. (define %standard-trytond-native-inputs
  167. ;; native-inputs required by most of the tryton module for running the test
  168. `(("python-dateutil" ,python-dateutil)
  169. ("python-genshi" ,python-genshi)
  170. ("python-lxml" ,python-lxml)
  171. ("python-magic" ,python-magic)
  172. ("python-passlib" ,python-passlib)
  173. ("python-polib" ,python-polib)
  174. ("python-proteus" ,python-proteus)
  175. ("python-relatorio" ,python-relatorio)
  176. ("python-sql" ,python-sql)
  177. ("python-werkzeug" ,python-werkzeug)
  178. ("python-wrapt" ,python-wrapt)))
  179. (define-public trytond-account
  180. (package
  181. (name "trytond-account")
  182. (version "6.0.3")
  183. (source
  184. (origin
  185. (method url-fetch)
  186. (uri (pypi-uri "trytond_account" version))
  187. (sha256
  188. (base32 "0j1mn8sd5n8rkwgfvcy9kf8s7s3qxvnilnc72i83ac573zj922xc"))))
  189. (build-system python-build-system)
  190. (arguments (tryton-arguments "account"))
  191. (native-inputs `(,@%standard-trytond-native-inputs))
  192. (propagated-inputs
  193. `(("python-simpleeval" ,python-simpleeval)
  194. ("trytond" ,trytond)
  195. ("trytond-company" ,trytond-company)
  196. ("trytond-currency" ,trytond-currency)
  197. ("trytond-party" ,trytond-party)))
  198. (home-page "https://www.tryton.org/")
  199. (synopsis "Tryton module for accounting")
  200. (description
  201. "This package provides a Tryton module that defines the fundamentals for
  202. most of accounting needs.")
  203. (license license:gpl3+)))
  204. (define-public python-trytond-account
  205. (deprecated-package "python-trytond-account" trytond-account))
  206. (define-public trytond-account-invoice
  207. (package
  208. (name "trytond-account-invoice")
  209. (version "6.0.3")
  210. (source
  211. (origin
  212. (method url-fetch)
  213. (uri (pypi-uri "trytond_account_invoice" version))
  214. (sha256
  215. (base32 "0r8zigb4qmv40kf835x8jd7049nnhk5g7g0aibvfd0y9p28lspnz"))))
  216. (build-system python-build-system)
  217. (arguments (tryton-arguments "account_invoice"))
  218. (native-inputs `(,@%standard-trytond-native-inputs))
  219. (propagated-inputs
  220. `(("trytond" ,trytond)
  221. ("trytond-account" ,trytond-account)
  222. ("trytond-account-product" ,trytond-account-product)
  223. ("trytond-company" ,trytond-company)
  224. ("trytond-currency" ,trytond-currency)
  225. ("trytond-party" ,trytond-party)
  226. ("trytond-product" ,trytond-product)))
  227. (home-page "https://www.tryton.org/")
  228. (synopsis "Tryton module for invoicing")
  229. (description
  230. "This package provides a Tryton module that adds the invoice, payment
  231. term.")
  232. (license license:gpl3+)))
  233. (define-public python-trytond-account-invoice
  234. (deprecated-package "python-trytond-account-invoice" trytond-account-invoice))
  235. (define-public trytond-account-invoice-stock
  236. (package
  237. (name "trytond-account-invoice-stock")
  238. (version "6.0.0")
  239. (source
  240. (origin
  241. (method url-fetch)
  242. (uri (pypi-uri "trytond_account_invoice_stock" version))
  243. (sha256
  244. (base32 "1228n6vsx0rdjsy3idvpyssa3n21nhvz9gqaacwa46c0hp2251bp"))))
  245. (build-system python-build-system)
  246. (arguments (tryton-arguments "account_invoice_stock"))
  247. (native-inputs `(,@%standard-trytond-native-inputs))
  248. (propagated-inputs
  249. `(("trytond" ,trytond)
  250. ("trytond-account-invoice" ,trytond-account-invoice)
  251. ("trytond-product" ,trytond-product)
  252. ("trytond-stock" ,trytond-stock)))
  253. (home-page "https://www.tryton.org/")
  254. (synopsis "Tryton module to link stock and invoice")
  255. (description
  256. "This package provides a Tryton module that adds link between invoice
  257. lines and stock moves. The unit price of the stock move is updated with the
  258. average price of the posted invoice lines that are linked to it.")
  259. (license license:gpl3+)))
  260. (define-public python-trytond-account-invoice-stock
  261. (deprecated-package
  262. "python-trytond-account-invoice-stock" trytond-account-invoice-stock))
  263. (define-public trytond-account-product
  264. (package
  265. (name "trytond-account-product")
  266. (version "6.0.2")
  267. (source
  268. (origin
  269. (method url-fetch)
  270. (uri (pypi-uri "trytond_account_product" version))
  271. (sha256
  272. (base32 "1z0dn1p22smzb4a9v451224wrpxcw94inl7jxkarc0q088gasn7d"))))
  273. (build-system python-build-system)
  274. (arguments (tryton-arguments "account_product"))
  275. (native-inputs `(,@%standard-trytond-native-inputs))
  276. (propagated-inputs
  277. `(("trytond" ,trytond)
  278. ("trytond-account" ,trytond-account)
  279. ("trytond-analytic-account" ,trytond-analytic-account)
  280. ("trytond-company" ,trytond-company)
  281. ("trytond-product" ,trytond-product)))
  282. (home-page "https://www.tryton.org/")
  283. (synopsis "Tryton module to add accounting on product")
  284. (description
  285. "This package provides a Tryton module that adds accounting on product
  286. and category.")
  287. (license license:gpl3+)))
  288. (define-public python-trytond-account-product
  289. (deprecated-package "python-trytond-account-product" trytond-account-product))
  290. (define-public trytond-analytic-account
  291. (package
  292. (name "trytond-analytic-account")
  293. (version "6.0.2")
  294. (source
  295. (origin
  296. (method url-fetch)
  297. (uri (pypi-uri "trytond_analytic_account" version))
  298. (sha256
  299. (base32 "09j9xz41n5hk3j7w63xbw1asd3p00prqvl652qcm9x1nrlmqiw3r"))))
  300. (build-system python-build-system)
  301. (arguments (tryton-arguments "analytic_account"))
  302. (native-inputs `(,@%standard-trytond-native-inputs))
  303. (propagated-inputs
  304. `(("trytond" ,trytond)
  305. ("trytond-account" ,trytond-account)
  306. ("trytond-company" ,trytond-company)
  307. ("trytond-currency" ,trytond-currency)
  308. ("trytond-party" ,trytond-party)))
  309. (home-page "https://www.tryton.org/")
  310. (synopsis "Tryton module for analytic accounting")
  311. (description
  312. "This package provides a Tryton module that adds the fundamentals
  313. required to analyse accounting using multiple different axes.")
  314. (license license:gpl3+)))
  315. (define-public python-trytond-analytic-account
  316. (deprecated-package
  317. "python-trytond-analytic-account" trytond-analytic-account))
  318. (define-public trytond-company
  319. (package
  320. (name "trytond-company")
  321. (version "6.0.3")
  322. (source
  323. (origin
  324. (method url-fetch)
  325. (uri (pypi-uri "trytond_company" version))
  326. (sha256
  327. (base32 "1q4qdyg32dn00pn3pj2yjl3jhxaqpv7a1cv5s5c95cpy5p46p02n"))))
  328. (build-system python-build-system)
  329. (arguments (tryton-arguments "company"))
  330. (native-inputs `(,@%standard-trytond-native-inputs))
  331. (propagated-inputs
  332. `(("trytond" ,trytond)
  333. ("trytond-currency" ,trytond-currency)
  334. ("trytond-party" ,trytond-party)))
  335. (home-page "https://www.tryton.org/")
  336. (synopsis "Tryton module with companies and employees")
  337. (description
  338. "This package provides a Tryton module that defines the concepts of
  339. company and employee and extend the user model.")
  340. (license license:gpl3+)))
  341. (define-public python-trytond-company
  342. (deprecated-package "python-trytond-company" trytond-company))
  343. (define-public trytond-country
  344. (package
  345. (name "trytond-country")
  346. (version "6.0.1")
  347. (source
  348. (origin
  349. (method url-fetch)
  350. (uri (pypi-uri "trytond_country" version))
  351. (sha256
  352. (base32 "1ksinysac7p0k8avsz8xqzfkmm21s6i93qyrsma5h4y5477cwmw7"))))
  353. (build-system python-build-system)
  354. ;; Doctest contains one test that requires internet access.
  355. (arguments (tryton-arguments "country" "--no-doctest"))
  356. (native-inputs `(,@%standard-trytond-native-inputs))
  357. (propagated-inputs
  358. `(("python-pycountry" ,python-pycountry)
  359. ("trytond" ,trytond)))
  360. (home-page "http://www.tryton.org/")
  361. (synopsis "Tryton module with countries")
  362. (description
  363. "This package provides a Tryton module with countries.")
  364. (license license:gpl3+)))
  365. (define-public python-trytond-country
  366. (deprecated-package "python-trytond-country" trytond-country))
  367. (define-public trytond-currency
  368. (package
  369. (name "trytond-currency")
  370. (version "6.0.1")
  371. (source
  372. (origin
  373. (method url-fetch)
  374. (uri (pypi-uri "trytond_currency" version))
  375. (sha256
  376. (base32 "0fs2wvhgvc0l4yzs5m9l8z4lbzazr42hgz0859malhnlp1sya2kq"))))
  377. (build-system python-build-system)
  378. ;; Doctest 'scenario_currency_rate_update.rst' fails.
  379. (arguments (tryton-arguments "currency" "--no-doctest"))
  380. (native-inputs
  381. `(,@%standard-trytond-native-inputs
  382. ("python-forex-python" ,python-forex-python)
  383. ("python-pycountry" ,python-pycountry)))
  384. (propagated-inputs
  385. `(("python-sql" ,python-sql)
  386. ("trytond" ,trytond)))
  387. (home-page "https://www.tryton.org/")
  388. (synopsis "Tryton module with currencies")
  389. (description
  390. "This package provides a Tryton module that defines the concepts of
  391. currency and rate.")
  392. (license license:gpl3+)))
  393. (define-public python-trytond-currency
  394. (deprecated-package "python-trytond-currency" trytond-currency))
  395. (define-public trytond-party
  396. (package
  397. (name "trytond-party")
  398. (version "6.0.2")
  399. (source
  400. (origin
  401. (method url-fetch)
  402. (uri (pypi-uri "trytond_party" version))
  403. (sha256
  404. (base32 "0aikzpr0ambc98v76dl6xqa42b08dy3b011y33lvxjp5mcha3f7y"))))
  405. (build-system python-build-system)
  406. ;; Doctest 'scenario_party_phone_number.rst' fails.
  407. (arguments (tryton-arguments "party" "--no-doctest"))
  408. (native-inputs `(,@%standard-trytond-native-inputs))
  409. (propagated-inputs
  410. `(("python-stdnum" ,python-stdnum)
  411. ("trytond" ,trytond)
  412. ("trytond-country" ,trytond-country)))
  413. (home-page "https://www.tryton.org/")
  414. (synopsis "Tryton module for parties and addresses")
  415. (description
  416. "This package provides a Tryton module for (counter)parties and
  417. addresses.")
  418. (license license:gpl3+)))
  419. (define-public python-trytond-party
  420. (deprecated-package "python-trytond-party" trytond-party))
  421. (define-public trytond-product
  422. (package
  423. (name "trytond-product")
  424. (version "6.0.1")
  425. (source
  426. (origin
  427. (method url-fetch)
  428. (uri (pypi-uri "trytond_product" version))
  429. (sha256
  430. (base32 "1xvvqxkvzyqy6fn2sj5h3zj0g17igzwx6s18sxkdz72vqz6kpv0l"))))
  431. (build-system python-build-system)
  432. (arguments (tryton-arguments "product"))
  433. (native-inputs `(,@%standard-trytond-native-inputs))
  434. (propagated-inputs
  435. `(("python-stdnum" ,python-stdnum)
  436. ("trytond" ,trytond)
  437. ("trytond-company" ,trytond-company)))
  438. (home-page "https://www.tryton.org/")
  439. (synopsis "Tryton module with products")
  440. (description
  441. "This package provides a Tryton module that defines two concepts: Product
  442. Template and Product.")
  443. (license license:gpl3+)))
  444. (define-public python-trytond-product
  445. (deprecated-package "python-trytond-product" trytond-product))
  446. (define-public trytond-purchase
  447. (package
  448. (name "trytond-purchase")
  449. (version "6.0.2")
  450. (source
  451. (origin
  452. (method url-fetch)
  453. (uri (pypi-uri "trytond_purchase" version))
  454. (sha256
  455. (base32 "12drjw30ik3alckn6xrny4814vzi3ysh17wgiawiy9319yahsvay"))))
  456. (build-system python-build-system)
  457. (arguments (tryton-arguments "purchase"))
  458. (native-inputs `(,@%standard-trytond-native-inputs))
  459. (propagated-inputs
  460. `(("trytond" ,trytond)
  461. ("trytond-account" ,trytond-account)
  462. ("trytond-account-invoice" ,trytond-account-invoice)
  463. ("trytond-account-invoice-stock" ,trytond-account-invoice-stock)
  464. ("trytond-account-product" ,trytond-account-product)
  465. ("trytond-company" ,trytond-company)
  466. ("trytond-currency" ,trytond-currency)
  467. ("trytond-party" ,trytond-party)
  468. ("trytond-product" ,trytond-product)
  469. ("trytond-stock" ,trytond-stock)))
  470. (home-page "https://www.tryton.org/")
  471. (synopsis "Tryton module for purchase")
  472. (description
  473. "This package provides a Tryton module that defines the Purchase model.")
  474. (license license:gpl3+)))
  475. (define-public python-trytond-purchase
  476. (deprecated-package "python-trytond-purchase" trytond-purchase))
  477. (define-public trytond-purchase-request
  478. (package
  479. (name "trytond-purchase-request")
  480. (version "6.0.0")
  481. (source
  482. (origin
  483. (method url-fetch)
  484. (uri (pypi-uri "trytond_purchase_request" version))
  485. (sha256
  486. (base32 "0yhf3lh5b24qpk80r5pbmmswf5757bxa0s7ckl40vf6lkjkccv5i"))))
  487. (build-system python-build-system)
  488. ;; Doctest 'scenario_purchase_request.rst' fails.
  489. (arguments (tryton-arguments "purchase_request" "--no-doctest"))
  490. (native-inputs `(,@%standard-trytond-native-inputs))
  491. (propagated-inputs
  492. `(("trytond" ,trytond)
  493. ("trytond-product" ,trytond-product)
  494. ("trytond-purchase" ,trytond-purchase)))
  495. (home-page "https://www.tryton.org/")
  496. (synopsis "Tryton module for purchase requests")
  497. (description
  498. "This package provides a Tryton module that introduces the concept of
  499. Purchase Requests which are central points to collect purchase requests
  500. generated by other process from Tryton.")
  501. (license license:gpl3+)))
  502. (define-public python-trytond-purchase-request
  503. (deprecated-package
  504. "python-trytond-purchase-request" trytond-purchase-request))
  505. (define-public trytond-stock
  506. (package
  507. (name "trytond-stock")
  508. (version "6.0.6")
  509. (source
  510. (origin
  511. (method url-fetch)
  512. (uri (pypi-uri "trytond_stock" version))
  513. (sha256
  514. (base32 "1v6pvkwj6vhjqbz2zn0609kb7kx4g0dsn1xhvax4z2dqigh7ywpx"))))
  515. (build-system python-build-system)
  516. (arguments (tryton-arguments "stock"))
  517. (native-inputs `(,@%standard-trytond-native-inputs))
  518. (propagated-inputs
  519. `(("python-simpleeval" ,python-simpleeval)
  520. ("trytond" ,trytond)
  521. ("trytond-company" ,trytond-company)
  522. ("trytond-currency" ,trytond-currency)
  523. ("trytond-party" ,trytond-party)
  524. ("trytond-product" ,trytond-product)))
  525. (home-page "https://www.tryton.org/")
  526. (synopsis "Tryton module for stock and inventory")
  527. (description
  528. "This package provides a Tryton module that defines the fundamentals for
  529. all stock management situations: Locations where products are stored, moves
  530. between these locations, shipments for product arrivals and departures and
  531. inventory to control and update stock levels.")
  532. (license license:gpl3+)))
  533. (define-public python-trytond-stock
  534. (deprecated-package "python-trytond-stock" trytond-stock))
  535. (define-public trytond-stock-lot
  536. (package
  537. (name "trytond-stock-lot")
  538. (version "6.0.0")
  539. (source
  540. (origin
  541. (method url-fetch)
  542. (uri (pypi-uri "trytond_stock_lot" version))
  543. (sha256
  544. (base32 "18cwrvnrzjk1wb765gr6hp3plpdpwz1a7cwimjhxi47iw7w5c84g"))))
  545. (build-system python-build-system)
  546. (arguments (tryton-arguments "stock_lot"))
  547. (native-inputs `(,@%standard-trytond-native-inputs))
  548. (propagated-inputs
  549. `(("trytond" ,trytond)
  550. ("trytond-product" ,trytond-product)
  551. ("trytond-stock" ,trytond-stock)))
  552. (home-page "https://www.tryton.org/")
  553. (synopsis "Tryton module for lot of products")
  554. (description
  555. "This package provides a Tryton module that defines lot of products.")
  556. (license license:gpl3+)))
  557. (define-public python-trytond-stock-lot
  558. (deprecated-package "python-trytond-stock-lot" trytond-stock-lot))
  559. (define-public trytond-stock-supply
  560. (package
  561. (name "trytond-stock-supply")
  562. (version "6.0.1")
  563. (source
  564. (origin
  565. (method url-fetch)
  566. (uri (pypi-uri "trytond_stock_supply" version))
  567. (sha256
  568. (base32 "1p5l3yjjy6l25kk9xnhbl691l3v8gfg9fhc87jc6qszhxlqxk730"))))
  569. (build-system python-build-system)
  570. (arguments (tryton-arguments "stock_supply"))
  571. (native-inputs `(,@%standard-trytond-native-inputs))
  572. (propagated-inputs
  573. `(("trytond" ,trytond)
  574. ("trytond-account" ,trytond-account)
  575. ("trytond-party" ,trytond-party)
  576. ("trytond-product" ,trytond-product)
  577. ("trytond-purchase" ,trytond-purchase)
  578. ("trytond-purchase-request" ,trytond-purchase-request)
  579. ("trytond-stock" ,trytond-stock)))
  580. (home-page "https://www.tryton.org/")
  581. (synopsis "Tryton module for stock supply")
  582. (description
  583. "This package provides a Tryton module that adds automatic supply
  584. mechanisms and introduces the concepts of order point.")
  585. (license license:gpl3+)))
  586. (define-public python-trytond-stock-supply
  587. (deprecated-package "python-trytond-stock-supply" trytond-stock-supply))