tbb.scm 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
  3. ;;; Copyright © 2016 Nikita <nikita@n0.is>
  4. ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages tbb)
  22. #:use-module (guix packages)
  23. #:use-module (guix licenses)
  24. #:use-module (guix git-download)
  25. #:use-module (guix utils)
  26. #:use-module (guix build-system cmake)
  27. #:use-module (gnu packages))
  28. (define-public tbb
  29. (package
  30. (name "tbb")
  31. (version "2021.3.0")
  32. (source (origin
  33. (method git-fetch)
  34. (uri (git-reference
  35. (url "https://github.com/oneapi-src/oneTBB")
  36. (commit (string-append "v" version))))
  37. (file-name (git-file-name name version))
  38. (sha256
  39. (base32
  40. "1bz039my3ma87f24ngcsqs16f8jlpdgaqg01ab4g60nfqbrz1lkq"))))
  41. (build-system cmake-build-system)
  42. (arguments
  43. `(#:configure-flags '("-DTBB_STRICT=OFF"))) ;; Don't fail on warnings
  44. (home-page "https://www.threadingbuildingblocks.org")
  45. (synopsis "C++ library for parallel programming")
  46. (description
  47. "Threading Building Blocks (TBB) is a C++ runtime library that abstracts
  48. the low-level threading details necessary for optimal multi-core performance.
  49. It uses common C++ templates and coding style to eliminate tedious threading
  50. implementation work. It provides parallel loop constructs, asynchronous
  51. tasks, synchronization primitives, atomic operations, and more.")
  52. (license asl2.0)))