scribus.scm 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015, 2018 Ricardo Wurmus <rekado@elephly.net>
  3. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2017, 2018, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
  5. ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
  6. ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
  7. ;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  8. ;;;
  9. ;;; This file is part of GNU Guix.
  10. ;;;
  11. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  12. ;;; under the terms of the GNU General Public License as published by
  13. ;;; the Free Software Foundation; either version 3 of the License, or (at
  14. ;;; your option) any later version.
  15. ;;;
  16. ;;; GNU Guix is distributed in the hope that it will be useful, but
  17. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  18. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  19. ;;; GNU General Public License for more details.
  20. ;;;
  21. ;;; You should have received a copy of the GNU General Public License
  22. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  23. (define-module (gnu packages scribus)
  24. #:use-module (guix packages)
  25. #:use-module (guix download)
  26. #:use-module (guix utils)
  27. #:use-module ((guix licenses) #:prefix license:)
  28. #:use-module (guix build-system cmake)
  29. #:use-module (gnu packages)
  30. #:use-module (gnu packages boost)
  31. #:use-module (gnu packages compression)
  32. #:use-module (gnu packages cups)
  33. #:use-module (gnu packages fontutils)
  34. #:use-module (gnu packages ghostscript)
  35. #:use-module (gnu packages gtk)
  36. #:use-module (gnu packages icu4c)
  37. #:use-module (gnu packages image)
  38. #:use-module (gnu packages imagemagick)
  39. #:use-module (gnu packages libreoffice)
  40. #:use-module (gnu packages linux)
  41. #:use-module (gnu packages pdf)
  42. #:use-module (gnu packages pkg-config)
  43. #:use-module (gnu packages python)
  44. #:use-module (gnu packages qt)
  45. #:use-module (gnu packages tls)
  46. #:use-module (gnu packages xml))
  47. (define-public scribus
  48. (package
  49. (name "scribus")
  50. (version "1.5.7")
  51. (source
  52. (origin
  53. (method url-fetch)
  54. (uri (string-append "mirror://sourceforge/scribus/scribus-devel/"
  55. version "/scribus-" version ".tar.xz"))
  56. (sha256
  57. (base32 "1kpq4vc95hj3w8l205kh0pmdlisi4v1gilz0sf8n39y7ryr1d0ri"))))
  58. (build-system cmake-build-system)
  59. (arguments
  60. `(#:tests? #f ;no test target
  61. #:configure-flags
  62. '("-DWANT_GRAPHICSMAGICK=1")))
  63. (inputs
  64. `(("boost" ,boost)
  65. ("cairo" ,cairo)
  66. ("cups" ,cups)
  67. ("fontconfig" ,fontconfig)
  68. ("freetype" ,freetype)
  69. ("graphicsmagick" ,graphicsmagick)
  70. ("harfbuzz" ,harfbuzz)
  71. ("hunspell" ,hunspell)
  72. ("icu4c" ,icu4c)
  73. ("lcms" ,lcms)
  74. ("libcdr" ,libcdr)
  75. ("libfreehand" ,libfreehand)
  76. ("libjpeg" ,libjpeg-turbo)
  77. ("libmspub" ,libmspub)
  78. ("libpagemaker" ,libpagemaker)
  79. ("librevenge" ,librevenge)
  80. ("libtiff" ,libtiff)
  81. ("libvisio" ,libvisio)
  82. ("libxml2" ,libxml2)
  83. ("libzmf" ,libzmf)
  84. ("openssl" ,openssl)
  85. ("podofo" ,podofo)
  86. ("poppler" ,poppler)
  87. ("python" ,python) ; need Python library
  88. ("qtbase" ,qtbase-5)
  89. ("qtdeclarative" ,qtdeclarative)
  90. ("zlib" ,zlib)))
  91. (native-inputs
  92. `(("pkg-config" ,pkg-config)
  93. ("qttools" ,qttools)
  94. ("util-linux" ,util-linux)))
  95. (home-page "https://www.scribus.net")
  96. (synopsis "Desktop publishing and page layout program")
  97. (description
  98. "Scribus is a @dfn{desktop publishing} (DTP) application and can
  99. be used for many tasks; from brochure design to newspapers, magazines,
  100. newsletters and posters to technical documentation. Scribus supports
  101. professional DTP features, such as CMYK color and a color management
  102. system to soft proof images for high quality color printing, flexible
  103. PDF creation options, Encapsulated PostScript import/export and
  104. creation of four color separations, import of EPS/PS and SVG as native
  105. vector graphics, Unicode text including right to left scripts such as
  106. Arabic and Hebrew via FreeType.")
  107. (license license:gpl2+)))