rush.scm 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages rush)
  19. #:use-module (guix packages)
  20. #:use-module (guix download)
  21. #:use-module (guix build-system gnu)
  22. #:use-module (guix licenses)
  23. #:use-module (gnu packages))
  24. (define-public rush
  25. (package
  26. (name "rush")
  27. (version "2.1")
  28. (source (origin
  29. (method url-fetch)
  30. (uri (string-append "mirror://gnu/rush/rush-"
  31. version ".tar.gz"))
  32. (sha256
  33. (base32
  34. "17i4mggr3rnfz0xbhqvd86jqva40c535fhlwkb2l4hjcbpg8blcf"))))
  35. (build-system gnu-build-system)
  36. (home-page "https://www.gnu.org/software/rush/")
  37. (synopsis "Restricted user (login) shell")
  38. (description
  39. "GNU Rush is a restricted user shell, for systems on which users are to
  40. be provided with only limited functionality or resources. Administrators set
  41. user rights via a configuration file which can be used to limit, for example,
  42. the commands that can be executed, CPU time, or virtual memory usage.")
  43. (license gpl3+)))