rcm.scm 2.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
  3. ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages rcm)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu)
  23. #:use-module (guix licenses)
  24. #:use-module (gnu packages python-xyz)
  25. #:use-module (gnu packages perl))
  26. (define-public rcm
  27. (package
  28. (name "rcm")
  29. (version "1.3.4")
  30. (source (origin
  31. (method url-fetch)
  32. (uri (string-append "https://thoughtbot.github.io/rcm/dist/rcm-"
  33. version ".tar.gz"))
  34. (sha256
  35. (base32 "0jn2crdqcna0fyg7w7x1mcyjblzykd3lh4vdxhsd5x4w8hvsw4cv"))))
  36. (build-system gnu-build-system)
  37. (arguments '(#:phases
  38. (modify-phases %standard-phases
  39. (add-after 'patch-source-shebangs 'patch-tests
  40. (lambda _
  41. (substitute* '("test/rcrc-tilde.t"
  42. "test/rcdn-hooks-run-in-order.t"
  43. "test/rcup-hooks-run-in-order.t")
  44. (("/bin/sh") (which "sh")))
  45. (substitute* "test/rcup-hooks.t"
  46. (("/usr/bin/env") (which "env")))
  47. #t)))
  48. #:parallel-tests? #f))
  49. (native-inputs `(("perl" ,perl)
  50. ("python-cram" ,python-cram)))
  51. (synopsis "Management suite for dotfiles")
  52. (description "The rcm suite of tools is for managing dotfiles directories. This is
  53. a directory containing all the @code{.*rc} files in your home directory
  54. (@code{.zshrc}, @code{.vimrc}, and so on). These files have gone by many
  55. names in history, such as “rc files” because they typically end in rc
  56. or “dotfiles” because they begin with a period. This suite is useful
  57. for committing your rc files to a central repository to share, but it also
  58. scales to a more complex situation such as multiple source directories
  59. shared between computers with some host-specific or task-specific files.")
  60. (license bsd-3)
  61. (home-page "https://github.com/thoughtbot/rcm")))