pure.scm 2.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
  3. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages pure)
  20. #:use-module ((guix licenses) #:prefix license:)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix git-download)
  24. #:use-module (guix utils)
  25. #:use-module (guix build-system gnu)
  26. #:use-module (guix gexp)
  27. #:use-module (gnu packages)
  28. #:use-module (gnu packages llvm)
  29. #:use-module (gnu packages multiprecision))
  30. (define-public pure
  31. (package
  32. (name "pure")
  33. (version "0.68")
  34. (source
  35. (origin
  36. (method url-fetch)
  37. (uri (string-append "https://github.com/agraef/pure-lang/releases/"
  38. "download/pure-" version "/"
  39. "pure-" version ".tar.gz"))
  40. (sha256
  41. (base32
  42. "0px6x5ivcdbbp2pz5n1r1cwg1syadklhjw8piqhl63n91i4r7iyb"))))
  43. (build-system gnu-build-system)
  44. (arguments
  45. `(#:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
  46. (assoc-ref %outputs "out")
  47. "/lib"))
  48. #:phases
  49. (modify-phases %standard-phases
  50. (add-after 'unpack 'patch-llvm-lookup
  51. (lambda _
  52. (substitute* "configure"
  53. (("-lLLVM-[$][{]llvm_version[}]")
  54. "`$LLVMCONF --libs`"))
  55. #t)))))
  56. (inputs
  57. `(("gmp" ,gmp)
  58. ("llvm" ,llvm-3.5)
  59. ("mpfr" ,mpfr)))
  60. (home-page "https://agraef.github.io/pure-lang/")
  61. (synopsis "Pure programming Language")
  62. (description "@code{pure} is a programming language based on term
  63. rewriting. It offers equational definitions with pattern matching,
  64. full symbolic rewriting capabilities, dynamic typing, eager and lazy
  65. evaluation, lexical closures, built-in list and matrix support and
  66. a C interface.")
  67. (license license:gpl3+)))