pumpio.scm 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 David Thompson <davet@gnu.org>
  3. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages pumpio)
  21. #:use-module (guix licenses)
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix git-download)
  25. #:use-module (guix build-system gnu)
  26. #:use-module (gnu packages aspell)
  27. #:use-module (gnu packages qt)
  28. #:use-module (gnu packages web))
  29. (define-public pumpa
  30. (package
  31. (name "pumpa")
  32. (version "0.9.3")
  33. (source (origin
  34. (method git-fetch) ; no source tarballs
  35. (uri (git-reference
  36. (url "git://pumpa.branchable.com/")
  37. (commit (string-append "v" version))))
  38. (sha256
  39. (base32
  40. "14072vis539zjgryjr5a77j2cprxii5znyg3p01qbb11lijk9nj7"))
  41. (file-name (string-append name "-" version "-checkout"))))
  42. (build-system gnu-build-system)
  43. (arguments
  44. '(#:phases
  45. (modify-phases %standard-phases
  46. (replace 'configure
  47. (lambda* (#:key inputs outputs #:allow-other-keys)
  48. ;; Fix dependency tests.
  49. (substitute* "pumpa.pro"
  50. (("/usr/include/tidy\\.h")
  51. (search-input-file inputs "/include/tidy.h"))
  52. (("/usr/include/aspell.h")
  53. (search-input-file inputs "/include/aspell.h")))
  54. ;; Run qmake with proper installation prefix.
  55. (let ((prefix (string-append "PREFIX="
  56. (assoc-ref outputs "out"))))
  57. (invoke "qmake" prefix))
  58. #t)))))
  59. (inputs
  60. `(("aspell" ,aspell)
  61. ("qtbase" ,qtbase-5)
  62. ("tidy" ,tidy)))
  63. (synopsis "Qt-based pump.io client")
  64. (description "Pumpa is a simple pump.io client written in C++ and Qt.")
  65. (home-page "https://pumpa.branchable.com/")
  66. (license gpl3+)))