printers.scm 2.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages printers)
  20. #:use-module (guix packages)
  21. #:use-module (guix git-download)
  22. #:use-module (guix build-system gnu)
  23. #:use-module ((guix licenses) #:prefix license:)
  24. #:use-module (gnu packages libusb)
  25. #:use-module (gnu packages pkg-config)
  26. #:use-module (gnu packages qt))
  27. ;; This is a module for packages related to printer-like devices, but not
  28. ;; related to CUPS.
  29. (define-public robocut
  30. (package
  31. (name "robocut")
  32. (version "1.0.11")
  33. (source
  34. (origin
  35. (method git-fetch)
  36. (uri (git-reference
  37. (url "https://github.com/Timmmm/robocut")
  38. (commit (string-append "v" version))))
  39. (file-name (git-file-name name version))
  40. (sha256
  41. (base32 "0dp9cssyik63yvkk35s51v94a873x751iqg93qzd8dpqkmz5z8gn"))))
  42. (build-system gnu-build-system)
  43. (arguments
  44. '(#:phases (modify-phases %standard-phases
  45. (replace 'configure
  46. (lambda* (#:key outputs #:allow-other-keys)
  47. (let ((out (assoc-ref outputs "out")))
  48. (substitute* "Robocut.pro"
  49. (("/usr/")
  50. (string-append out "/")))
  51. (invoke "qmake"
  52. (string-append "PREFIX=" out))
  53. #t))))))
  54. (inputs
  55. `(("libusb" ,libusb)
  56. ("qt" ,qtbase-5)
  57. ("qtsvg" ,qtsvg)))
  58. (native-inputs
  59. `(("pkg-config" ,pkg-config)
  60. ("qmake" ,qtbase-5)))
  61. (synopsis "Graphical program to drive plotting cutters")
  62. (description
  63. "Robocut is a simple graphical program that allows you to cut graphics
  64. with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
  65. (home-page "http://robocut.org")
  66. (license license:gpl3+)))