nickle.scm 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016 Nikita <nikita@n0.is>
  3. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages nickle)
  20. #:use-module (gnu packages)
  21. #:use-module (gnu packages readline)
  22. #:use-module (guix build-system gnu)
  23. #:use-module (guix download)
  24. #:use-module ((guix licenses) #:prefix license:)
  25. #:use-module (guix packages))
  26. (define-public nickle
  27. (package
  28. (name "nickle")
  29. (version "2.82")
  30. (source (origin
  31. (method url-fetch)
  32. (uri (string-append "https://nickle.org/release/nickle-"
  33. version ".tar.gz"))
  34. (sha256
  35. (base32
  36. "0jy96z01qbrnmsrywn5mfa14615qdix6b8520qd65c6yjyrk8gs0"))))
  37. (build-system gnu-build-system)
  38. (native-inputs
  39. `(("readline" ,readline)))
  40. (synopsis "Numeric oriented programming language")
  41. (description
  42. "Nickle is a programming language based prototyping environment with
  43. powerful programming and scripting capabilities. Nickle supports a variety of
  44. datatypes, especially arbitrary precision numbers. The programming language
  45. vaguely resembles C. Some things in C which do not translate easily are
  46. different, some design choices have been made differently, and a very few
  47. features are simply missing. Nickle provides the functionality of Unix bc, dc
  48. and expr in a different form. It is also an ideal environment for prototyping
  49. complex algorithms. Nickle's scripting capabilities make it a replacement for
  50. spreadsheets in some applications, and its numeric features complement the
  51. limited numeric functionality of text-oriented languages such as AWK and Perl.")
  52. (home-page "https://nickle.org/")
  53. (license license:expat)))