moreutils.scm 3.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
  3. ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2016–2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages moreutils)
  21. #:use-module ((guix licenses) #:prefix l:)
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (gnu packages perl)
  26. #:use-module (gnu packages xml)
  27. #:use-module (gnu packages docbook))
  28. (define-public moreutils
  29. (package
  30. (name "moreutils")
  31. (version "0.65")
  32. (source
  33. (origin
  34. (method url-fetch)
  35. (uri (string-append
  36. "https://git.joeyh.name/index.cgi/moreutils.git/snapshot/"
  37. name "-" version ".tar.gz"))
  38. (sha256
  39. (base32 "10c8b4bwnli4gxwvgmgkc5kin1ksrxsnxmigs7y4rrh4aaszdjb0"))))
  40. (build-system gnu-build-system)
  41. ;; For building the manual pages.
  42. (native-inputs
  43. `(("docbook-xml" ,docbook-xml-4.4)
  44. ("docbook-xsl" ,docbook-xsl)
  45. ("libxml2" ,libxml2)
  46. ("libxslt" ,libxslt)))
  47. (inputs
  48. `(("perl" ,perl)
  49. ("perl-timedate" ,perl-timedate)
  50. ("perl-time-duration" ,perl-time-duration)))
  51. (arguments
  52. `(#:phases
  53. (modify-phases %standard-phases
  54. (add-after 'install 'wrap-program
  55. (lambda* (#:key outputs #:allow-other-keys)
  56. (let* ((out (assoc-ref outputs "out")))
  57. (wrap-program
  58. (string-append out "/bin/ts")
  59. `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
  60. #t))
  61. (delete 'configure)) ; no configure script
  62. #:make-flags
  63. (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
  64. (string-append "DOCBOOKXSL="
  65. (assoc-ref %build-inputs "docbook-xsl") "/xml/xsl/"
  66. ,(package-name docbook-xsl) "-"
  67. ,(package-version docbook-xsl))
  68. "CC=gcc")))
  69. (home-page "https://joeyh.name/code/moreutils/")
  70. (synopsis "Miscellaneous general-purpose command-line tools")
  71. (description
  72. "Moreutils is a collection of general-purpose command-line tools to
  73. augment the traditional Unix toolbox.")
  74. (license l:gpl2+)))