moe.scm 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
  3. ;;; Copyright © 2016, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages moe)
  20. #:use-module ((guix licenses) #:select (gpl2+))
  21. #:use-module (gnu packages ncurses)
  22. #:use-module (gnu packages compression)
  23. #:use-module (guix packages)
  24. #:use-module (guix download)
  25. #:use-module (guix build-system gnu))
  26. (define-public moe
  27. (package
  28. (name "moe")
  29. (version "1.11")
  30. (source
  31. (origin
  32. (method url-fetch)
  33. (uri (string-append "mirror://gnu/moe/moe-"
  34. version ".tar.lz"))
  35. (sha256
  36. (base32
  37. "1yg2ln2mm6gzv61cxnv60dw1cr5bl2dhkjy685jrd3aabb7wpyqf"))))
  38. (build-system gnu-build-system)
  39. (native-inputs `(("lzip" ,lzip)))
  40. (inputs `(("ncurses" ,ncurses)))
  41. (home-page "https://www.gnu.org/software/moe/moe.html")
  42. (synopsis "Modeless, multiple-buffer, user-friendly 8-bit text editor")
  43. (description
  44. "GNU Moe is a powerful-but-simple-to-use text editor. It works in a
  45. modeless manner, and features an intuitive set of key-bindings that
  46. assign a degree of severity to each key; for example, key
  47. combinations with the Alt key are for harmless commands like cursor
  48. movements while combinations with the Control key are for commands
  49. that will modify the text. Moe features multiple windows, unlimited
  50. undo/redo, unlimited line length, global search and replace, and
  51. more.")
  52. (license gpl2+)))