microcom.scm 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
  3. ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages microcom)
  20. #:use-module (guix packages)
  21. #:use-module (guix licenses)
  22. #:use-module (guix git-download)
  23. #:use-module (guix download)
  24. #:use-module (gnu packages autotools)
  25. #:use-module (gnu packages readline)
  26. #:use-module (guix build-system gnu))
  27. (define-public microcom
  28. (package
  29. (name "microcom")
  30. (version "2017.03.0")
  31. (source (origin
  32. (method git-fetch)
  33. (uri (git-reference
  34. (url "https://git.pengutronix.de/git/tools/microcom.git")
  35. (commit (string-append "v" version))))
  36. (file-name (git-file-name name version))
  37. (sha256
  38. (base32 "060q42lf1bx403smxm97cz8r4ksq942mq5z708vavy6syv3fkap4"))))
  39. (build-system gnu-build-system)
  40. (inputs `(("readline" ,readline)))
  41. (native-inputs `(("automake" ,automake)
  42. ("autoconf" ,autoconf)))
  43. (home-page "https://git.pengutronix.de/?p=tools/microcom.git")
  44. (synopsis "Minimalistic serial line terminal program")
  45. (description "Microcom is a minimalistic terminal program for accessing
  46. devices via a serial connection. It features connection via RS232 serial
  47. interfaces (including setting of transfer rates) as well as in @code{telnetmode}
  48. as specified in rfc2217 and a (Linux specific) CAN mode.")
  49. (license gpl2+)))