medical.scm 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
  3. ;;; Copyright © 2017 Quiliro <quiliro@fsfla.org>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages medical)
  20. #:use-module (guix build-system python)
  21. #:use-module (guix download)
  22. #:use-module (guix licenses)
  23. #:use-module (guix packages)
  24. #:use-module (gnu packages databases)
  25. #:use-module (gnu packages python-xyz)
  26. #:use-module (gnu packages qt))
  27. (define-public openmolar-1
  28. (package
  29. (name "openmolar")
  30. (version "1.0.15-gd81f9e5")
  31. (source (origin
  32. (method url-fetch)
  33. (uri (string-append
  34. "https://static.openmolar.com/om1/releases/openmolar-"
  35. version ".tar.gz"))
  36. (sha256
  37. (base32
  38. "1cfdzfbi6wslw7k0dc6ad6xrgs75iwsl91cg73w4myswaqqkfk3z"))))
  39. (build-system python-build-system)
  40. (arguments
  41. `(#:use-setuptools? #f
  42. #:phases
  43. (modify-phases %standard-phases
  44. (add-after 'unpack 'patch-/usr
  45. (lambda* (#:key outputs #:allow-other-keys)
  46. (substitute* "setup.py"
  47. (("/usr") (assoc-ref outputs "out")))
  48. #t)))))
  49. (inputs
  50. `(("python-pyqt+qscintilla" ,python-pyqt+qscintilla)
  51. ("python-mysqlclient" ,python-mysqlclient)
  52. ("qscintilla" ,qscintilla)))
  53. (home-page "https://openmolar.com/om1")
  54. (synopsis "Dental practice management software")
  55. (description "Openmolar is a dental practice management suite. Its
  56. functionality includes appointments, patient records, treatment planning,
  57. billing etc. It is a full featured, reliable and thoroughly tested
  58. application and has been translated into many languages.")
  59. (license gpl3+)))