marst.scm 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages marst)
  19. #:use-module (guix packages)
  20. #:use-module (guix licenses)
  21. #:use-module (guix download)
  22. #:use-module (gnu packages compression)
  23. #:use-module (guix build-system gnu))
  24. (define-public marst
  25. (package
  26. (name "marst")
  27. (version "2.7")
  28. (source
  29. (origin
  30. (method url-fetch)
  31. (uri (string-append
  32. "mirror://gnu/" name "/" name "-" version
  33. ".tar.gz"))
  34. (sha256
  35. (base32 "0l6swjy8fjrqw89ghc1vvakg21jmpfkpsw92yssrzkg3rg8vkrry"))))
  36. (build-system gnu-build-system)
  37. (home-page "https://www.gnu.org/software/marst/")
  38. (synopsis "Algol-to-C translator")
  39. (description
  40. "GNU MARST is an Algol-to-C translator. The package consists of the
  41. translator itself, a library that contains the necessary Algol 60 procedures,
  42. and a converter that converts existing Algol 60 programs from other
  43. representations to the MARST representation.")
  44. (license gpl3+)))