lisp-check.scm 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages lisp-check)
  19. #:use-module (gnu packages)
  20. #:use-module ((guix licenses) #:prefix license:)
  21. #:use-module (gnu packages lisp-xyz)
  22. #:use-module (guix packages)
  23. #:use-module (guix git-download)
  24. #:use-module (guix build-system asdf))
  25. ;;; Commentary:
  26. ;;;
  27. ;;; This module only contains Common Lisp libraries related to code testing
  28. ;;; facilities.
  29. (define-public sbcl-nst
  30. (let ((commit "6c0990f594abcf5887e8d80f1035e3b60454b61b")
  31. (revision "1"))
  32. (package
  33. (name "sbcl-nst")
  34. (version (git-version "4.1.2" revision commit))
  35. (source
  36. (origin
  37. (method git-fetch)
  38. (uri (git-reference
  39. (url "https://github.com/jphmrst/cl-nst")
  40. (commit commit)))
  41. (file-name (git-file-name "nst" version))
  42. (sha256
  43. (base32 "1hf3r6pqbnd9vsd1i24qmz928kia72hdgmiafiwb6jw1hmj3r6ga"))))
  44. (build-system asdf-build-system/sbcl)
  45. (inputs
  46. `(("closer-mop" ,sbcl-closer-mop)
  47. ("org-sampler" ,sbcl-org-sampler)))
  48. (home-page "https://github.com/jphmrst/cl-nst")
  49. (synopsis "Unit testing for Common Lisp")
  50. (description
  51. "NST is a unit/regression testing system for Common Lisp.")
  52. (license license:llgpl))))
  53. (define-public ecl-nst
  54. (sbcl-package->ecl-package sbcl-nst))
  55. (define-public cl-nst
  56. (sbcl-package->cl-source-package sbcl-nst))
  57. ;;; lisp-check.scm ends here