libedit.scm 2.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
  3. ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
  4. ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
  6. ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
  7. ;;;
  8. ;;; This file is part of GNU Guix.
  9. ;;;
  10. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  11. ;;; under the terms of the GNU General Public License as published by
  12. ;;; the Free Software Foundation; either version 3 of the License, or (at
  13. ;;; your option) any later version.
  14. ;;;
  15. ;;; GNU Guix is distributed in the hope that it will be useful, but
  16. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  17. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. ;;; GNU General Public License for more details.
  19. ;;;
  20. ;;; You should have received a copy of the GNU General Public License
  21. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  22. (define-module (gnu packages libedit)
  23. #:use-module (guix licenses)
  24. #:use-module (guix packages)
  25. #:use-module (guix download)
  26. #:use-module (guix build-system gnu)
  27. #:use-module (gnu packages ncurses))
  28. (define-public libedit
  29. (package
  30. (name "libedit")
  31. (version "20191231-3.1")
  32. (source
  33. (origin
  34. (method url-fetch)
  35. (uri (string-append "https://thrysoee.dk/editline"
  36. "/libedit-" version ".tar.gz"))
  37. (sha256
  38. (base32 "0wch48nml28jj6ild889745dsg2agm7mpvrmbl1gi98nw6vjrf6v"))))
  39. (build-system gnu-build-system)
  40. (inputs
  41. `(("ncurses" ,ncurses)))
  42. (home-page "https://thrysoee.dk/editline/")
  43. (synopsis "NetBSD Editline library")
  44. (description
  45. "This is an autotool- and libtoolized port of the NetBSD Editline
  46. library (libedit). This Berkeley-style licensed command line editor library
  47. provides generic line editing, history, and tokenization functions, similar to
  48. those found in GNU Readline.")
  49. (license bsd-3)))
  50. (define-public editline
  51. (package
  52. (name "editline")
  53. (version "1.17.1")
  54. (source
  55. (origin
  56. (method url-fetch)
  57. (uri (string-append
  58. "https://ftp.troglobit.com/editline/editline-" version ".tar.xz"))
  59. (sha256
  60. (base32 "03pw3z6pz590v8xfnjx0yynnzij2sb9xwjbvqvdzsid56crkn8nz"))))
  61. (build-system gnu-build-system)
  62. (home-page "https://troglobit.com/projects/editline/")
  63. (synopsis "Line editing library")
  64. (description
  65. "@code{editline} is a small line editing library. It can be linked into almost
  66. any program to provide command line editing and history functions. It is call
  67. compatible with the GNU Readline library, but at a fraction of the size,
  68. and as a result fewer features.")
  69. (license bsd-4)))