libbsd.scm 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages libbsd)
  19. #:use-module (guix build-system gnu)
  20. #:use-module (guix download)
  21. #:use-module (guix licenses)
  22. #:use-module (guix packages))
  23. (define-public libbsd
  24. (package
  25. (name "libbsd")
  26. (version "0.10.0")
  27. (source (origin
  28. (method url-fetch)
  29. (uri (string-append "https://libbsd.freedesktop.org/releases/"
  30. "libbsd-" version ".tar.xz"))
  31. (sha256
  32. (base32
  33. "11x8q45jvjvf2dvgclds64mscyg10lva33qinf2hwgc84v3svf1l"))))
  34. (build-system gnu-build-system)
  35. (arguments
  36. '(#:configure-flags '("--disable-static")))
  37. (synopsis "Utility functions from BSD systems")
  38. (description "This library provides useful functions commonly found on BSD
  39. systems, and lacking on others like GNU systems, thus making it easier to port
  40. projects with strong BSD origins, without needing to embed the same code over
  41. and over again on each project.")
  42. (home-page "https://libbsd.freedesktop.org/wiki/")
  43. ;; This package is a collection of third-party functions that were
  44. ;; originally released under various non-copyleft licenses.
  45. (license (list bsd-2 bsd-3 bsd-4 expat isc public-domain
  46. (non-copyleft "file://COPYING"
  47. "See COPYING in the distribution.")))))