lesstif.scm 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages lesstif)
  19. #:use-module ((guix licenses) #:prefix license:)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu)
  23. #:use-module (gnu packages xorg))
  24. (define-public lesstif
  25. (package
  26. (name "lesstif")
  27. (version "0.95.2")
  28. (source
  29. (origin
  30. (method url-fetch)
  31. (uri (string-append
  32. "mirror://sourceforge/lesstif/lesstif/" version
  33. "/lesstif-" version ".tar.bz2"))
  34. (sha256
  35. (base32
  36. "1qzpxjjf7ri1jzv71mvq5m9g8hfaj5yzwp30rwxlm6n2b24a6jpb"))))
  37. (build-system gnu-build-system)
  38. (propagated-inputs
  39. `(("printproto" ,printproto)))
  40. (inputs
  41. `(("libxext" ,libxext)
  42. ("libxt" ,libxt)))
  43. (home-page "http://lesstif.sourceforge.net/")
  44. (synopsis "Clone of the Motif toolkit for the X window system")
  45. (description "Clone of the Motif toolkit for the X window system.")
  46. (license license:gpl2+))) ; some files are lgpl2.1+ or x11