kodi.scm 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 David Thompson <davet@gnu.org>
  3. ;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
  4. ;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
  5. ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  6. ;;; Copyright © 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
  7. ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
  8. ;;;
  9. ;;; This file is part of GNU Guix.
  10. ;;;
  11. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  12. ;;; under the terms of the GNU General Public License as published by
  13. ;;; the Free Software Foundation; either version 3 of the License, or (at
  14. ;;; your option) any later version.
  15. ;;;
  16. ;;; GNU Guix is distributed in the hope that it will be useful, but
  17. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  18. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  19. ;;; GNU General Public License for more details.
  20. ;;;
  21. ;;; You should have received a copy of the GNU General Public License
  22. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  23. (define-module (gnu packages kodi)
  24. #:use-module ((guix licenses) #:prefix license:)
  25. #:use-module (guix utils)
  26. #:use-module (guix packages)
  27. #:use-module (guix download)
  28. #:use-module (guix git-download)
  29. #:use-module (guix build-system cmake)
  30. #:use-module (guix build-system gnu)
  31. #:use-module (guix build-system trivial)
  32. #:use-module (gnu packages)
  33. #:use-module (gnu packages algebra)
  34. #:use-module (gnu packages audio)
  35. #:use-module (gnu packages autotools)
  36. #:use-module (gnu packages avahi)
  37. #:use-module (gnu packages base)
  38. #:use-module (gnu packages bash)
  39. #:use-module (gnu packages cdrom)
  40. #:use-module (gnu packages cmake)
  41. #:use-module (gnu packages compression)
  42. #:use-module (gnu packages curl)
  43. #:use-module (gnu packages databases)
  44. #:use-module (gnu packages documentation)
  45. #:use-module (gnu packages file-systems)
  46. #:use-module (gnu packages fontutils)
  47. #:use-module (gnu packages freedesktop)
  48. #:use-module (gnu packages fribidi)
  49. #:use-module (gnu packages gettext)
  50. #:use-module (gnu packages ghostscript)
  51. #:use-module (gnu packages gawk)
  52. #:use-module (gnu packages gl)
  53. #:use-module (gnu packages glib)
  54. #:use-module (gnu packages gperf)
  55. #:use-module (gnu packages groff)
  56. #:use-module (gnu packages gnunet)
  57. #:use-module (gnu packages gnupg)
  58. #:use-module (gnu packages image)
  59. #:use-module (gnu packages java)
  60. #:use-module (gnu packages libusb)
  61. #:use-module (gnu packages linux)
  62. #:use-module (gnu packages mp3)
  63. #:use-module (gnu packages pcre)
  64. #:use-module (gnu packages pkg-config)
  65. #:use-module (gnu packages pretty-print)
  66. #:use-module (gnu packages pulseaudio)
  67. #:use-module (gnu packages python)
  68. #:use-module (gnu packages samba)
  69. #:use-module (gnu packages sdl)
  70. #:use-module (gnu packages serialization)
  71. #:use-module (gnu packages sqlite)
  72. #:use-module (gnu packages ssh)
  73. #:use-module (gnu packages swig)
  74. #:use-module (gnu packages textutils)
  75. #:use-module (gnu packages tls)
  76. #:use-module (gnu packages video)
  77. #:use-module (gnu packages web)
  78. #:use-module (gnu packages xdisorg)
  79. #:use-module (gnu packages xiph)
  80. #:use-module (gnu packages xml)
  81. #:use-module (gnu packages xorg)
  82. #:use-module (gnu packages assembly))
  83. (define-public crossguid
  84. (let ((commit "fef89a4174a7bf8cd99fa9154864ce9e8e3bf989")
  85. (revision "2"))
  86. (package
  87. (name "crossguid")
  88. (version (string-append "0.0-" revision "." (string-take commit 7)))
  89. ;; This is the commit that Kodi wants.
  90. (source (origin
  91. (method git-fetch)
  92. (uri (git-reference
  93. (url "https://github.com/graeme-hill/crossguid")
  94. (commit commit)))
  95. (file-name (string-append name "-" version "-checkout"))
  96. (sha256
  97. (base32
  98. "1blrkc7zcqrqcr5msvhyhm98s2jvm9hr0isqs4288q2r4mdnrfq0"))))
  99. (build-system gnu-build-system)
  100. (arguments
  101. '(#:phases
  102. (modify-phases %standard-phases
  103. (delete 'configure) ; no configure script
  104. (replace 'build
  105. (lambda _
  106. (invoke "g++" "-c" "guid.cpp" "-o" "guid.o"
  107. "-DGUID_LIBUUID")
  108. (invoke "ar" "rvs" "libcrossguid.a" "guid.o")))
  109. (replace 'check
  110. (lambda _
  111. (invoke "g++" "-c" "test.cpp" "-o" "test.o")
  112. (invoke "g++" "-c" "testmain.cpp" "-o" "testmain.o")
  113. (invoke "g++" "test.o" "guid.o" "testmain.o"
  114. "-o" "test" "-luuid")
  115. (invoke (string-append (getcwd) "/test"))))
  116. (replace 'install
  117. (lambda* (#:key outputs #:allow-other-keys)
  118. (let ((out (assoc-ref outputs "out")))
  119. (install-file "guid.h" (string-append out "/include"))
  120. (install-file "libcrossguid.a"
  121. (string-append out "/lib"))
  122. #t))))))
  123. (inputs
  124. `(("libuuid" ,util-linux "lib")))
  125. (synopsis "Lightweight universal identifier library")
  126. (description "CrossGuid is a minimal GUID/UUID
  127. generator library for C++.")
  128. (home-page "https://github.com/graeme-hill/crossguid")
  129. (license license:expat))))
  130. ;; Kodi requires using their own special forks of these libraries.
  131. ;; In addition, it insists on downloading and building these as part
  132. ;; of the standard build process. To make things easier, we bootstrap
  133. ;; and patch shebangs here, so we don't have to worry about it later.
  134. (define libdvdnav/kodi
  135. (let ((commit "6.0.0-Leia-Alpha-3"))
  136. (package
  137. (name "libdvdnav-bootstrapped")
  138. (version commit)
  139. (source (origin
  140. (method git-fetch)
  141. (uri (git-reference
  142. (url "https://github.com/xbmc/libdvdnav")
  143. (commit commit)))
  144. (file-name (string-append name "-" version "-checkout"))
  145. (sha256
  146. (base32
  147. "0qwlf4lgahxqxk1r2pzl866mi03pbp7l1fc0rk522sc0ak2s9jhb"))))
  148. (build-system gnu-build-system)
  149. (arguments
  150. '(#:tests? #f
  151. #:phases
  152. (modify-phases %standard-phases
  153. (delete 'configure)
  154. (delete 'build)
  155. (replace 'install
  156. (lambda* (#:key outputs #:allow-other-keys)
  157. (copy-recursively "." (assoc-ref outputs "out"))
  158. #t)))))
  159. (native-inputs
  160. `(("autoconf" ,autoconf)
  161. ("automake" ,automake)
  162. ("libtool" ,libtool)
  163. ("pkg-config" ,pkg-config)))
  164. (home-page "https://github.com/xbmc/libdvdnav")
  165. (synopsis (package-synopsis libdvdnav))
  166. (description (package-description libdvdnav))
  167. (license license:gpl2+))))
  168. (define libdvdread/kodi
  169. (let ((commit "6.0.0-Leia-Alpha-3"))
  170. (package
  171. (name "libdvdread-bootstrapped")
  172. (version commit)
  173. (source (origin
  174. (method git-fetch)
  175. (uri (git-reference
  176. (url "https://github.com/xbmc/libdvdread")
  177. (commit commit)))
  178. (file-name (string-append name "-" version "-checkout"))
  179. (sha256
  180. (base32
  181. "1xxn01mhkdnp10cqdr357wx77vyzfb5glqpqyg8m0skyi75aii59"))))
  182. (build-system gnu-build-system)
  183. (arguments
  184. '(#:tests? #f
  185. #:phases
  186. (modify-phases %standard-phases
  187. (delete 'configure)
  188. (delete 'build)
  189. (replace 'install
  190. (lambda* (#:key outputs #:allow-other-keys)
  191. (copy-recursively "." (assoc-ref outputs "out"))
  192. #t)))))
  193. (native-inputs
  194. `(("autoconf" ,autoconf)
  195. ("automake" ,automake)
  196. ("libtool" ,libtool)
  197. ("pkg-config" ,pkg-config)))
  198. (home-page "https://github.com/xbmc/libdvdread")
  199. (synopsis (package-synopsis libdvdread))
  200. (description (package-description libdvdread))
  201. (license (list license:gpl2+ license:lgpl2.1+)))))
  202. (define libdvdcss/kodi
  203. (let ((commit "1.4.2-Leia-Beta-5"))
  204. (package
  205. (name "libdvdcss-bootstrapped")
  206. (version commit)
  207. (source (origin
  208. (method git-fetch)
  209. (uri (git-reference
  210. (url "https://github.com/xbmc/libdvdcss")
  211. (commit commit)))
  212. (file-name (string-append name "-" version "-checkout"))
  213. (sha256
  214. (base32
  215. "0j41ydzx0imaix069s3z07xqw9q95k7llh06fc27dcn6f7b8ydyl"))))
  216. (build-system gnu-build-system)
  217. (arguments
  218. '(#:tests? #f
  219. #:phases
  220. (modify-phases %standard-phases
  221. (delete 'configure)
  222. (delete 'build)
  223. (replace 'install
  224. (lambda* (#:key outputs #:allow-other-keys)
  225. (copy-recursively "." (assoc-ref outputs "out"))
  226. #t)))))
  227. (native-inputs
  228. `(("autoconf" ,autoconf)
  229. ("automake" ,automake)
  230. ("libtool" ,libtool)
  231. ("pkg-config" ,pkg-config)))
  232. (home-page "https://github.com/xbmc/libdvdcss")
  233. (synopsis (package-synopsis libdvdcss))
  234. (description (package-description libdvdcss))
  235. (license license:gpl2+))))
  236. (define-public fstrcmp
  237. (package
  238. (name "fstrcmp")
  239. (version "0.7.D001")
  240. (source
  241. (origin
  242. (method url-fetch)
  243. (uri (string-append "http://fstrcmp.sourceforge.net/fstrcmp-"
  244. version ".tar.gz"))
  245. (sha256
  246. (base32
  247. "0xilghiy3mz78bjmfldi39qyy7jvw5b6wafsx370lw401y2qw0g4"))))
  248. (build-system gnu-build-system)
  249. (home-page "http://fstrcmp.sourceforge.net/")
  250. (arguments
  251. '(#:configure-flags '("SH=sh")))
  252. (native-inputs
  253. `(("ghostscript" ,ghostscript) ; ps2pdf
  254. ("groff" ,groff)
  255. ("libtool" ,libtool)
  256. ("which" ,which)))
  257. (synopsis "fuzzy comparison of strings")
  258. (description
  259. "The fstrcmp project provides a library that is used to make fuzzy
  260. comparisons of strings and byte arrays, including multi-byte character strings.
  261. This can be useful in error messages, enabling the suggestion of likely valid
  262. alternatives. In compilers, this can reduce the cascade of secondary errors.")
  263. (license license:gpl3+)))
  264. (define-public kodi
  265. (package
  266. (name "kodi")
  267. (version "18.8")
  268. (source (origin
  269. (method git-fetch)
  270. (uri (git-reference
  271. (url "https://github.com/xbmc/xbmc")
  272. (commit (string-append version "-Leia"))))
  273. (file-name (git-file-name name version))
  274. (sha256
  275. (base32
  276. "0qpkpz43s207msvv3qkiy6vzqwcgmydxv3py7vc29mv6h30chrva"))
  277. (patches (search-patches "kodi-skip-test-449.patch"
  278. "kodi-increase-test-timeout.patch"
  279. "kodi-set-libcurl-ssl-parameters.patch"))
  280. (snippet
  281. '(begin
  282. (use-modules (guix build utils))
  283. (for-each delete-file-recursively
  284. '("project/BuildDependencies/"
  285. ;; TODO: Purge these jars.
  286. ;;"tools/codegenerator/groovy"
  287. ;; And these sources:
  288. ;; "tools/depend/native/JsonSchemaBuilder"
  289. ;; "tools/depend/native/TexturePacker"
  290. ;; "lib/gtest"
  291. ;; "lib/cpluff"
  292. ;; "lib/libUPnP"
  293. "lib/libUPnP/Neptune/ThirdParty"
  294. "project/Win32BuildSetup/tools/7z"))
  295. #t))
  296. (modules '((guix build utils)))))
  297. (build-system cmake-build-system)
  298. (arguments
  299. '(#:modules ((srfi srfi-1)
  300. (guix build cmake-build-system)
  301. (guix build utils))
  302. #:configure-flags
  303. (list "-DENABLE_INTERNAL_FFMPEG=OFF"
  304. "-DENABLE_INTERNAL_CROSSGUID=OFF"
  305. (string-append "-Dlibdvdread_URL="
  306. (assoc-ref %build-inputs "libdvdread-bootstrapped"))
  307. (string-append "-Dlibdvdnav_URL="
  308. (assoc-ref %build-inputs "libdvdnav-bootstrapped"))
  309. (string-append "-Dlibdvdcss_URL="
  310. (assoc-ref %build-inputs "libdvdcss-bootstrapped"))
  311. (string-append "-DSYSTEM_LDFLAGS=-Wl,-rpath="
  312. (assoc-ref %build-inputs "curl") "/lib"))
  313. #:phases
  314. (modify-phases %standard-phases
  315. ;; The build system tries to bootstrap these bundled components
  316. ;; during the regular build phase, which causes serious issues
  317. ;; because there's no time for shebangs to be patched. So, we
  318. ;; bootstrap it on our own instead.
  319. (add-after 'unpack 'bootstrap-bundled-software
  320. (lambda _
  321. (let ((dirs '("tools/depends/native/JsonSchemaBuilder/src"
  322. "lib/cpluff")))
  323. (every (lambda (third-party)
  324. (with-directory-excursion third-party
  325. (invoke "autoreconf" "-vif")))
  326. dirs))))
  327. (add-after 'bootstrap-bundled-software 'patch-stuff
  328. (lambda* (#:key inputs #:allow-other-keys)
  329. ;; Prevent the build scripts from calling autoreconf in the
  330. ;; build stage. Otherwise, it would undo the bootstrapping
  331. ;; and shebang patching that we worked so hard for.
  332. (substitute* "cmake/modules/FindCpluff.cmake"
  333. (("autoreconf -vif") "true"))
  334. (substitute* "lib/cpluff/po/Makefile.in.in"
  335. (("/bin/sh") (which "sh")))
  336. (substitute* "cmake/modules/FindLibDvd.cmake"
  337. ;; The libdvd* sources that we bootstrapped separately are
  338. ;; unpacked in the build phase. This is our best opportunity
  339. ;; to make them writable before the build process starts.
  340. (("autoreconf -vif") "chmod -R u+w ."))
  341. (substitute* "xbmc/platform/linux/LinuxTimezone.cpp"
  342. (("/usr/share/zoneinfo")
  343. (search-input-directory inputs "share/zoneinfo")))
  344. ;; Don't phone home to check for updates.
  345. (substitute* "system/addon-manifest.xml"
  346. (("<addon optional=\\\"true\\\">service.xbmc.versioncheck</addon>")
  347. ""))
  348. ;; Let's disable some tests that are known not to work here.
  349. ;; Doing this later while in the cmake "../build" directory
  350. ;; is trickier.
  351. (substitute* '("xbmc/utils/test/TestSystemInfo.cpp")
  352. (("TEST_F\\(TestSystemInfo, GetOsPrettyNameWithVersion\\)")
  353. "TEST_F(TestSystemInfo, DISABLED_GetOsPrettyNameWithVersion)")
  354. (("TEST_F\\(TestSystemInfo, GetOsName\\)")
  355. "TEST_F(TestSystemInfo, DISABLED_GetOsName)")
  356. (("TEST_F\\(TestSystemInfo, GetOsVersion\\)")
  357. "TEST_F(TestSystemInfo, DISABLED_GetOsVersion)"))
  358. #t))
  359. (add-before 'build 'set-build-environment
  360. (lambda _
  361. ;; Some bundled build scripts fall back to /bin/sh
  362. ;; if this is not set.
  363. (setenv "CONFIG_SHELL" (which "sh"))
  364. #t))
  365. (add-before 'check 'build-kodi-test
  366. (lambda _
  367. (invoke "make" "kodi-test"))))))
  368. ;; TODO: Add dependencies for:
  369. ;; - cec
  370. ;; - plist
  371. ;; - shairplay
  372. (native-inputs
  373. `(("autoconf" ,autoconf)
  374. ("automake" ,automake)
  375. ("gettext" ,gettext-minimal)
  376. ("icedtea" ,icedtea) ; needed at build-time only, mandatory
  377. ("libdvdcss-bootstrapped" ,libdvdcss/kodi)
  378. ("libdvdnav-bootstrapped" ,libdvdnav/kodi)
  379. ("libdvdread-bootstrapped" ,libdvdread/kodi)
  380. ("libtool" ,libtool)
  381. ("pkg-config" ,pkg-config)
  382. ("swig" ,swig)
  383. ("yasm" ,yasm)))
  384. (inputs
  385. `(("alsa-lib" ,alsa-lib)
  386. ("avahi" ,avahi)
  387. ("bluez" ,bluez)
  388. ("crossguid" ,crossguid)
  389. ("curl" ,curl)
  390. ("dcadec" ,dcadec)
  391. ("dbus" ,dbus)
  392. ("eudev" ,eudev)
  393. ("ffmpeg" ,ffmpeg)
  394. ("flac" ,flac)
  395. ("flatbuffers" ,flatbuffers)
  396. ("fmt" ,fmt)
  397. ("fontconfig" ,fontconfig)
  398. ("freetype" ,freetype)
  399. ("fribidi" ,fribidi)
  400. ("fstrcmp" ,fstrcmp)
  401. ("giflib" ,giflib)
  402. ("glew" ,glew)
  403. ("gnutls" ,gnutls)
  404. ("lame" ,lame)
  405. ("lcms" ,lcms)
  406. ("libass" ,libass)
  407. ("libbluray" ,libbluray)
  408. ("libcap" ,libcap)
  409. ("libcdio" ,libcdio)
  410. ("libdrm" ,libdrm)
  411. ("libgcrypt" ,libgcrypt)
  412. ("libjpeg" ,libjpeg-turbo)
  413. ("libltdl" ,libltdl)
  414. ("libmad" ,libmad)
  415. ("libmicrohttpd" ,libmicrohttpd)
  416. ("libmpeg2" ,libmpeg2)
  417. ("libnfs" ,libnfs)
  418. ("libogg" ,libogg)
  419. ("libpng" ,libpng)
  420. ("libssh" ,libssh)
  421. ("libtiff" ,libtiff)
  422. ("libva" ,libva)
  423. ("libvorbis" ,libvorbis)
  424. ("libxml2" ,libxml2)
  425. ("libxrandr" ,libxrandr)
  426. ("libxrender" ,libxrender)
  427. ("libxslt" ,libxslt)
  428. ("lzo" ,lzo)
  429. ("mariadb-dev" ,mariadb "lib")
  430. ("mariadb-dev" ,mariadb "dev")
  431. ("openssl" ,openssl)
  432. ("pcre" ,pcre)
  433. ("pulseaudio" ,pulseaudio)
  434. ("python" ,python-2)
  435. ("rapidjson" ,rapidjson)
  436. ("samba" ,samba)
  437. ("sqlite" ,sqlite)
  438. ("taglib" ,taglib)
  439. ("tinyxml" ,tinyxml)
  440. ("tzdata" ,tzdata)
  441. ("util-linux" ,util-linux)
  442. ("zip" ,zip)
  443. ("zlib" ,zlib)))
  444. (synopsis "Media center for home theater computers")
  445. (description "Kodi is a media center application for playing videos,
  446. music, games, etc. Kodi is highly customizable and features a theme and
  447. plug-in system.")
  448. (home-page "https://kodi.tv")
  449. ;; XBMC is largely GPL2+, with some library components as LGPL2.1+, but
  450. ;; there are some other licenses spread throughout.
  451. (license (list license:gpl2+ license:lgpl2.1+
  452. license:gpl3+ ;WiiRemote client
  453. license:expat ;cpluff, dbwrappers
  454. license:public-domain ;cpluff/examples
  455. license:bsd-3 ;misc, gtest
  456. license:bsd-2)))) ;xbmc/freebsd
  457. (define-public kodi/wayland
  458. (package/inherit kodi
  459. (name "kodi-wayland")
  460. (arguments
  461. (substitute-keyword-arguments (package-arguments kodi)
  462. ((#:configure-flags flags)
  463. `(append '("-DCORE_PLATFORM_NAME=wayland"
  464. "-DWAYLAND_RENDER_SYSTEM=gl")
  465. ,flags))))
  466. (inputs
  467. `(("libinput" ,libinput)
  468. ("libxkbcommon" ,libxkbcommon)
  469. ("waylandpp" ,waylandpp)
  470. ("waylandp-protocols" ,wayland-protocols)
  471. ,@(package-inputs kodi)))
  472. (synopsis "Kodi with Wayland rendering backend")))
  473. (define-public kodi-cli
  474. (let ((commit "104dc23b2a993c8e6db8c46f4f8bec24b146549b") ; Add support for
  475. (revision "1")) ; `$HOME/.kodirc'.
  476. (package
  477. (name "kodi-cli")
  478. (version (string-append "1.1-" revision "." (string-take commit 7)))
  479. (source (origin
  480. (method git-fetch)
  481. (uri (git-reference (url "https://github.com/nawar/kodi-cli")
  482. (commit commit)))
  483. (sha256
  484. (base32
  485. "1xjhasc5gngfxpr1dlzy6q24w0wpdfjx12p43fanjppxw4i49n5p"))
  486. (file-name (string-append name "-" version "-checkout"))))
  487. (build-system trivial-build-system)
  488. (inputs
  489. `(("bash" ,bash)
  490. ("curl" ,curl)
  491. ("mps-youtube" ,mps-youtube)))
  492. (arguments
  493. `(#:modules ((guix build utils))
  494. #:builder
  495. (begin
  496. (use-modules (guix build utils))
  497. (copy-recursively (assoc-ref %build-inputs "source") ".")
  498. (substitute* "kodi-cli"
  499. (("/bin/bash") (string-append (assoc-ref %build-inputs "bash")
  500. "/bin/bash"))
  501. (("output=\\$\\((curl)" all curl)
  502. (string-append "output=$("
  503. (assoc-ref %build-inputs "curl")
  504. "/bin/" curl))
  505. (("play_youtube `(mpsyt)" all mpsyt)
  506. (string-append "play_youtube `"
  507. (assoc-ref %build-inputs "mps-youtube")
  508. "/bin/" mpsyt)))
  509. (install-file "kodi-cli" (string-append %output "/bin"))
  510. #t)))
  511. (home-page "https://github.com/nawar/kodi-cli")
  512. (synopsis "Control Kodi from the command line")
  513. (description "@code{kodi-cli} is a tool for sending commands to a Kodi
  514. server using JSON RPC.
  515. Features:
  516. @itemize
  517. @item Play, pause, stop the currently playing item.
  518. @item Skip forward or backward in the currently playing item.
  519. @item Play or queue to the currently list of YouTube videos.
  520. @item Interactive and noninteractive volume control.
  521. @item Interactive navigation.
  522. @item Send text to the Kodi keyboard.
  523. @item Toggle fullscreen.
  524. @item Update or clean Kodi libraries.
  525. @end itemize\n")
  526. (license license:gpl2+))))