kde-systemtools.scm 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
  3. ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages kde-systemtools)
  20. #:use-module (guix build-system qt)
  21. #:use-module (guix download)
  22. #:use-module ((guix licenses) #:prefix license:)
  23. #:use-module (guix packages)
  24. #:use-module (guix utils)
  25. #:use-module (gnu packages)
  26. #:use-module (gnu packages compression)
  27. #:use-module (gnu packages kde)
  28. #:use-module (gnu packages kde-frameworks)
  29. #:use-module (gnu packages linux)
  30. #:use-module (gnu packages pkg-config)
  31. #:use-module (gnu packages qt)
  32. #:use-module (gnu packages ruby)
  33. #:use-module (gnu packages search)
  34. #:use-module (gnu packages vnc)
  35. #:use-module (gnu packages xml)
  36. #:use-module (gnu packages xorg))
  37. (define-public dolphin
  38. (package
  39. (name "dolphin")
  40. (version "20.04.1")
  41. (source
  42. (origin
  43. (method url-fetch)
  44. (uri (string-append "mirror://kde/stable/release-service/" version
  45. "/src/dolphin-" version ".tar.xz"))
  46. (sha256
  47. (base32 "0xr5s0s40i2bsfjfapvpa7dxh9s4604cxirg97xcaacd6fdvhpds"))))
  48. (build-system qt-build-system)
  49. (native-inputs
  50. `(("extra-cmake-modules" ,extra-cmake-modules)
  51. ("kdoctools" ,kdoctools)
  52. ("ruby" ,ruby)
  53. ("ruby-test-unit" ,ruby-test-unit)))
  54. (inputs
  55. `(("baloo" ,baloo)
  56. ("baloo-widgets" ,baloo-widgets)
  57. ("kactivities" ,kactivities)
  58. ("kbookmarks" ,kbookmarks)
  59. ("kcmutils" ,kcmutils)
  60. ("kcompletion" ,kcompletion)
  61. ("kconfig" ,kconfig)
  62. ("kcoreaddons" ,kcoreaddons)
  63. ("kcrash" ,kcrash)
  64. ("kdbusaddons" ,kdbusaddons)
  65. ("ki18n" ,ki18n)
  66. ("kiconthemes" ,kiconthemes)
  67. ("kinit" ,kinit)
  68. ("kio" ,kio)
  69. ("knewstuff" ,knewstuff)
  70. ("knotifications" ,knotifications)
  71. ("kparts" ,kparts)
  72. ("ktextwidgets" ,ktextwidgets)
  73. ("kwindowsystem" ,kwindowsystem)
  74. ("oxygen-icons" ,oxygen-icons) ;; default icon set
  75. ("phonon" ,phonon)
  76. ("qtbase" ,qtbase-5)
  77. ("solid" ,solid)))
  78. (arguments
  79. `(#:tests? #f)) ;; TODO: 4/15 tests fail even with offscreen
  80. (home-page "https://kde.org/applications/system/org.kde.dolphin")
  81. (synopsis "File manager for KDE")
  82. (description "Dolphin is a file manager for KDE focusing on usability.
  83. The main features of Dolphin are:
  84. @itemize
  85. @item Navigation bar for URLs, which navigates quickly
  86. through the file hierarchy.
  87. @item View properties are remembered for each folder.
  88. @item Split of views is supported.
  89. @item Network transparency.
  90. @item Undo/redo functionality.
  91. @item Renaming of a variable number of selected items in one step.
  92. @end itemize")
  93. (license ;; GPL for programs, FDL for documentation
  94. (list license:gpl2+ license:fdl1.2+))))
  95. (define-public dolphin-plugins
  96. (package
  97. (name "dolphin-plugins")
  98. (version "20.04.1")
  99. (source
  100. (origin
  101. (method url-fetch)
  102. (uri (string-append "mirror://kde/stable/release-service/" version
  103. "/src/dolphin-plugins-" version ".tar.xz"))
  104. (sha256
  105. (base32 "12g44s6g7ma6avp15l45l42qyzbglswvahm2wji79zdls5vjnz7r"))))
  106. (build-system qt-build-system)
  107. (native-inputs
  108. `(("extra-cmake-modules" ,extra-cmake-modules)))
  109. (inputs
  110. `(("dolphin" ,dolphin)
  111. ("ki18n" ,ki18n)
  112. ("kio" ,kio)
  113. ("ktexteditor" ,ktexteditor)
  114. ("kxmlgui" ,kxmlgui)
  115. ("oxygen-icons" ,oxygen-icons) ;; default icon set
  116. ("qtbase" ,qtbase-5)))
  117. (home-page "http://www.kde.org/")
  118. (synopsis "VCS-Plugins for Dolphin")
  119. (description "This package contains plugins that offer integration in
  120. Dolphin with the version control systems: Bzr, Git, Mercurial, Subversion.")
  121. (license license:gpl2+)))
  122. (define-public khelpcenter
  123. (package
  124. (name "khelpcenter")
  125. (version "20.04.1")
  126. (source
  127. (origin
  128. (method url-fetch)
  129. (uri (string-append "mirror://kde/stable/release-service/" version
  130. "/src/khelpcenter-" version ".tar.xz"))
  131. (sha256
  132. (base32 "0wxzjragvjcfc7c4qja8wzpshhaywficj7f7wkmppzybcsxwn9qb"))))
  133. (build-system qt-build-system)
  134. (native-inputs
  135. `(("extra-cmake-modules" ,extra-cmake-modules)
  136. ("kdoctools" ,kdoctools)))
  137. (inputs
  138. `(("grantlee" ,grantlee)
  139. ("karchive" ,karchive)
  140. ("kbookmarks" ,kbookmarks)
  141. ("kcodecs" ,kcodecs)
  142. ("kconfig" ,kconfig)
  143. ("kcoreaddons" ,kcoreaddons)
  144. ("kdbusaddons" ,kdbusaddons)
  145. ("khtml" ,khtml)
  146. ("ki18n" ,ki18n)
  147. ("kinit" ,kinit)
  148. ("kio" ,kio)
  149. ("kjs" ,kjs)
  150. ("kparts" ,kparts)
  151. ("kservice" ,kservice)
  152. ("kwindowsystem" ,kwindowsystem)
  153. ("libxml2" ,libxml2)
  154. ("oxygen-icons" ,oxygen-icons) ;; default icon set
  155. ("qtbase" ,qtbase-5)
  156. ("xapian" ,xapian)))
  157. (arguments
  158. `(#:tests? #f)) ;; 1/1 test fails
  159. (home-page "https://kde.org/applications/system/org.kde.Help")
  160. (synopsis "KDE documentation viewer")
  161. (description "KHelpCenter uses meta data files which describe the
  162. documentation available in the system. Each document is represented by a meta
  163. data file and shown as an entry in the KHelpCenter navigation tree view. The
  164. meta data contains information about title and short description of the
  165. document, the location of the document and some more information like how to
  166. search the document and translations of title and description. Document
  167. hierarchy is represented as hierarchy of the meta data files. Directories are
  168. also described by a meta data file which contains the same information as a
  169. document meta data file.")
  170. (license license:gpl2+)))
  171. (define-public konsole
  172. (package
  173. (name "konsole")
  174. (version "20.04.1")
  175. (source
  176. (origin
  177. (method url-fetch)
  178. (uri (string-append "mirror://kde/stable/release-service/" version
  179. "/src/konsole-" version ".tar.xz"))
  180. (sha256
  181. (base32 "0ckr7bjkyaw0gr5kx569jfnhkhwmlk4lqk41ng61qwxlb4bsdbdm"))))
  182. (build-system qt-build-system)
  183. (native-inputs
  184. `(("extra-cmake-modules" ,extra-cmake-modules)
  185. ("kdoctools" ,kdoctools)))
  186. (inputs
  187. `(("kbookmarks" ,kbookmarks)
  188. ("kcompletion" ,kcompletion)
  189. ("kconfig" ,kconfig)
  190. ("kconfigwidgets" ,kconfigwidgets)
  191. ("kcoreaddons" ,kcoreaddons)
  192. ("kcrash" ,kcrash)
  193. ("kdbusaddons" ,kdbusaddons)
  194. ("kguiaddons" ,kguiaddons)
  195. ("ki18n" ,ki18n)
  196. ("kiconthemes" ,kiconthemes)
  197. ("kinit" ,kinit)
  198. ("kio" ,kio)
  199. ("knewstuff" ,knewstuff)
  200. ("kglobalaccel" ,kglobalaccel)
  201. ("knotifications" ,knotifications)
  202. ("knotifyconfig" ,knotifyconfig)
  203. ("kparts" ,kparts)
  204. ("kpty" ,kpty)
  205. ("kservice" ,kservice)
  206. ("ktextwidgets" ,ktextwidgets)
  207. ("kwidgetsaddons" ,kwidgetsaddons)
  208. ("kwindowsystem" ,kwindowsystem)
  209. ("kxmlgui" ,kxmlgui)
  210. ("oxygen-icons" ,oxygen-icons) ;; default icon set
  211. ("qtbase" ,qtbase-5)
  212. ("qtscript" ,qtscript)))
  213. (arguments
  214. `(#:tests? #f)) ;; TODO: 2/15 tests fail even with HOME, offscreen, SHELL, debus
  215. (home-page "http://www.kde.org/")
  216. (synopsis "Terminal emulator similar for KDE")
  217. (description "Konsole is a terminal emulator, similar to xterm, built on
  218. the KDE Platform. It can contain multiple terminal sessions inside one window
  219. using detachable tabs. Konsole supports customizable schemes, saved sessions,
  220. output monitoring and more.
  221. This package is part of the KDE base applications module.")
  222. (license ;; GPL for programs, LGPL for libraries, FDL for documentation
  223. (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
  224. (define-public krfb
  225. (package
  226. (name "krfb")
  227. (version "20.04.1")
  228. (source
  229. (origin
  230. (method url-fetch)
  231. (uri (string-append "mirror://kde/stable/release-service/" version
  232. "/src/krfb-" version ".tar.xz"))
  233. (sha256
  234. (base32 "092ijn88jpmgk2zwz37vzf35jisl234mc3krc9jl7bd955akx51k"))))
  235. (build-system qt-build-system)
  236. (native-inputs
  237. `(("extra-cmake-modules" ,extra-cmake-modules)
  238. ("pkg-config" ,pkg-config)
  239. ("kdoctools" ,kdoctools)))
  240. (inputs
  241. `(("kcompletion" ,kcompletion)
  242. ("kconfig" ,kconfig)
  243. ("kcoreaddons" ,kcoreaddons)
  244. ("kcrash" ,kcrash)
  245. ("kdbusaddons" ,kdbusaddons)
  246. ("kdnssd" ,kdnssd)
  247. ("ki18n" ,ki18n)
  248. ("knotifications" ,knotifications)
  249. ("kwallet" ,kwallet)
  250. ("kwidgetsaddons" ,kwidgetsaddons)
  251. ("kwindowsystem" ,kwindowsystem)
  252. ("kxmlgui" ,kxmlgui)
  253. ("libvnc" ,libvnc)
  254. ("libxcb" ,libxcb)
  255. ("libxtst" ,libxtst)
  256. ("oxygen-icons" ,oxygen-icons) ;; default icon set
  257. ("pipewire" ,pipewire)
  258. ("qtbase" ,qtbase-5)
  259. ("qtx11extras" ,qtx11extras)
  260. ("xcb-util-image" ,xcb-util-image)
  261. ("zlib" ,zlib)))
  262. (home-page "https://kde.org/applications/internet/org.kde.krfb")
  263. (synopsis "Desktop Sharing utility")
  264. (description "KDE Desktop Sharing is a server application that allows you
  265. to share your current session with a user on another machine. The desktop
  266. session can be viewed or even controlled remotely by any VNC or RFB client,
  267. such as the KDE Remote Desktop Connection client.
  268. KDE Desktop Sharing can restrict access to only users who are explicitly
  269. invited, and will ask for confirmation when a user attempts to connect.
  270. This package is part of the KDE networking module.")
  271. (license ;; GPL for programs, LGPL for libraries, FDL for documentation
  272. (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
  273. (define-public ksystemlog
  274. (package
  275. (name "ksystemlog")
  276. (version "20.04.1")
  277. (source
  278. (origin
  279. (method url-fetch)
  280. (uri (string-append "mirror://kde/stable/release-service/" version
  281. "/src/ksystemlog-" version ".tar.xz"))
  282. (sha256
  283. (base32 "1826h89ynvlxdwzyqil2d79cvynglww6fax7qp41wxasgarxhsni"))))
  284. (build-system qt-build-system)
  285. (native-inputs
  286. `(("extra-cmake-modules" ,extra-cmake-modules)
  287. ("kdoctools" ,kdoctools)))
  288. (inputs
  289. ;; Not including Journald since this is not used in guix
  290. `(("karchive" ,karchive)
  291. ("kcompletion" ,kcompletion)
  292. ("kconfig" ,kconfig)
  293. ("kcoreaddons" ,kcoreaddons)
  294. ("ki18n" ,ki18n)
  295. ("kiconthemes" ,kiconthemes)
  296. ("kio" ,kio)
  297. ("kitemviews" ,kitemviews)
  298. ("ktextwidgets" ,ktextwidgets)
  299. ("kwidgetsaddons" ,kwidgetsaddons)
  300. ("kxmlgui" ,kxmlgui)
  301. ("oxygen-icons" ,oxygen-icons) ;; default icon set
  302. ("qtbase" ,qtbase-5)))
  303. (home-page "https://kde.org/applications/system/org.kde.ksystemlog")
  304. (synopsis "System log viewer")
  305. (description "This program is developed for being used by beginner users,
  306. which don't know how to find information about their Linux system, and how the
  307. log files are in their computer. But it is also designed for advanced users,
  308. who want to quickly see problems occurring on their server.
  309. This package is part of the KDE administration module.")
  310. (license license:gpl2+)))
  311. (define-public yakuake
  312. (package
  313. (name "yakuake")
  314. (version "20.12.1")
  315. (source (origin
  316. (method url-fetch)
  317. (uri (string-append "mirror://kde/stable/release-service/" version
  318. "/src/yakuake-" version ".tar.xz"))
  319. (sha256
  320. (base32
  321. "02pal9xx1wbpw7dimvs2aw1xnyjqlvbjlybkkfhf8x7c6m1r63aa"))))
  322. (build-system qt-build-system)
  323. (native-inputs
  324. `(("extra-cmake-modules" ,extra-cmake-modules)))
  325. (inputs
  326. `(("breeze-icons" ,breeze-icons)
  327. ("karchive" ,karchive)
  328. ("kconfig" ,kconfig)
  329. ("kcoreaddons" ,kcoreaddons)
  330. ("kcrash" ,kcrash)
  331. ("kdbusaddons" ,kdbusaddons)
  332. ("kglobalaccel" ,kglobalaccel)
  333. ("ki18n" ,ki18n)
  334. ("kiconthemes" ,kiconthemes)
  335. ("kio" ,kio)
  336. ("knewstuff" ,knewstuff)
  337. ("knotifications" ,knotifications)
  338. ("knotifyconfig" ,knotifyconfig)
  339. ("konsole" ,konsole)
  340. ("kparts" ,kparts)
  341. ("kwayland" ,kwayland)
  342. ("kwidgetsaddons" ,kwidgetsaddons)
  343. ("kwindowsystem" ,kwindowsystem)
  344. ("qtbase" ,qtbase-5)
  345. ("qtsvg" ,qtsvg)
  346. ("qtx11extras" ,qtx11extras)))
  347. (home-page "https://www.kde.org/applications/system/yakuake/")
  348. (synopsis "Quad-style terminal emulator for KDE")
  349. (description "Yakuake is a drop-down terminal emulator based on KDE Konsole
  350. technology. Features include:
  351. @itemize
  352. @item Smoothly rolls down from the top of your screen
  353. @item Tabbed interface
  354. @item Configurable dimensions and animation speed
  355. @item Skinnable
  356. @item Sophisticated D-Bus interface
  357. @end itemize")
  358. (license license:gpl2+)))