kde-multimedia.scm 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
  3. ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
  4. ;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages kde-multimedia)
  21. #:use-module (guix build-system qt)
  22. #:use-module (guix download)
  23. #:use-module ((guix licenses) #:prefix license:)
  24. #:use-module (guix packages)
  25. #:use-module (guix utils)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages audio)
  28. #:use-module (gnu packages base)
  29. #:use-module (gnu packages compression)
  30. #:use-module (gnu packages cdrom)
  31. #:use-module (gnu packages glib)
  32. #:use-module (gnu packages gtk)
  33. #:use-module (gnu packages gnome)
  34. #:use-module (gnu packages gstreamer)
  35. #:use-module (gnu packages kde-frameworks)
  36. #:use-module (gnu packages libcanberra)
  37. #:use-module (gnu packages linux)
  38. #:use-module (gnu packages mp3)
  39. #:use-module (gnu packages music)
  40. #:use-module (gnu packages pkg-config)
  41. #:use-module (gnu packages pulseaudio)
  42. #:use-module (gnu packages qt)
  43. #:use-module (gnu packages video)
  44. #:use-module (gnu packages xiph)
  45. #:use-module (gnu packages xorg))
  46. (define-public audiocd-kio
  47. (package
  48. (name "audiocd-kio")
  49. (version "20.04.1")
  50. (source
  51. (origin
  52. (method url-fetch)
  53. (uri (string-append "mirror://kde/stable/release-service/" version
  54. "/src/audiocd-kio-" version ".tar.xz"))
  55. (sha256
  56. (base32 "0qlnxxbayqhz25jbvzis27jw2zbw1pmacp8rv7v5wa7zfqn3kmyk"))))
  57. (build-system qt-build-system)
  58. (native-inputs
  59. `(("extra-cmake-modules" ,extra-cmake-modules)
  60. ("kdoctools" ,kdoctools)))
  61. (inputs
  62. `(("cdparanoia" ,cdparanoia)
  63. ("flac" ,flac)
  64. ("kcmutils" ,kcmutils)
  65. ("kconfig" ,kconfig)
  66. ("ki18n" ,ki18n)
  67. ("kio" ,kio)
  68. ("libkcddb" ,libkcddb)
  69. ("libkcompactdisc" ,libkcompactdisc)
  70. ("libvorbis" ,libvorbis)
  71. ("phonon" ,phonon)
  72. ("qtbase" ,qtbase-5)))
  73. (home-page "https://kde.org/applications/multimedia/org.kde.kio_audiocd")
  74. (synopsis "Transparent audio CD integration for applications using the KDE
  75. Platform")
  76. (description "KIO AudioCD is a KIO slave that enables KIO-aware
  77. applications (such as Dolphin or k3b) to access audio and CD text data on the
  78. audio compact disks. It allows transparent drag and drop conversion of audio
  79. data into the popular formats and has a configuration System Settings module
  80. available in the \"Multimedia\" section.
  81. This package is part of the KDE multimedia module.")
  82. (license ;; GPL for programs, FDL for documentation
  83. (list license:gpl2+ license:fdl1.2+))))
  84. (define-public dragon
  85. (package
  86. (name "dragon")
  87. (version "20.04.1")
  88. (source
  89. (origin
  90. (method url-fetch)
  91. (uri (string-append "mirror://kde/stable/release-service/" version
  92. "/src/dragon-" version ".tar.xz"))
  93. (sha256
  94. (base32 "1sssg20a1vpwk816lp5jgwahilaswb9f3hgfqvc73il4g11ky1xj"))))
  95. (build-system qt-build-system)
  96. (native-inputs
  97. `(("extra-cmake-modules" ,extra-cmake-modules)
  98. ("kdoctools" ,kdoctools)))
  99. (inputs
  100. `(("kconfig" ,kconfig)
  101. ("kconfigwidgets" ,kconfigwidgets)
  102. ("kcoreaddons" ,kcoreaddons)
  103. ("kcrash" ,kcrash)
  104. ("kdbusaddons" ,kdbusaddons)
  105. ("ki18n" ,ki18n)
  106. ("kio" ,kio)
  107. ("kjobwidgets" ,kjobwidgets)
  108. ("knotifications" ,knotifications)
  109. ("kparts" ,kparts)
  110. ("kwidgetsaddons" ,kwidgetsaddons)
  111. ("kwindowsystem" ,kwindowsystem)
  112. ("kxmlgui" ,kxmlgui)
  113. ("oxygen-icons" ,oxygen-icons) ; default icon set
  114. ("phonon" ,phonon)
  115. ("phonon-backend-gstreamer" ,phonon-backend-gstreamer)
  116. ("qtbase" ,qtbase-5)
  117. ("solid" ,solid)))
  118. (home-page "https://kde.org/applications/multimedia/org.kde.dragonplayer")
  119. (synopsis "Simple video player")
  120. (description "Dragon Player is a multimedia player where the focus is on
  121. simplicity, instead of features. Dragon Player does one thing, and only one
  122. thing, which is playing multimedia files. It's simple interface is designed
  123. not to get in your way and instead empower you to simply play multimedia
  124. files.
  125. This package is part of the KDE multimedia module.")
  126. (license ;; GPL for programs, FDL for documentation
  127. (list license:gpl2+ license:fdl1.2+))))
  128. (define-public elisa
  129. (package
  130. (name "elisa")
  131. (version "20.12.0")
  132. (source
  133. (origin
  134. (method url-fetch)
  135. (uri (string-append "mirror://kde/stable/release-service/" version
  136. "/src/elisa-" version ".tar.xz"))
  137. (sha256
  138. (base32 "02450lsnbd37fms1i2bb9qc9wir4vym6qqd9p5hr6a6s6qwfs6qf"))))
  139. (build-system qt-build-system)
  140. (native-inputs
  141. `(("extra-cmake-modules" ,extra-cmake-modules)
  142. ("pkg-config" ,pkg-config)
  143. ("dbus" ,dbus)
  144. ("kdoctools" ,kdoctools)
  145. ("xorg-server" , xorg-server-for-tests)))
  146. (inputs
  147. `(("kconfig" ,kconfig)
  148. ("baloo" ,baloo)
  149. ("kconfigwidgets" ,kconfigwidgets)
  150. ("kcoreaddons" ,kcoreaddons)
  151. ("kcrash" ,kcrash)
  152. ("kcmutils" ,kcmutils)
  153. ("kdbusaddons" ,kdbusaddons)
  154. ("kdeclarative" ,kdeclarative)
  155. ("kfilemetadata" ,kfilemetadata)
  156. ("ki18n" ,ki18n)
  157. ("kio" ,kio)
  158. ("kirigami" ,kirigami)
  159. ("kmediaplayer" ,kmediaplayer)
  160. ("kparts" ,kparts)
  161. ("kpackage" ,kpackage)
  162. ("kwidgetsaddons" ,kwidgetsaddons)
  163. ("kxmlgui" ,kxmlgui)
  164. ("oxygen-icons" ,oxygen-icons) ; default icon set
  165. ("phonon" ,phonon)
  166. ("qtbase" ,qtbase-5)
  167. ("qtdeclarative" ,qtdeclarative)
  168. ("qtgraphicaleffects" ,qtgraphicaleffects) ; not listed as dependency
  169. ("qtmultimedia" ,qtmultimedia)
  170. ("qtquickcontrols" ,qtquickcontrols)
  171. ("qtquickcontrols2" ,qtquickcontrols2)
  172. ("qtsvg" ,qtsvg)
  173. ("qtx11extras" ,qtx11extras)
  174. ;; TODO: upnpqt https://gitlab.com/homeautomationqt/upnp-player-qt
  175. ("vlc" ,vlc)))
  176. (arguments
  177. `(#:phases
  178. (modify-phases %standard-phases
  179. (add-before 'check 'start-xorg-server
  180. (lambda* (#:key inputs #:allow-other-keys)
  181. ;; The test suite requires a running X server, setting
  182. ;; QT_QPA_PLATFORM=offscreen does not suffice.
  183. (system "Xvfb :1 -screen 0 640x480x24 &")
  184. (setenv "DISPLAY" ":1")
  185. #t))
  186. (replace 'check
  187. (lambda* (#:key tests? test-target #:allow-other-keys)
  188. (when tests?
  189. (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
  190. (invoke "dbus-launch" "make" test-target))
  191. #t)))))
  192. (home-page "https://kde.org/applications/multimedia/org.kde.elisa")
  193. (synopsis "Powerful music player for Plasma 5")
  194. (description "Elisa is a simple music player aiming to provide a nice
  195. experience for its users. Elisa browses music by album, artist or
  196. all tracks. The music is indexed using either a private indexer or an indexer
  197. using Baloo. The private one can be configured to scan music on chosen paths.
  198. The Baloo one is much faster because Baloo is providing all needed data from
  199. its own database. You can build and play your own playlist.")
  200. (license license:lgpl3+)))
  201. (define-public ffmpegthumbs
  202. (package
  203. (name "ffmpegthumbs")
  204. (version "20.04.1")
  205. (source
  206. (origin
  207. (method url-fetch)
  208. (uri (string-append "mirror://kde/stable/release-service/" version
  209. "/src/ffmpegthumbs-" version ".tar.xz"))
  210. (sha256
  211. (base32 "17l50z33a1h5zkrrfkb261yi2hms66qj36l1mndq7mvs97y2ggmc"))))
  212. (build-system qt-build-system)
  213. (native-inputs
  214. `(("extra-cmake-modules" ,extra-cmake-modules)
  215. ("pkg-config" ,pkg-config)))
  216. (inputs
  217. `(("ffmpeg" ,ffmpeg)
  218. ("kconfig" ,kconfig)
  219. ("ki18n" ,ki18n)
  220. ("kio" ,kio)
  221. ("qtbase" ,qtbase-5)))
  222. (home-page "https://kde.org/applications/multimedia/org.kde.ffmpegthumbs")
  223. (synopsis "Video thumbnail generator for KDE using ffmpeg")
  224. (description "
  225. FFMpegThumbs is a video thumbnail generator for KDE file managers
  226. like Dolphin and Konqueror. It enables them to show preview images
  227. of video files using FFMpeg.
  228. This package is part of the KDE multimedia module.")
  229. (license license:gpl2+)))
  230. (define-public juk
  231. (package
  232. (name "juk")
  233. (version "20.04.1")
  234. (source
  235. (origin
  236. (method url-fetch)
  237. (uri (string-append "mirror://kde/stable/release-service/" version
  238. "/src/juk-" version ".tar.xz"))
  239. (sha256
  240. (base32 "06vsh7knyhcbcbf632jhldbqpzfkdyils2l8dbcdw5nj5hhgzzmr"))))
  241. (build-system qt-build-system)
  242. (native-inputs
  243. `(("extra-cmake-modules" ,extra-cmake-modules)))
  244. (inputs
  245. `(("kcoreaddons" ,kcoreaddons)
  246. ("kcompletion" ,kcompletion)
  247. ("kconfig" ,kconfig)
  248. ("kcrash" ,kcrash)
  249. ("kdbusaddons" ,kdbusaddons)
  250. ("kdoctools" ,kdoctools)
  251. ("kglobalaccel" ,kglobalaccel)
  252. ("ki18n" ,ki18n)
  253. ("kiconthemes" ,kiconthemes)
  254. ("kjobwidgets" ,kjobwidgets)
  255. ("kio" ,kio)
  256. ("knotifications" ,knotifications)
  257. ("ktextwidgets" ,ktextwidgets)
  258. ("kwallet" ,kwallet)
  259. ("kwidgetsaddons" ,kwidgetsaddons)
  260. ("kwindowsystem" ,kwindowsystem)
  261. ("kxmlgui" ,kxmlgui)
  262. ("oxygen-icons" ,oxygen-icons) ; default icon set
  263. ("phonon" ,phonon)
  264. ("phonon-backend-gstreamer" ,phonon-backend-gstreamer)
  265. ("qtbase" ,qtbase-5)
  266. ("qtsvg" ,qtsvg)
  267. ("taglib" ,taglib)))
  268. (home-page "https://kde.org/applications/multimedia/org.kde.juk")
  269. (synopsis "Music jukebox / music player")
  270. (description "JuK is a powerful music player capable of managing a large
  271. music collection.
  272. Some of JuK's features include:
  273. @itemize
  274. @item Music collection, playlists, and smart playlists
  275. @item Tag editing support, including the ability to edit multiple files at once
  276. @item Tag-based music file organization and renaming
  277. @item CD burning support using k3b
  278. @item Album art using Google Image Search
  279. @end itemize
  280. This package is part of the KDE multimedia module.")
  281. (license license:gpl2+)))
  282. (define-public k3b
  283. (package
  284. (name "k3b")
  285. (version "20.04.2")
  286. (source
  287. (origin
  288. (method url-fetch)
  289. (uri (string-append "mirror://kde/stable/release-service/" version
  290. "/src/k3b-" version ".tar.xz"))
  291. (sha256
  292. (base32 "15wm987hz6rfs9ds9l1gbs6gdsardj1ywvk6zmpvj2i2190y4b3q"))))
  293. (build-system qt-build-system)
  294. (arguments
  295. `(#:phases
  296. (modify-phases %standard-phases
  297. (add-after 'unpack 'set-absolute-library-paths
  298. (lambda _
  299. ;; Set absolute paths for dlopened libraries. We can’t use k3b’s
  300. ;; runpath as they are loaded by the Qt library.
  301. (let ((libcdio-paranoia (assoc-ref %build-inputs "libcdio-paranoia"))
  302. (libdvdcss (assoc-ref %build-inputs "libdvdcss")))
  303. (substitute* "libk3b/tools/k3bcdparanoialib.cpp"
  304. (("\"(cdio_cdda|cdio_paranoia)\"" _ library)
  305. (string-append "\"" libcdio-paranoia "/lib/" library "\"")))
  306. (substitute* "libk3b/tools/k3blibdvdcss.cpp"
  307. (("\"(dvdcss)\"" _ library)
  308. (string-append "\"" libdvdcss "/lib/" library "\""))))
  309. #t))
  310. (add-after 'qt-wrap 'wrap-path
  311. (lambda _
  312. ;; Set paths to backend programs.
  313. (wrap-program (string-append (assoc-ref %outputs "out") "/bin/k3b")
  314. `("PATH" ":" prefix
  315. ,(map (lambda (input)
  316. (string-append (assoc-ref %build-inputs input) "/bin"))
  317. '("cdrdao" "dvd+rw-tools" "libburn" "sox"))))
  318. #t)))))
  319. (native-inputs
  320. `(("extra-cmake-modules" ,extra-cmake-modules)
  321. ("pkg-config" ,pkg-config)
  322. ("kdoctools" ,kdoctools)))
  323. (inputs
  324. `(("cdrdao" ,cdrdao)
  325. ("dvd+rw-tools" ,dvd+rw-tools)
  326. ("ffmpeg" ,ffmpeg)
  327. ("flac" ,flac)
  328. ("karchive" ,karchive)
  329. ("kcmutils" ,kcmutils)
  330. ("kconfig" ,kconfig)
  331. ("kcoreaddons" ,kcoreaddons)
  332. ("kfilemetadata" ,kfilemetadata)
  333. ("ki18n" ,ki18n)
  334. ("kiconthemes" ,kiconthemes)
  335. ("kio" ,kio)
  336. ("kjobwidgets" ,kjobwidgets)
  337. ("knewstuff" ,knewstuff)
  338. ("knotifications" ,knotifications)
  339. ("knotifyconfig" ,knotifyconfig)
  340. ("kservice" ,kservice)
  341. ("kwidgetsaddons" ,kwidgetsaddons)
  342. ("kxmlgui" ,kxmlgui)
  343. ("lame" ,lame)
  344. ("libburn" ,libburn)
  345. ("libcdio-paranoia" ,libcdio-paranoia)
  346. ("libdvdcss" ,libdvdcss)
  347. ("libdvdread" ,libdvdread)
  348. ;; TODO: LibFuzzer
  349. ("libiconv" ,libiconv)
  350. ("libkcddb" ,libkcddb)
  351. ("libmad" ,libmad)
  352. ("libmpcdec" ,libmpcdec)
  353. ;;("libmusicbrainz" ,libmusicbrainz) ; wants old version 2
  354. ("libsamplerate" ,libsamplerate)
  355. ("libsndfile" ,libsndfile)
  356. ("libvorbis" ,libvorbis)
  357. ("oxygen-icons" ,oxygen-icons) ; default icon set
  358. ("qtbase" ,qtbase-5)
  359. ("qtwebkit" ,qtwebkit)
  360. ("shared-mime-info" ,shared-mime-info)
  361. ("solid" ,solid)
  362. ("sox" ,sox)
  363. ("taglib" ,taglib)
  364. ("zlib" ,zlib)))
  365. (home-page "https://kde.org/applications/multimedia/org.kde.k3b")
  366. (synopsis "Sophisticated CD/DVD burning application")
  367. (description "K3b is CD-writing software which intends to be feature-rich
  368. and provide an easily usable interface. Features include burning audio CDs
  369. from .WAV and .MP3 audio files, configuring external programs and configuring
  370. devices.
  371. The @code{udisks-service} should be enabled for @command{k3b} to discover the
  372. available CD drives.")
  373. (license ;; GPL for programs, FDL for documentation
  374. (list license:gpl2+ license:fdl1.2+))))
  375. (define-public kaffeine
  376. (package
  377. (name "kaffeine")
  378. (version "2.0.18")
  379. (source
  380. (origin
  381. (method url-fetch)
  382. (uri (string-append "mirror://kde/stable/kaffeine"
  383. "/kaffeine-" version ".tar.xz"))
  384. (sha256
  385. (base32 "10dnhr9v2jlki44i3gmjagky66ybixmv6f29z5imk9clgddrlyfr"))))
  386. (build-system qt-build-system)
  387. (native-inputs
  388. `(("extra-cmake-modules" ,extra-cmake-modules)
  389. ("pkg-config" ,pkg-config)
  390. ("kdoctools" ,kdoctools)))
  391. (inputs
  392. `(("eudev" ,eudev)
  393. ("kcoreaddons" ,kcoreaddons)
  394. ("kdbusaddons" ,kdbusaddons)
  395. ("ki18n" ,ki18n)
  396. ("kio" ,kio)
  397. ("kwidgetsaddons" ,kwidgetsaddons)
  398. ("kwindowsystem" ,kwindowsystem)
  399. ("kxmlgui" ,kxmlgui)
  400. ("libxscrnsaver" ,libxscrnsaver)
  401. ("oxygen-icons" ,oxygen-icons) ; default icon set
  402. ("qtbase" ,qtbase-5)
  403. ("qtx11extras" ,qtx11extras)
  404. ("solid" ,solid)
  405. ("v4l-utils" ,v4l-utils) ; libdvbv5
  406. ("vlc" ,vlc)))
  407. (arguments
  408. `(#:phases
  409. (modify-phases %standard-phases
  410. (add-after 'unpack 'fix-code
  411. (lambda _
  412. (substitute* "src/dvb/dvbdevice_linux.cpp"
  413. (("\\s*qPrintable\\(transponder\\.getTransmissionType\\(\\)\\)\\);")
  414. "transponder.getTransmissionType());"))
  415. #t)))))
  416. (home-page "https://kde.org/applications/multimedia/org.kde.kaffeine")
  417. (synopsis "Versatile media player for KDE")
  418. (description "Kaffeine is a media player for KDE. While it supports
  419. multiple Phonon backends, its default backend is Xine, giving Kaffeine a wide
  420. variety of supported media types and letting Kaffeine access CDs, DVDs, and
  421. network streams easily.
  422. Kaffeine can keep track of multiple playlists simultaneously, and supports
  423. autoloading of subtitle files for use while playing video.")
  424. (license ;; GPL for programs, FDL for documentation
  425. (list license:gpl2+ license:fdl1.2+))))
  426. (define-public kamoso
  427. (package
  428. (name "kamoso")
  429. (version "20.04.1")
  430. (source
  431. (origin
  432. (method url-fetch)
  433. (uri (string-append "mirror://kde/stable/release-service/" version
  434. "/src/kamoso-" version ".tar.xz"))
  435. (sha256
  436. (base32 "0c47j315kjfikd3b6x18786k3gqymicjjslpm0a58zdxl3wpqfay"))))
  437. (build-system qt-build-system)
  438. (native-inputs
  439. `(("extra-cmake-modules" ,extra-cmake-modules)
  440. ("glib:bin" ,glib "bin")
  441. ("kdoctools" ,kdoctools)
  442. ("pkg-config" ,pkg-config)))
  443. (inputs
  444. `(("gstreamer" ,gstreamer)
  445. ("gst-plugins-base" ,gst-plugins-base)
  446. ("kconfig" ,kconfig)
  447. ("ki18n" ,ki18n)
  448. ("kio" ,kio)
  449. ("kirigami" ,kirigami)
  450. ("knotifications" ,knotifications)
  451. ("kparts" ,kparts)
  452. ("oxygen-icons" ,oxygen-icons) ; default icon set
  453. ("purpose" ,purpose)
  454. ("qtbase" ,qtbase-5)
  455. ("qtdeclarative" ,qtdeclarative)
  456. ("qtgraphicaleffects" ,qtgraphicaleffects)
  457. ("qtquickcontrols" ,qtquickcontrols)
  458. ("qtquickcontrols2" ,qtquickcontrols2) ; not listed as dependency
  459. ("qtx11extras" ,qtx11extras)))
  460. (arguments
  461. `(#:tests? #f ; test program gets built, but is not found
  462. #:configure-flags
  463. (list (string-append "-DCMAKE_CXX_FLAGS=-I"
  464. (assoc-ref %build-inputs "gst-plugins-base")
  465. "/include/gstreamer-1.0"))))
  466. (home-page "https://kde.org/applications/multimedia/org.kde.kamoso")
  467. (synopsis "Take pictures and videos out of your webcam")
  468. (description "Kamoso is a simple and friendly program to use your
  469. camera. Use it to take pictures and make videos to share.")
  470. (license ;; GPL for programs, LGPL for libraries
  471. (list license:gpl2+ license:lgpl2.0+))))
  472. (define-public kmix
  473. (package
  474. (name "kmix")
  475. (version "20.04.1")
  476. (source
  477. (origin
  478. (method url-fetch)
  479. (uri (string-append "mirror://kde/stable/release-service/" version
  480. "/src/kmix-" version ".tar.xz"))
  481. (sha256
  482. (base32 "1na52ypp57wqrc6pl1khinx9i6fidv1k97nnxcy8zb4l7d5sh1nd"))))
  483. (build-system qt-build-system)
  484. (native-inputs
  485. `(("extra-cmake-modules" ,extra-cmake-modules)
  486. ("pkg-config" ,pkg-config)))
  487. (inputs
  488. `(("alsa-lib" ,alsa-lib)
  489. ("glib" ,glib)
  490. ("kconfigwidgets" ,kconfigwidgets)
  491. ("kcompletion" ,kcompletion)
  492. ("kconfig" ,kconfig)
  493. ("kconfigwidgets" ,kconfigwidgets)
  494. ("kcrash" ,kcrash)
  495. ("kdbusaddons" ,kdbusaddons)
  496. ("kdoctools" ,kdoctools)
  497. ("kglobalaccel" ,kglobalaccel)
  498. ("ki18n" ,ki18n)
  499. ("kiconthemes" ,kiconthemes)
  500. ("knotifications" ,knotifications)
  501. ("kwidgetsaddons" ,kwidgetsaddons)
  502. ("kwindowsystem" ,kwindowsystem)
  503. ("kxmlgui" ,kxmlgui)
  504. ("libcanberra" ,libcanberra)
  505. ("oxygen-icons" ,oxygen-icons) ; default icon set
  506. ("plasma-framework" ,plasma-framework)
  507. ("pulseaudio" ,pulseaudio)
  508. ("qtbase" ,qtbase-5)
  509. ("solid" ,solid)))
  510. (home-page "https://kde.org/applications/multimedia/org.kde.kmix")
  511. (synopsis "Volume control and mixer")
  512. (description "KMix is an audio device mixer, used to adjust volume, select
  513. recording inputs, and set other hardware options.
  514. This package is part of the KDE multimedia module.")
  515. (license ;; GPL for programs, LGPL for libraries, FDL for documentation
  516. (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
  517. (define-public kmplayer
  518. (package
  519. (name "kmplayer")
  520. (version "0.12.0b")
  521. (source
  522. (origin
  523. (method url-fetch)
  524. (uri (string-append "mirror://kde/stable/kmplayer/0.12"
  525. "/kmplayer-" version ".tar.bz2"))
  526. (sha256
  527. (base32 "0wzdxym4fc83wvqyhcwid65yv59a2wvp1lq303cn124mpnlwx62y"))
  528. (patches (search-patches
  529. "kmplayer-aarch64.patch"
  530. "kmplayer-upstream_Fix-build-with-Qt-5.9.patch"))))
  531. (build-system qt-build-system)
  532. (native-inputs
  533. `(("extra-cmake-modules" ,extra-cmake-modules)
  534. ("pkg-config" ,pkg-config)
  535. ("kdoctools" ,kdoctools)))
  536. (inputs
  537. `(("kconfig" ,kconfig)
  538. ("kcoreaddons" ,kcoreaddons)
  539. ("kdelibs4support" ,kdelibs4support)
  540. ("ki18n" ,ki18n)
  541. ("kinit" ,kinit)
  542. ("kio" ,kio)
  543. ("kparts" ,kparts)
  544. ("kmediaplayer" ,kmediaplayer)
  545. ("kwidgetsaddons" ,kwidgetsaddons)
  546. ("libxcb" ,libxcb) ;; FIXME: why does cmake not find XEVIE and XPRINT?
  547. ("oxygen-icons" ,oxygen-icons) ; default icon set
  548. ("phonon" ,phonon)
  549. ("qtbase" ,qtbase-5)
  550. ("cairo" ,cairo)
  551. ("qtsvg" ,qtsvg)
  552. ("qtx11extras" ,qtx11extras)
  553. ("xcb-util" ,xcb-util)
  554. ("xcb-util-cursor" ,xcb-util-cursor)
  555. ("xcb-util-errors" ,xcb-util-errors)
  556. ("xcb-util-image" ,xcb-util-image)
  557. ("xcb-util-keysyms" ,xcb-util-keysyms)
  558. ("xcb-util-wm" ,xcb-util-wm)))
  559. (arguments
  560. `(#:configure-flags
  561. (list (string-append
  562. "-DCMAKE_CXX_FLAGS=-I"
  563. (assoc-ref %build-inputs "qtx11extras") "/include/qt5"))))
  564. (home-page "https://kde.org/applications/multimedia/org.kde.kmplayer")
  565. (synopsis "Media player using mplayer/phonon as backend")
  566. (description "Kmplayer can play all the audio/video supported by
  567. mplayer/phonon from a local file or URL and be embedded in Konqueror and
  568. KHTML. It also plays DVDs.
  569. Some features:
  570. @itemize
  571. @item play DVD/VCD movies (from file or url and from a video device)
  572. @item embed inside konqueror (movie is played inside konqueror)
  573. @item embed inside khtml (movie playback inside a html page)
  574. @item Movie recording using mencoder (part of the mplayer package)
  575. @item No video during recording, but you can always open a new window and play it
  576. @item Broadcasting, http streaming, using ffserver/ffmpeg
  577. @item For TV sources, you need v4lctl (part of the xawtv package)
  578. @end itemize")
  579. (license ;; GPL for programs, LGPL for libraries, FDL for documentation
  580. (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
  581. (define-public kwave
  582. (package
  583. (name "kwave")
  584. (version "20.04.1")
  585. (source
  586. (origin
  587. (method url-fetch)
  588. (uri (string-append "mirror://kde/stable/release-service/" version
  589. "/src/kwave-" version ".tar.xz"))
  590. (sha256
  591. (base32 "0ysa873pc2gip95cxr8yv7ifd9qql5zg6h67i9n9q3iqa6v58iyw"))))
  592. (build-system qt-build-system)
  593. (native-inputs
  594. `(("extra-cmake-modules" ,extra-cmake-modules)
  595. ("librsvg" ,librsvg)
  596. ("pkg-config" ,pkg-config)
  597. ("kdoctools" ,kdoctools)))
  598. (inputs
  599. `(("also-lib" ,alsa-lib)
  600. ("audiofile" ,audiofile)
  601. ("flac" ,flac)
  602. ("id3lib" ,id3lib)
  603. ("karchive" ,karchive)
  604. ("kcompletion" ,kcompletion)
  605. ("kconfig" ,kconfig)
  606. ("kconfigwidgets" ,kconfigwidgets)
  607. ("kcoreaddons" ,kcoreaddons)
  608. ("kcrash" ,kcrash)
  609. ("kdbusaddons" ,kdbusaddons)
  610. ("ki18n" ,ki18n)
  611. ("kiconthemes" ,kiconthemes)
  612. ("kio" ,kio)
  613. ("kservice" ,kservice)
  614. ("ktextwidgets" ,ktextwidgets)
  615. ("kwidgetsaddons" ,kwidgetsaddons)
  616. ("kxmlgui" ,kxmlgui)
  617. ("libmad" ,libmad)
  618. ("libsamplerate" ,libsamplerate)
  619. ("libvorbis" ,libvorbis)
  620. ("opus" ,opus)
  621. ("oxygen-icons" ,oxygen-icons) ; default icon set
  622. ("pulseaudio" ,pulseaudio)
  623. ("qtbase" ,qtbase-5)
  624. ("qtmultimedia" ,qtmultimedia)
  625. ("zlib" ,zlib)))
  626. (home-page "https://kde.org/applications/multimedia/org.kde.kwave")
  627. (synopsis "Sound editor for KDE")
  628. (description "Kwave is a sound editor designed for the KDE Desktop
  629. Environment.
  630. With Kwave you can record, play back, import and edit many sorts of audio
  631. files including multi-channel files. It includes some plugins to transform
  632. audio files in several ways and presents a graphical view with a complete
  633. zoom- and scroll capability.
  634. Its features include:
  635. @itemize
  636. @item 24 Bit Support
  637. @item Undo/Redo
  638. @item Use of multicore CPUs (SMP, hyperthreading)
  639. @item Simple Drag & Drop
  640. @item Realtime Pre-Listen for some effects
  641. @item Support for multi-track files
  642. @item Playback and recording via native ALSA (or OSS, deprecated)
  643. @item Playback via PulseAudio and Phonon
  644. @item Load and edit-capability for large files (can use virtual memory)
  645. @item Reading and auto-repair of damaged wav-files
  646. @item Supports multiple windows
  647. @item Extendable Plugin interface
  648. @item a nice splashscreen
  649. @item some label handling
  650. @end itemize")
  651. (license ;; GPL for programs, LGPL for libraries, FDL for documentation
  652. (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+
  653. license:cc-by-sa3.0 license:cc-by-sa4.0 ;; icons, samples
  654. license:cc0 license:bsd-3)))) ;; utilities files
  655. (define-public libkcddb
  656. (package
  657. (name "libkcddb")
  658. (version "20.04.1")
  659. (source
  660. (origin
  661. (method url-fetch)
  662. (uri (string-append "mirror://kde/stable/release-service/" version
  663. "/src/libkcddb-" version ".tar.xz"))
  664. (sha256
  665. (base32 "1fwryaj8ldmsqhl5qxjda8by9i7xlb97r8p9rqzckw697hkfhs0h"))))
  666. (build-system qt-build-system)
  667. (native-inputs
  668. `(("extra-cmake-modules" ,extra-cmake-modules)
  669. ("kdoctools" ,kdoctools)))
  670. (inputs
  671. `(("kcodecs" ,kcodecs)
  672. ("kconfig" ,kconfig)
  673. ("ki18n" ,ki18n)
  674. ("kio" ,kio)
  675. ("kwidgetsaddons" ,kwidgetsaddons)
  676. ("libmusicbrainz" ,libmusicbrainz)
  677. ("qtbase" ,qtbase-5)))
  678. (arguments
  679. `(#:tests? #f)) ; Most tests require network
  680. (home-page "https://invent.kde.org/multimedia/libkcddb")
  681. (synopsis "CDDB library for KDE Platform (runtime)")
  682. (description "A library for retrieving and sending cddb information.")
  683. (license ;; GPL for programs, LGPL for libraries, FDL for documentation
  684. (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
  685. (define-public libkcompactdisc
  686. (package
  687. (name "libkcompactdisc")
  688. (version "20.04.1")
  689. (source
  690. (origin
  691. (method url-fetch)
  692. (uri (string-append "mirror://kde/stable/release-service/" version
  693. "/src/libkcompactdisc-" version ".tar.xz"))
  694. (sha256
  695. (base32 "0iy4i0hxqsrnndd4iqkww7v1rqry7kvi5paxdw5qjfffwn8kcsbx"))))
  696. (build-system qt-build-system)
  697. (native-inputs
  698. `(("extra-cmake-modules" ,extra-cmake-modules)))
  699. (inputs
  700. `(("alsa-lib" ,alsa-lib)
  701. ("kcoreaddons" ,kcoreaddons)
  702. ("ki18n" ,ki18n)
  703. ("phonon" ,phonon)
  704. ("qtbase" ,qtbase-5)
  705. ("solid" ,solid)))
  706. (home-page "https://invent.kde.org/multimedia/libkcompactdisc")
  707. (synopsis "KDE library for playing & ripping CDs")
  708. (description "The KDE Compact Disc library provides an API for
  709. applications using the KDE Platform to interface with the CD drives for audio
  710. CDs.")
  711. (license ;; GPL for programs, LGPL for libraries
  712. (list license:gpl2+ license:lgpl2.0+))))