gsasl.scm 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
  3. ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
  4. ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
  5. ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  6. ;;; Copyright © 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
  7. ;;;
  8. ;;; This file is part of GNU Guix.
  9. ;;;
  10. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  11. ;;; under the terms of the GNU General Public License as published by
  12. ;;; the Free Software Foundation; either version 3 of the License, or (at
  13. ;;; your option) any later version.
  14. ;;;
  15. ;;; GNU Guix is distributed in the hope that it will be useful, but
  16. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  17. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. ;;; GNU General Public License for more details.
  19. ;;;
  20. ;;; You should have received a copy of the GNU General Public License
  21. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  22. (define-module (gnu packages gsasl)
  23. #:use-module (gnu packages)
  24. #:use-module (gnu packages compression)
  25. #:use-module (gnu packages libidn)
  26. #:use-module (gnu packages gnupg)
  27. #:use-module (gnu packages nettle)
  28. #:use-module (gnu packages kerberos)
  29. #:use-module (gnu packages tls)
  30. #:use-module ((guix licenses) #:prefix license:)
  31. #:use-module (guix packages)
  32. #:use-module (guix download)
  33. #:use-module (guix build-system gnu))
  34. (define-public libntlm
  35. (package
  36. (name "libntlm")
  37. (version "1.6")
  38. (source (origin
  39. (method url-fetch)
  40. (uri (string-append "https://www.nongnu.org/libntlm/releases/"
  41. "libntlm-" version ".tar.gz"))
  42. (sha256
  43. (base32
  44. "08b83nss16jsn213j326yhn1vnrz10k15fwq6jm5b1vdn23nndzj"))))
  45. (build-system gnu-build-system)
  46. (synopsis "Library that implements NTLM authentication")
  47. (description
  48. "Libntlm is a library that implements NTLM authentication.")
  49. (license license:lgpl2.1+)
  50. (home-page "https://www.nongnu.org/libntlm/")))
  51. (define-public gss
  52. (package
  53. (name "gss")
  54. (version "1.0.3")
  55. (source (origin
  56. (method url-fetch)
  57. (uri (string-append "mirror://gnu/gss/gss-" version
  58. ".tar.gz"))
  59. (sha256 (base32
  60. "1syyvh3k659xf1hdv9pilnnhbbhs6vfapayp4xgdcc8mfgf9v4gz"))))
  61. (build-system gnu-build-system)
  62. (inputs `(("nettle" ,nettle)
  63. ("shishi" ,shishi)
  64. ("zlib" ,zlib)))
  65. (synopsis "Generic Security Service library")
  66. (description
  67. "The GNU Generic Security Service provides a free implementation of the
  68. GSS-API specification. It provides a generic application programming
  69. interface for programs to access security services. Security services present
  70. a generic, GSS interface, with which the calling application interacts via
  71. this library, freeing the application developer from needing to know about
  72. the underlying security implementation.")
  73. (license license:gpl3+)
  74. (home-page "https://www.gnu.org/software/gss/")))
  75. (define-public gsasl
  76. (package
  77. (name "gsasl")
  78. (version "1.10.0")
  79. (source (origin
  80. (method url-fetch)
  81. (uri (string-append "mirror://gnu/gsasl/gsasl-" version
  82. ".tar.gz"))
  83. (sha256
  84. (base32
  85. "1lv8fp01aq4jjia9g4vkx90zacl8rgmjhfi6f1wdwnh9ws7bvg45"))))
  86. (build-system gnu-build-system)
  87. (arguments
  88. `(#:configure-flags '("--with-gssapi-impl=mit"
  89. "--disable-static")))
  90. (inputs
  91. `(("libgcrypt" ,libgcrypt)
  92. ("libidn" ,libidn)
  93. ("libntlm" ,libntlm)
  94. ("mit-krb5" ,mit-krb5)
  95. ("zlib" ,zlib)))
  96. (native-inputs
  97. `(;; Needed for cross compiling.
  98. ("libgcrypt" ,libgcrypt)))
  99. (propagated-inputs
  100. ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
  101. ;; propagated input of GnuTLS.
  102. `(("gnutls" ,gnutls)))
  103. (synopsis "Simple Authentication and Security Layer library")
  104. (description
  105. "GNU SASL is an implementation of the Simple Authentication and
  106. Security Layer framework. On network servers such as IMAP or SMTP servers,
  107. SASL is used to handle client/server authentication. This package contains
  108. both a library and a command-line tool to access the library.")
  109. (license license:gpl3+)
  110. (home-page "https://www.gnu.org/software/gsasl/")))