gnustep.scm 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
  4. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages gnustep)
  22. #:use-module (guix download)
  23. #:use-module (guix packages)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (guix licenses)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages base)
  28. #:use-module (gnu packages xorg)
  29. #:use-module (gnu packages libffcall)
  30. #:use-module (gnu packages gnome)
  31. #:use-module (gnu packages gtk)
  32. #:use-module (gnu packages texinfo)
  33. #:use-module (gnu packages autotools)
  34. #:use-module (gnu packages glib)
  35. #:use-module (gnu packages fontutils)
  36. #:use-module (gnu packages image)
  37. #:use-module (gnu packages pkg-config)
  38. #:use-module (gnu packages xml)
  39. #:use-module (ice-9 match))
  40. (define-public gnustep-make
  41. (package
  42. (name "gnustep-make")
  43. (version "2.7.0")
  44. (source (origin
  45. (method url-fetch)
  46. (uri (string-append "ftp://ftp.gnustep.org/pub/gnustep/core/"
  47. name "-" version ".tar.gz"))
  48. (sha256
  49. (base32
  50. "1khiygfkz0zhh9b5nybn40g0xnnjxchk24n49hff1bwanszir84h"))))
  51. (build-system gnu-build-system)
  52. (arguments
  53. '(#:tests? #f)) ; no check target
  54. (native-inputs
  55. `(("which" ,which)))
  56. (home-page "http://gnustep.org")
  57. (synopsis "GNUstep make package")
  58. (description "The makefile package is a simple, powerful and extensible way
  59. to write makefiles for a GNUstep-based project. It allows the user to write a
  60. project without having to deal with the complex issues associated with
  61. configuration, building, installation, and packaging. It also allows the user
  62. to easily create cross-compiled binaries.")
  63. (license gpl3+)))
  64. (define-public windowmaker
  65. (package
  66. (name "windowmaker")
  67. (version "0.95.9")
  68. (synopsis "NeXTSTEP-like window manager")
  69. (source (origin
  70. (method url-fetch)
  71. (uri (string-append
  72. "https://github.com/window-maker/wmaker/releases/download/"
  73. "wmaker-" version "/WindowMaker-" version ".tar.gz"))
  74. (sha256
  75. (base32
  76. "055pqvlkhipyjn7m6bb3fs4zz9rd1ynzl0mmwbhp05ihc3zmh8zj"))))
  77. (build-system gnu-build-system)
  78. (arguments
  79. `(#:modules ((guix build gnu-build-system)
  80. (guix build utils)
  81. (ice-9 match))
  82. #:phases
  83. (modify-phases %standard-phases
  84. (add-before 'configure 'pre-configure
  85. (lambda* (#:key outputs #:allow-other-keys)
  86. ;; 'wmaker' wants to invoke 'wmaker.inst' the first time,
  87. ;; and the 'wmsetbg', so make sure it uses the right ones.
  88. ;; We can't use a wrapper here because that would pollute
  89. ;; $PATH in the whole session.
  90. (let* ((out (assoc-ref outputs "out"))
  91. (bin (string-append out "/bin")))
  92. (substitute* "src/main.c"
  93. (("\"wmaker\\.inst")
  94. (string-append "\"" bin "/wmaker.inst")))
  95. (substitute* '("src/defaults.c" "WPrefs.app/Menu.c")
  96. (("\"wmsetbg")
  97. (string-append "\"" bin "/wmsetbg")))
  98. ;; Add enough cells to the command character array to
  99. ;; allow passing our large path to the wmsetbg binary.
  100. ;; The path to wmsetbg in Guix requires 67 extra characters.
  101. (substitute* "src/defaults.c"
  102. (("len = strlen\\(text\\) \\+ 40;")
  103. (string-append "len = strlen(text) + 107;")))
  104. #t)))
  105. (add-after 'install 'install-xsession
  106. (lambda* (#:key outputs #:allow-other-keys)
  107. (let* ((out (assoc-ref outputs "out"))
  108. (xsessions (string-append out "/share/xsessions")))
  109. (mkdir-p xsessions)
  110. (call-with-output-file
  111. (string-append xsessions "/windowmaker.desktop")
  112. (lambda (port)
  113. (format port "~
  114. [Desktop Entry]~@
  115. Name=Window Maker~@
  116. Comment=~a~@
  117. Exec=~a/bin/wmaker~@
  118. Type=Application~%"
  119. (string-map (match-lambda
  120. (#\newline #\space)
  121. (chr chr))
  122. ,synopsis) out))))
  123. #t))
  124. (add-after 'install-xsession 'wrap
  125. (lambda* (#:key outputs #:allow-other-keys)
  126. (let* ((out (assoc-ref outputs "out"))
  127. (bin (string-append out "/bin")))
  128. ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
  129. ;; etc., so make sure everything is in $PATH.
  130. (wrap-program (string-append bin "/wmaker.inst")
  131. `("PATH" ":" prefix (,bin)))
  132. #t))))))
  133. (inputs
  134. `(("libxmu" ,libxmu)
  135. ("libxft" ,libxft)
  136. ("libx11" ,libx11)
  137. ("libxinerama" ,libxinerama)
  138. ("fontconfig" ,fontconfig)
  139. ("libjpeg" ,libjpeg-turbo)
  140. ("giflib" ,giflib)
  141. ("libpng" ,libpng)
  142. ("libtiff" ,libtiff)))
  143. (native-inputs
  144. `(("pkg-config" ,pkg-config)))
  145. (home-page "https://windowmaker.org/")
  146. (description
  147. "Window Maker is an X11 window manager originally designed to provide
  148. integration support for the GNUstep Desktop Environment. In every way
  149. possible, it reproduces the elegant look and feel of the NeXTSTEP user
  150. interface. It is fast, feature rich, easy to configure, and easy to use.")
  151. ;; Artwork is distributed under the WTFPL.
  152. (license gpl2+)))
  153. (define-public wmbattery
  154. (package
  155. (name "wmbattery")
  156. (version "2.54")
  157. (source (origin
  158. (method url-fetch)
  159. (uri (string-append
  160. "mirror://debian/pool/main/w/wmbattery/wmbattery_"
  161. version ".orig.tar.gz"))
  162. (sha256
  163. (base32
  164. "1r4n58mwkm69y1pjs7l64hg8r1lpndrzyrfl2rdgd4zi6v0jhyyw"))))
  165. (build-system gnu-build-system)
  166. (arguments '(#:tests? #f)) ; no "check" target
  167. (inputs
  168. `(("glib" ,glib)
  169. ("libx11" ,libx11)
  170. ("libxext" ,libxext)
  171. ("libxpm" ,libxpm)
  172. ("upower" ,upower)))
  173. (native-inputs
  174. `(("pkg-config" ,pkg-config)))
  175. (home-page "https://www.dockapps.net/wmbattery")
  176. (synopsis "Display laptop battery info")
  177. (description
  178. "Wmbattery displays the status of your laptop's battery in a small icon.
  179. This includes if it is plugged in, if the battery is charging, how many minutes
  180. of battery life remain, battery life remaining (with both a percentage and a
  181. graph), and battery status (high - green, low - yellow, or critical - red).")
  182. (license gpl2)))
  183. (define-public wmnd
  184. (package
  185. (name "wmnd")
  186. (version "0.4.18")
  187. (source (origin
  188. (method url-fetch)
  189. (uri (string-append
  190. "http://www.thregr.org/~wavexx/software/wmnd/releases/"
  191. name "-" version ".tar.gz"))
  192. (sha256
  193. (base32
  194. "01s37d8cfpncza1mlw13ar4rcwbrc1vgaj3ifhglmlcnzvvayg0n"))))
  195. (build-system gnu-build-system)
  196. (inputs
  197. `(("libx11" ,libx11)
  198. ("libxext" ,libxext)
  199. ("libxpm" ,libxpm)))
  200. (native-inputs
  201. `(("pkg-config" ,pkg-config)))
  202. (home-page "http://www.thregr.org/~wavexx/software/wmnd/")
  203. (synopsis "Network interface monitor")
  204. (description
  205. "WMND is a dockapp for monitoring network interfaces under WindowMaker and
  206. other compatible window managers.")
  207. (license gpl2+)))
  208. (define-public wmcpuload
  209. (package
  210. (name "wmcpuload")
  211. (version "1.1.1")
  212. (source (origin
  213. (method url-fetch)
  214. (uri (string-append
  215. "mirror://debian/pool/main/w/wmcpuload/"
  216. name "_" version ".orig.tar.gz"))
  217. (sha256
  218. (base32
  219. "1334y0axnxydwv05d172f405iljrfakg4kcyg9kmn46v6ywv424g"))))
  220. (build-system gnu-build-system)
  221. (inputs
  222. `(("libx11" ,libx11)
  223. ("libxext" ,libxext)
  224. ("libxpm" ,libxpm)))
  225. (native-inputs
  226. `(("pkg-config" ,pkg-config)))
  227. (home-page "https://www.dockapps.net/wmcpuload")
  228. (synopsis "Monitor CPU usage")
  229. (description
  230. "Wmcpuload displays the current CPU usage, expressed as a percentile and a
  231. chart, and has an LCD look-alike user interface. The back-light may be turned
  232. on and off by clicking the mouse button over the application. If the CPU usage
  233. hits a certain threshold, an alarm-mode will alert you by turning back-light
  234. on.")
  235. (license gpl2+)))
  236. (define-public wmclock
  237. (package
  238. (name "wmclock")
  239. (version "1.0.16")
  240. (source (origin
  241. (method url-fetch)
  242. (uri (string-append
  243. "mirror://debian/pool/main/w/wmclock/"
  244. name "_" version ".orig.tar.gz"))
  245. (sha256
  246. (base32
  247. "1lx276ba8r2yydhmwj1g586jdqg695ad89ng36fr3mb067gvb2rz"))))
  248. (build-system gnu-build-system)
  249. (inputs
  250. `(("libx11" ,libx11)
  251. ("libxext" ,libxext)
  252. ("libxpm" ,libxpm)))
  253. ;; wmclock requires autoreconf to generate its configure script.
  254. (native-inputs
  255. `(("autoconf" ,autoconf)
  256. ("automake" ,automake)
  257. ("pkg-config" ,pkg-config)))
  258. (home-page "https://www.dockapps.net/wmclock")
  259. (synopsis "Display the date and time")
  260. (description
  261. "wmclock is an applet for Window Maker which displays the date and time in
  262. a dockable tile. It features multiple language support, 24h or 12h time
  263. display, and can run a user-specified program on mouse click.")
  264. (license gpl2+)))
  265. (define-public wmfire
  266. (package
  267. (name "wmfire")
  268. (version "1.2.4")
  269. (source (origin
  270. (method url-fetch)
  271. (uri (string-append "http://www.improbability.net/"
  272. name "/" name "-" version ".tar.gz"))
  273. (sha256
  274. (base32
  275. "101grahd80n97y2dczb629clmcgiavdpbbwy78kk5wgs362m12z3"))
  276. (patches
  277. (search-patches "wmfire-update-for-new-gdk-versions.patch"))))
  278. (build-system gnu-build-system)
  279. (inputs
  280. `(("gtk+" ,gtk+-2)
  281. ("libgtop" ,libgtop)))
  282. (native-inputs
  283. `(("pkg-config" ,pkg-config)))
  284. (home-page "http://www.improbability.net/")
  285. (synopsis "Display flames to represent resource usage")
  286. (description
  287. "wmfire is an applet for Window Maker that can monitor the average cpu
  288. load, or individual cpu load on SMP computers. Additionally it can monitor the
  289. memory, network load, a file or just be set to show a pretty flame. On
  290. entering the dock a burning spot replaces the cursor, and after two seconds
  291. symbols to represent the current monitor are \"burnt\" onscreen. The flame
  292. colour can also be changed.")
  293. (license gpl2+)))