gkrellm.scm 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
  3. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages gkrellm)
  21. #:use-module ((guix licenses) #:prefix license:)
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (gnu packages gettext)
  26. #:use-module (gnu packages gtk)
  27. #:use-module (gnu packages pkg-config)
  28. #:use-module (gnu packages xorg))
  29. (define-public gkrellm
  30. (package
  31. (name "gkrellm")
  32. (version "2.3.11")
  33. (source
  34. (origin
  35. (method url-fetch)
  36. (uri (string-append "http://gkrellm.srcbox.net/releases/gkrellm-"
  37. version ".tar.bz2"))
  38. (sha256
  39. (base32 "01lccz4fga40isv09j8rjgr0qy10rff9vj042n6gi6gdv4z69q0y"))))
  40. (build-system gnu-build-system)
  41. (inputs
  42. `(("gettext" ,gettext-minimal)
  43. ("gtk+" ,gtk+-2)
  44. ("libice" ,libice)
  45. ("libsm" ,libsm)))
  46. (native-inputs
  47. `(("pkg-config" ,pkg-config)))
  48. (arguments
  49. `(#:tests? #f ; there is no check target
  50. #:phases
  51. (modify-phases %standard-phases
  52. (delete 'configure)) ; no configure script
  53. #:make-flags
  54. (let ((out (assoc-ref %outputs "out")))
  55. (list (string-append "INSTALLROOT=" out)
  56. "CC=gcc"))))
  57. (home-page "http://gkrellm.srcbox.net/")
  58. (synopsis "System monitors")
  59. (description
  60. "GKrellM is a single process stack of system monitors which supports
  61. applying themes to match its appearance to your window manager, Gtk, or any
  62. other theme.")
  63. (license license:gpl3+)))