genealogy.scm 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
  3. ;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages genealogy)
  20. #:use-module (guix build-system python)
  21. #:use-module (guix git-download)
  22. #:use-module ((guix licenses) #:prefix license:)
  23. #:use-module (guix packages)
  24. #:use-module (gnu packages fonts)
  25. #:use-module (gnu packages freedesktop)
  26. #:use-module (gnu packages geo)
  27. #:use-module (gnu packages gettext)
  28. #:use-module (gnu packages ghostscript)
  29. #:use-module (gnu packages glib)
  30. #:use-module (gnu packages gnome)
  31. #:use-module (gnu packages graphviz)
  32. #:use-module (gnu packages gtk)
  33. #:use-module (gnu packages python)
  34. #:use-module (gnu packages python-xyz)
  35. #:use-module (gnu packages sqlite)
  36. #:use-module (gnu packages version-control))
  37. (define-public gramps
  38. (package
  39. (name "gramps")
  40. (version "5.1.3")
  41. (source
  42. (origin
  43. (method git-fetch)
  44. (uri (git-reference
  45. (url "https://github.com/gramps-project/gramps")
  46. (commit (string-append "v" version))))
  47. (file-name (git-file-name name version))
  48. (sha256
  49. (base32 "109dwkswz2h2328xkqk2zj736d117s9pp7rz5cc1qg2vxn1lpm93"))))
  50. (build-system python-build-system)
  51. (native-inputs
  52. `(("gettext" ,gettext-minimal)
  53. ("intltool" ,intltool)))
  54. (inputs
  55. `(("cairo" ,cairo)
  56. ("font-gnu-freefont" ,font-gnu-freefont)
  57. ("geocode-glib" ,geocode-glib)
  58. ("gexiv2" ,gexiv2)
  59. ("ghostscript" ,ghostscript)
  60. ("gobject-introspection" ,gobject-introspection)
  61. ("gtk+" ,gtk+)
  62. ("gtkspell3" ,gtkspell3)
  63. ("graphviz" ,graphviz)
  64. ("librsvg" ,librsvg)
  65. ("osm-gps-map" ,osm-gps-map)
  66. ("pango" ,pango)
  67. ("python-bsddb3" ,python-bsddb3)
  68. ("python-pillow" ,python-pillow)
  69. ("python-pycairo" ,python-pycairo)
  70. ("python-pygobject" ,python-pygobject)
  71. ("python-pyicu" ,python-pyicu)
  72. ("rcs" ,rcs)
  73. ("sqlite" ,sqlite)
  74. ("xdg-utils" ,xdg-utils)))
  75. (arguments
  76. `(#:imported-modules ((guix build glib-or-gtk-build-system)
  77. ,@%python-build-system-modules)
  78. #:modules ((ice-9 match)
  79. (guix build python-build-system)
  80. ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
  81. (guix build utils))
  82. #:phases
  83. (modify-phases %standard-phases
  84. (add-before 'check 'set-home-for-tests
  85. (lambda _
  86. (setenv "HOME" (getenv "TMPDIR"))
  87. #t))
  88. (add-before 'wrap 'wrap-with-GI_TYPELIB_PATH
  89. (lambda* (#:key inputs outputs #:allow-other-keys)
  90. (let ((out (assoc-ref outputs "out"))
  91. (paths (map (match-lambda
  92. ((output . directory)
  93. (let ((girepodir (string-append
  94. directory
  95. "/lib/girepository-1.0")))
  96. (if (file-exists? girepodir)
  97. girepodir
  98. #f))))
  99. inputs)))
  100. (wrap-program (string-append out "/bin/gramps")
  101. `("GI_TYPELIB_PATH" ":" prefix ,(filter identity paths))))
  102. #t))
  103. (add-after 'wrap 'glib-or-gtk-wrap
  104. (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
  105. (home-page "https://gramps-project.org")
  106. (synopsis "Genealogical research software")
  107. (description
  108. "Gramps is a free software project and community striving to produce
  109. a genealogy program that is both intuitive for hobbyists and feature-complete
  110. for professional genealogists.")
  111. (license license:gpl2+)))