gcal.scm 2.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2018 Ludovic Courtès <ludo@gnu.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages gcal)
  19. #:use-module (guix packages)
  20. #:use-module (guix download)
  21. #:use-module (guix build-system gnu)
  22. #:use-module (guix licenses))
  23. (define-public gcal
  24. (package
  25. (name "gcal")
  26. (version "4.1")
  27. (source (origin
  28. (method url-fetch)
  29. (uri (string-append "mirror://gnu/gcal/gcal-"
  30. version ".tar.xz"))
  31. (sha256
  32. (base32
  33. "1av11zkfirbixn05hyq4xvilin0ncddfjqzc4zd9pviyp506rdci"))
  34. (modules '((guix build utils)))
  35. (snippet
  36. '(begin
  37. ;; Adjust the bundled gnulib to work with glibc 2.28. See e.g.
  38. ;; "m4-gnulib-libio.patch". This is a phase rather than patch
  39. ;; or snippet to work around <https://bugs.gnu.org/32347>.
  40. (substitute* (find-files "lib" "\\.c$")
  41. (("#if defined _IO_ftrylockfile")
  42. "#if defined _IO_EOF_SEEN"))
  43. (substitute* "lib/stdio-impl.h"
  44. (("^/\\* BSD stdio derived implementations")
  45. (string-append "#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN\n"
  46. "# define _IO_IN_BACKUP 0x100\n"
  47. "#endif\n\n"
  48. "/* BSD stdio derived implementations")))
  49. #t))))
  50. (build-system gnu-build-system)
  51. (home-page "https://www.gnu.org/software/gcal/")
  52. (synopsis "Calculating and printing a wide variety of calendars")
  53. (description
  54. "Gcal is a program to calculate and print calendars on the
  55. command-line. Calendars can be printed in 1-month, 3-month or whole-year
  56. views. In addition, eternal holiday lists can be generated for many
  57. countries, which can be complemented by user-made lists of fixed dates to
  58. make an agenda. Gcal can also calculate astronomical data, such as the
  59. phases of the moon, and supports alternative calendar formats: Julian,
  60. Gregorian, Islamic, Chinese and more.")
  61. (license gpl3+)))