freeipmi.scm 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2015, 2016, 2017, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2019–2021 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages freeipmi)
  21. #:use-module (guix packages)
  22. #:use-module (guix licenses)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (gnu packages gnupg))
  26. (define-public freeipmi
  27. (package
  28. (name "freeipmi")
  29. (version "1.6.8")
  30. (source (origin
  31. (method url-fetch)
  32. (uri (string-append "mirror://gnu/freeipmi/freeipmi-"
  33. version ".tar.gz"))
  34. (sha256
  35. (base32
  36. "0w8af1i57szmxl9vfifwwyal7xh8aixz2l9487wvy6yckqk6m92a"))))
  37. (build-system gnu-build-system)
  38. (arguments
  39. '(#:configure-flags '("--disable-static")))
  40. (inputs
  41. `(("libgcrypt" ,libgcrypt)))
  42. (home-page "https://www.gnu.org/software/freeipmi/")
  43. (synopsis "Platform management, including sensor and power monitoring")
  44. (description
  45. "GNU FreeIPMI is a collection of in-band and out-of-band IPMI software
  46. in accordance with the IPMI v1.5/2.0 specification. These programs provide a
  47. set of interfaces for platform management. Common functionality includes
  48. sensor monitoring, system event monitoring, power control and
  49. serial-over-LAN.")
  50. (license gpl3+)))