distributed.scm 3.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2019 Brant Gardner <brantcgardner@brantware.com>
  3. ;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages distributed)
  21. #:use-module (guix packages)
  22. #:use-module (guix utils)
  23. #:use-module (guix download)
  24. #:use-module (guix git-download)
  25. #:use-module (guix build-system gnu)
  26. #:use-module ((guix licenses) #:prefix license:)
  27. #:use-module (gnu packages)
  28. #:use-module (gnu packages autotools)
  29. #:use-module (gnu packages base)
  30. #:use-module (gnu packages compression)
  31. #:use-module (gnu packages databases)
  32. #:use-module (gnu packages pkg-config)
  33. #:use-module (gnu packages tls)
  34. #:use-module (gnu packages curl)
  35. #:use-module (gnu packages wxwidgets)
  36. #:use-module (gnu packages gnome)
  37. #:use-module (gnu packages gtk)
  38. #:use-module (gnu packages perl)
  39. #:use-module (gnu packages sqlite)
  40. #:use-module (gnu packages python)
  41. #:use-module (gnu packages python-xyz))
  42. (define-public boinc-client
  43. (package
  44. (name "boinc-client")
  45. (version "7.16.17")
  46. (source (origin
  47. (method git-fetch)
  48. (uri (git-reference
  49. (url "https://github.com/boinc/boinc")
  50. (commit (string-append "client_release/"
  51. (version-major+minor version)
  52. "/" version))))
  53. (file-name (git-file-name "boinc" version))
  54. (sha256
  55. (base32
  56. "1p8y3mnf5yfhavhqxwf9v68prg1601h8q1pllm5z89zh661di3mj"))))
  57. (build-system gnu-build-system)
  58. (arguments '(#:configure-flags '("--disable-server")))
  59. (inputs `(("openssl" ,openssl)
  60. ("curl" ,curl)
  61. ("wxwidgets" ,wxwidgets)
  62. ("gtk+" ,gtk+)
  63. ("gdk-pixbuf" ,gdk-pixbuf)
  64. ("libnotify" ,libnotify)
  65. ("sqlite" ,sqlite)
  66. ("python" ,python)
  67. ("python-pyserial" ,python-pyserial)))
  68. (native-inputs
  69. `(("autoconf" ,autoconf)
  70. ("automake" ,automake)
  71. ("libtool" ,libtool)
  72. ("pkg-config" ,pkg-config)))
  73. (synopsis "Help cutting-edge science research using your computer")
  74. (description "BOINC is a platform for high-throughput computing on a large
  75. scale (thousands or millions of computers). It can be used for volunteer
  76. computing (using consumer devices) or grid computing (using organizational
  77. resources). It supports virtualized, parallel, and GPU-based applications.")
  78. (home-page "https://boinc.berkeley.edu/")
  79. ;; BOINC is distributed as LGPL3+, with some individual modules under GPL3+.
  80. (license (list license:lgpl3+ license:gpl3+))))
  81. (define-public boinc-server
  82. ;; XXX The server and client packages duplicate many files such as /lib.
  83. ;; TODO: consolidate them?
  84. (package (inherit boinc-client)
  85. (name "boinc-server")
  86. (arguments '(#:configure-flags '("--disable-client" "--disable-manager")
  87. #:parallel-build? #f))
  88. (inputs `(("openssl" ,openssl)
  89. ("curl" ,curl)
  90. ("mariadb:dev" ,mariadb "dev")
  91. ("zlib" ,zlib)))
  92. (propagated-inputs `(("python" ,python-wrapper)
  93. ("perl" ,perl)))))