direct-connect.scm 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages direct-connect)
  19. #:use-module (guix build-system scons)
  20. #:use-module ((guix licenses) #:prefix license:)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (gnu packages boost)
  24. #:use-module (gnu packages compression)
  25. #:use-module (gnu packages gettext)
  26. #:use-module (gnu packages gnome)
  27. #:use-module (gnu packages gtk)
  28. #:use-module (gnu packages pkg-config)
  29. #:use-module (gnu packages python-xyz)
  30. #:use-module (gnu packages tls)
  31. #:use-module (gnu packages version-control))
  32. (define-public linuxdcpp
  33. (package
  34. (name "linuxdcpp")
  35. (version "1.1.0")
  36. (source
  37. (origin
  38. (method url-fetch)
  39. (uri (string-append
  40. "https://launchpad.net/linuxdcpp/1.1/1.1.0/+download/linuxdcpp-"
  41. version ".tar.bz2"))
  42. (sha256
  43. (base32
  44. "12i92hirmwryl1qy0n3jfrpziwzb82f61xca9jcjwyilx502f0b6"))))
  45. (build-system scons-build-system)
  46. (arguments
  47. `(#:scons ,scons-python2
  48. #:scons-flags (list (string-append "PREFIX=" %output))
  49. #:tests? #f)) ; no tests
  50. (inputs
  51. `(("boost" ,boost)
  52. ("bzip2" ,bzip2)
  53. ("gtk+" ,gtk+-2)
  54. ("libglade" ,libglade)
  55. ("libnotify" ,libnotify)
  56. ("openssl" ,openssl)))
  57. (native-inputs
  58. `(("bazaar" ,bazaar)
  59. ("gettext-minimal" ,gettext-minimal)
  60. ("pkg-config" ,pkg-config)))
  61. (home-page "https://launchpad.net/linuxdcpp/")
  62. (synopsis "Direct Connect client")
  63. (description "LinuxDC++ is a Direct Connect (DC) client. Direct Connect
  64. is a peer-to-peer file-sharing protocol. Clients connect to a central hub
  65. where they can chat or share files with one another. Users can view other
  66. users' list of shared files or search the hub for files.")
  67. (license license:gpl2+)))