cppi.scm 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages cppi)
  19. #:use-module (guix packages)
  20. #:use-module (guix download)
  21. #:use-module (guix build-system gnu)
  22. #:use-module (guix licenses))
  23. (define-public cppi
  24. (package
  25. (name "cppi")
  26. (version "1.18")
  27. (source (origin
  28. (method url-fetch)
  29. (uri (string-append "mirror://gnu/cppi/cppi-"
  30. version ".tar.xz"))
  31. (sha256
  32. (base32
  33. "1jk42cjaggk71rimjnx3qpmb6hivps0917vl3z7wbxk3i2whb98j"))))
  34. (build-system gnu-build-system)
  35. (home-page "https://www.gnu.org/software/cppi/")
  36. (synopsis "Indent C preprocessor directives to reflect nesting and more")
  37. (description
  38. "GNU Cppi processes C source code files to properly indent the
  39. preprocessor directives to reflect their nesting. It also performs other
  40. standardizations, such as correcting the number of spaces between directives
  41. and the text following them.")
  42. (license gpl3+)))