convmv.scm 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages convmv)
  19. #:use-module (gnu packages)
  20. #:use-module (gnu packages perl)
  21. #:use-module (guix licenses)
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu))
  25. (define-public convmv
  26. (package
  27. (name "convmv")
  28. (version "2.05")
  29. (source (origin
  30. (method url-fetch)
  31. (uri (string-append "https://www.j3e.de/linux/convmv/convmv-"
  32. version ".tar.gz"))
  33. (sha256
  34. (base32
  35. "19hwv197p7c23f43vvav5bs19z9b72jzca2npkjsxgprwj5ardjk"))))
  36. (build-system gnu-build-system)
  37. (arguments
  38. `(#:test-target "test"
  39. #:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out")))
  40. #:phases
  41. (modify-phases %standard-phases
  42. (delete 'bootstrap)
  43. (delete 'configure)
  44. (add-before 'check 'unpack-testsuite
  45. (lambda _
  46. (invoke "tar" "xf" "testsuite.tar")
  47. (patch-shebang "suite/dotests.sh")
  48. (patch-shebang "suite/parsable_tester.pl")
  49. #t)))))
  50. (inputs
  51. `(("perl" ,perl)))
  52. (synopsis "Convert filenames between character sets")
  53. (description
  54. "convmv is a file renamer, that converts between different encodings,
  55. e.g. from ISO-8859-1 to UTF-8. It is particularly usefuls for files with
  56. names, that display incorrectly.")
  57. (license (list gpl2 gpl3))
  58. (home-page "https://www.j3e.de/")))