configuration-management.scm 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages configuration-management)
  19. #:use-module (gnu packages)
  20. #:use-module (guix build-system go)
  21. #:use-module (guix git-download)
  22. #:use-module (gnu packages golang)
  23. #:use-module (gnu packages version-control)
  24. #:use-module (gnu packages textutils)
  25. #:use-module ((guix licenses) #:prefix license:)
  26. #:use-module (guix packages)
  27. #:use-module (guix utils))
  28. (define-public chezmoi
  29. (package
  30. (name "chezmoi")
  31. ;; XXX: Make sure 7f238faa61e46d79b54d4d0ea8f0b5fc27db84b2 applied before
  32. ;; version update, which should fix @code{password-store} integration.
  33. (version "1.8.1")
  34. (source (origin
  35. (method git-fetch)
  36. (uri (git-reference
  37. (url "https://github.com/twpayne/chezmoi")
  38. (commit (string-append "v" version))))
  39. (file-name (git-file-name name version))
  40. (sha256
  41. (base32
  42. "1b8y0wq3myhvjdnwl0i4x85iil7i7kmsjajvbw1a47afm83jkbaw"))))
  43. (build-system go-build-system)
  44. (arguments
  45. `(#:import-path "github.com/twpayne/chezmoi"
  46. ;; We don't need to install the source code for end-user applications.
  47. #:install-source? #f))
  48. (native-inputs
  49. `(("go-github-com-masterminds-sprig" ,go-github-com-masterminds-sprig)
  50. ("go-github-com-masterminds-goutils" ,go-github-com-masterminds-goutils)
  51. ("go-github-com-masterminds-semver" ,go-github-com-masterminds-semver)
  52. ("go-github-com-google-uuid" ,go-github-com-google-uuid)
  53. ("go-github-com-huandu-xstrings" ,go-github-com-huandu-xstrings)
  54. ("go-github-com-imdario-mergo" ,go-github-com-imdario-mergo)
  55. ("go-github-com-mitchellh-reflectwalk" ,go-github-com-mitchellh-reflectwalk)
  56. ("go-github-com-mitchellh-copystructure" ,go-github-com-mitchellh-copystructure)
  57. ("go-github-com-bmatcuk-doublestar" ,go-github-com-bmatcuk-doublestar)
  58. ("go-github-com-charmbracelet-glamour" ,go-github-com-charmbracelet-glamour)
  59. ("go-github-com-alecthomas-chroma" ,go-github-com-alecthomas-chroma)
  60. ("go-github-com-coreos-go-semver" ,go-github-com-coreos-go-semver)
  61. ("go-github-com-danwakefield-fnmatch" ,go-github-com-danwakefield-fnmatch)
  62. ("go-github-com-dlclark-regexp2" ,go-github-com-dlclark-regexp2)
  63. ("go-github-go-git" ,go-github-go-git)
  64. ("go-github-com-google-go-github" ,go-github-com-google-go-github)
  65. ("go-github-com-google-go-querystring" ,go-github-com-google-go-querystring)
  66. ("go-github-com-google-renameio" ,go-github-com-google-renameio)
  67. ("go-github-com-microcosm-cc-bluemonday",go-github-com-microcosm-cc-bluemonday)
  68. ("go-github-com-aymerick-douceur" ,go-github-com-aymerick-douceur)
  69. ("go-github-com-chris-ramon-douceur" ,go-github-com-chris-ramon-douceur)
  70. ("go-github-com-gorilla-css" ,go-github-com-gorilla-css)
  71. ("go-github-com-muesli-reflow-ansi" ,go-github-com-muesli-reflow-ansi)
  72. ("go-github-com-muesli-reflow-wordwrap" ,go-github-com-muesli-reflow-wordwrap)
  73. ("go-github-com-muesli-reflow-indent" ,go-github-com-muesli-reflow-indent)
  74. ("go-github-com-muesli-reflow-padding" ,go-github-com-muesli-reflow-padding)
  75. ("go-github-com-muesli-termenv" ,go-github-com-muesli-termenv)
  76. ("go-github-com-google-goterm" ,go-github-com-google-goterm)
  77. ("go-golang-org-colorful" ,go-golang-org-colorful)
  78. ("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
  79. ("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
  80. ("go-github-com-olekukonko-tablewriter" ,go-github-com-olekukonko-tablewriter)
  81. ("go-github-com-pelletier-go-toml" ,go-github-com-pelletier-go-toml)
  82. ("go-github-com-pkg-diff" ,go-github-com-pkg-diff)
  83. ("go-github-com-sergi-go-diff" ,go-github-com-sergi-go-diff)
  84. ("go-github-com-spf13-cobra" ,go-github-com-spf13-cobra)
  85. ("go-github-com-spf13-viper" ,go-github-com-spf13-viper)
  86. ("go-github-com-twpayne-go-shell" ,go-github-com-twpayne-go-shell)
  87. ("go-github-com-twpayne-go-vfs" ,go-github-com-twpayne-go-vfs)
  88. ("go-github-com-twpayne-go-vfsafero" ,go-github-com-twpayne-go-vfsafero)
  89. ("go-github-com-twpayne-go-xdg" ,go-github-com-twpayne-go-xdg)
  90. ("go-github-com-yuin-goldmark" ,go-github-com-yuin-goldmark)
  91. ("go-github-com-zalando-go-keyring" ,go-github-com-zalando-go-keyring)
  92. ("go-github-com-godbus-dbus" ,go-github-com-godbus-dbus)
  93. ("go-etcd-io-bbolt" ,go-etcd-io-bbolt)
  94. ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
  95. ("go-golang-org-x-net" ,go-golang-org-x-net)
  96. ("go-golang-org-x-oauth2" ,go-golang-org-x-oauth2)
  97. ("go-github-com-rogpeppe-go-internal" ,go-github-com-rogpeppe-go-internal)
  98. ("gopkg-in-errgo-fmt-errors" ,gopkg-in-errgo-fmt-errors)))
  99. (home-page "https://www.chezmoi.io/")
  100. (synopsis "Personal configuration files manager")
  101. (description "This package helps to manage personal configuration files
  102. across multiple machines.")
  103. (license license:expat)))