cinnamon.scm 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017 Nikita <nikita@n0.is>
  3. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages cinnamon)
  21. #:use-module ((guix licenses) #:prefix license:)
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix git-download)
  25. #:use-module (guix utils)
  26. #:use-module (guix build-system gnu)
  27. #:use-module (gnu packages)
  28. #:use-module (gnu packages autotools)
  29. #:use-module (gnu packages freedesktop)
  30. #:use-module (gnu packages gettext)
  31. #:use-module (gnu packages glib)
  32. #:use-module (gnu packages gtk)
  33. #:use-module (gnu packages gnome)
  34. #:use-module (gnu packages pkg-config)
  35. #:use-module (gnu packages pulseaudio)
  36. #:use-module (gnu packages python)
  37. #:use-module (gnu packages xorg))
  38. (define-public cinnamon-desktop
  39. (package
  40. (name "cinnamon-desktop")
  41. (version "3.4.2")
  42. (source (origin
  43. (method git-fetch)
  44. (uri (git-reference
  45. (url "https://github.com/linuxmint/cinnamon-desktop")
  46. (commit version)))
  47. (file-name (git-file-name name version))
  48. (sha256
  49. (base32
  50. "18mjy80ly9361npjhxpm3n0pkmrwviaqr2kixjb7hyxa6kzzh5xw"))))
  51. (build-system gnu-build-system)
  52. ;; TODO: package 'libgsystem'.
  53. (inputs
  54. `(("accountsservice" ,accountsservice)
  55. ("gtk+" ,gtk+)
  56. ("glib" ,glib)
  57. ("gobject-introspection" ,gobject-introspection)
  58. ("gnome-common" ,gnome-common)
  59. ("libxkbfile" ,libxkbfile)
  60. ("libxrandr" ,libxrandr)
  61. ("python-2" ,python-2)
  62. ("pulseaudio" ,pulseaudio)
  63. ("xkeyboard-config" ,xkeyboard-config)))
  64. (native-inputs
  65. `(("autoconf" ,autoconf)
  66. ("automake" ,automake)
  67. ("gettext" ,gettext-minimal)
  68. ("glib" ,glib "bin") ; glib-gettextize
  69. ("intltool" ,intltool)
  70. ("libtool" ,libtool)
  71. ("pkg-config" ,pkg-config)))
  72. (home-page "https://github.com/linuxmint/cinnamon-desktop/")
  73. (synopsis "Library for the Cinnamon Desktop")
  74. (description
  75. "The cinnamon-desktop package contains the libcinnamon-desktop library,
  76. as well as some desktop-wide documents.")
  77. (license (list license:gpl2+ license:lgpl2.0+
  78. license:expat)))) ;display-name.c , edid-parse.c