augeas.scm 2.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
  3. ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
  5. ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages augeas)
  22. #:use-module ((guix licenses) #:prefix license:)
  23. #:use-module (guix packages)
  24. #:use-module (guix download)
  25. #:use-module (guix utils)
  26. #:use-module (guix build-system gnu)
  27. #:use-module (gnu packages)
  28. #:use-module (gnu packages readline)
  29. #:use-module (gnu packages pkg-config)
  30. #:use-module (gnu packages xml))
  31. (define-public augeas
  32. (package
  33. (name "augeas")
  34. (version "1.12.0")
  35. (source (origin
  36. (method url-fetch)
  37. (uri (string-append "http://download.augeas.net/augeas-"
  38. version ".tar.gz"))
  39. (sha256
  40. (base32
  41. "11ybhb13wkkilsn7b416a1dn61m1xrq0lbdpkhp5w61jrk4l469j"))))
  42. (build-system gnu-build-system)
  43. ;; Marked as "required" in augeas.pc.
  44. (propagated-inputs
  45. `(("libxml2" ,libxml2)))
  46. (inputs
  47. `(("readline" ,readline)))
  48. (native-inputs
  49. `(("pkg-config" ,pkg-config)))
  50. (home-page "https://augeas.net")
  51. (synopsis "Edit configuration files programmatically")
  52. (description
  53. "Augeas is a library and command line tool for programmatically editing
  54. configuration files in a controlled manner. Augeas exposes a tree of all
  55. configuration settings and a simple local API for manipulating the tree.
  56. Augeas then modifies underlying configuration files according to the changes
  57. that have been made to the tree; it does as little modeling of configurations
  58. as possible, and focuses exclusivley on transforming the tree-oriented syntax
  59. of its public API to the myriad syntaxes of individual configuration files.")
  60. (license license:lgpl2.1+)))