antivirus.scm 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
  3. ;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
  4. ;;; Copyright © 2019–2021 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages antivirus)
  21. #:use-module ((guix licenses) #:prefix license:)
  22. #:use-module (guix build-system gnu)
  23. #:use-module (guix packages)
  24. #:use-module (guix download)
  25. #:use-module (guix utils)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages autotools)
  28. #:use-module (gnu packages bison)
  29. #:use-module (gnu packages check)
  30. #:use-module (gnu packages compression)
  31. #:use-module (gnu packages curl)
  32. #:use-module (gnu packages cyrus-sasl)
  33. #:use-module (gnu packages flex)
  34. #:use-module (gnu packages llvm)
  35. #:use-module (gnu packages multiprecision)
  36. #:use-module (gnu packages ncurses)
  37. #:use-module (gnu packages pcre)
  38. #:use-module (gnu packages pkg-config)
  39. #:use-module (gnu packages tls)
  40. #:use-module (gnu packages web)
  41. #:use-module (gnu packages xml))
  42. (define-public clamav
  43. (package
  44. (name "clamav")
  45. (version "0.103.3")
  46. (source (origin
  47. (method url-fetch)
  48. (uri (string-append "https://www.clamav.net/downloads/production/"
  49. "clamav-" version ".tar.gz"))
  50. (sha256
  51. (base32
  52. "1sba4zccgwjqk29b5qkgfc9gm794hmk6j7bpj8wilgcz8hc3svlz"))
  53. (modules '((guix build utils)))
  54. (snippet
  55. '(begin
  56. (for-each delete-file-recursively
  57. '("win32" ; unnecessary
  58. "libclamav/c++/llvm" ; use system llvm
  59. "libclamav/tomsfastmath" ; use system tomsfastmath
  60. "libclamunrar")) ; non-free license
  61. #t))
  62. (patches
  63. (search-patches "clamav-system-tomsfastmath.patch"
  64. "clamav-config-llvm-libs.patch"))))
  65. (build-system gnu-build-system)
  66. (native-inputs
  67. `(("autoconf" ,autoconf)
  68. ("automake" ,automake)
  69. ("check" ,check) ; for tests
  70. ("libtool" ,libtool)
  71. ("pkg-config" ,pkg-config)))
  72. (inputs
  73. `(("bzip2" ,bzip2)
  74. ("libcurl" ,curl)
  75. ("libjson" ,json-c)
  76. ("libltdl" ,libltdl)
  77. ("libmspack" ,libmspack)
  78. ("llvm" ,llvm-3.6) ; requires <3.7, for JIT/verifier
  79. ("ncurses" ,ncurses)
  80. ("openssl" ,libressl)
  81. ("pcre2" ,pcre2)
  82. ("sasl" ,cyrus-sasl) ; for linking curl with libtool
  83. ("tomsfastmath" ,tomsfastmath)
  84. ("xml" ,libxml2)
  85. ("zlib" ,zlib)))
  86. (arguments
  87. `(#:configure-flags
  88. (let-syntax ((with (syntax-rules ()
  89. ((_ name)
  90. (string-append "--with-" name "="
  91. (assoc-ref %build-inputs name))))))
  92. (list "--disable-unrar"
  93. "--enable-llvm"
  94. "--with-system-llvm"
  95. "--with-system-libmspack"
  96. "--without-included-ltdl"
  97. (with "xml")
  98. (with "openssl")
  99. (with "libjson")
  100. (with "pcre2")
  101. (with "zlib")
  102. (with "libcurl")
  103. ;; For sanity, specifying --enable-* flags turns
  104. ;; "support unavailable" warnings into errors.
  105. "--enable-bzip2"
  106. "--enable-check"
  107. "--sysconfdir=/etc/clamav"
  108. ;; Default database directory needs to be writeable
  109. "--with-dbdir=/var/db/clamav"))
  110. ;; install sample .conf files to %output/etc rather than /etc/clamav
  111. #:make-flags (list (string-append "sysconfdir=" %output "/etc"))
  112. #:phases (modify-phases %standard-phases
  113. ;; Regenerate configure script. Without this we don't get
  114. ;; the correct value for LLVM linker variables.
  115. (add-after 'unpack 'reconf
  116. (lambda _ (invoke "autoreconf" "-vfi")))
  117. (add-before 'configure 'patch-llvm-config
  118. (lambda _
  119. (substitute* '("libclamav/c++/detect.cpp"
  120. "libclamav/c++/ClamBCRTChecks.cpp"
  121. "libclamav/c++/bytecode2llvm.cpp")
  122. (("llvm/Config/config.h") "llvm/Config/llvm-config.h"))
  123. ;; `llvm-config --libfiles` inappropriately lists lib*.a
  124. ;; libraries, rather than the lib*.so's that our llvm
  125. ;; contains. They're used only for listing extra build
  126. ;; dependencies, so ignore them until that's fixed.
  127. (substitute* "libclamav/c++/Makefile.in"
  128. (("@LLVMCONFIG_LIBFILES@") ""))
  129. #t))
  130. (add-before 'check 'skip-clamd-tests
  131. ;; XXX: The check?_clamd tests fail inside the build
  132. ;; chroot, but pass outside.
  133. (lambda _
  134. (substitute* "unit_tests/Makefile"
  135. (("check2_clamd.sh.*check4_clamd.sh") ""))
  136. #t)))))
  137. (home-page "https://www.clamav.net")
  138. (synopsis "Antivirus engine")
  139. (description
  140. "Clam AntiVirus is an anti-virus toolkit, designed especially for e-mail
  141. scanning on mail gateways. It provides a number of utilities including a
  142. flexible and scalable multi-threaded daemon, a command line scanner, and
  143. advanced tool for automatic database updates. The core of the package is an
  144. anti-virus engine available in the form of a shared library.")
  145. (license (list license:gpl2+ ;ClamAV itself
  146. license:lgpl2.1 ;libclamav/mspack.[ch]
  147. license:public-domain ;libclamav/7z/*, libclamav/rijndael.[ch], etc...
  148. (package-license bzip2) ;modified bzip2 source in libclamav/nsis
  149. license:bsd-2 ;several files in libclamav
  150. license:bsd-3 ;libclamav/{regex,qsort.c,swf.[ch]
  151. license:ncsa ;libclamav/c++/PointerTracking.cpp
  152. license:zlib ;libclamav/inf*.h
  153. license:x11 ;libclamav/lzw
  154. (license:non-copyleft "libclamav/strlcat.c") ;"OpenBSD" license
  155. license:asl2.0 ;libclamav/yara*
  156. license:expat)))) ;shared/getopt.[ch]