manifest.scm 2.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374
  1. ;;; Copyright © 2023 Free Software Foundation, Inc.
  2. ;;;
  3. ;;; This file is part of GNU Guile.
  4. ;;;
  5. ;;; GNU Guile is free software; you can redistribute it and/or modify it
  6. ;;; under the terms of the GNU General Public License as published by
  7. ;;; the Free Software Foundation; either version 3 of the License, or (at
  8. ;;; your option) any later version.
  9. ;;;
  10. ;;; GNU Guile is distributed in the hope that it will be useful, but
  11. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  12. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  13. ;;; GNU General Public License for more details.
  14. ;;;
  15. ;;; You should have received a copy of the GNU General Public License
  16. ;;; along with GNU Guile. If not, see <http://www.gnu.org/licenses/>.
  17. ;; This file defines a Guix manifest for use by Cuirass, the continuous
  18. ;; integration service running at <https://ci.guix.gnu.org>.
  19. (use-modules (guix)
  20. (guix profiles)
  21. (guile-package))
  22. (define* (package->manifest-entry* package system
  23. #:key target)
  24. "Return a manifest entry for PACKAGE on SYSTEM, optionally cross-compiled to
  25. TARGET."
  26. (manifest-entry
  27. (inherit (package->manifest-entry package))
  28. (name (string-append (package-name package) "." system
  29. (if target
  30. (string-append "." target)
  31. "")))
  32. (item (with-parameters ((%current-system system)
  33. (%current-target-system target))
  34. package))))
  35. (define native-builds
  36. (manifest
  37. (append (map (lambda (system)
  38. (package->manifest-entry* guile system))
  39. '("x86_64-linux" "i686-linux"
  40. "aarch64-linux" "armhf-linux"
  41. "powerpc64le-linux"))
  42. (map (lambda (guile)
  43. (package->manifest-entry* guile "x86_64-linux"))
  44. (cons (package
  45. (inherit (package-with-c-toolchain
  46. guile
  47. `(("clang-toolchain"
  48. ,(specification->package
  49. "clang-toolchain")))))
  50. (name "guile-clang"))
  51. (list guile-without-threads
  52. guile-without-networking
  53. guile-debug
  54. guile-strict-typing))))))
  55. (define cross-builds
  56. (manifest
  57. (map (lambda (target)
  58. (package->manifest-entry* guile "x86_64-linux"
  59. #:target target))
  60. '("i586-pc-gnu"
  61. ;; "arm-linux-gnueabihf"
  62. "aarch64-linux-gnu"
  63. "riscv64-linux-gnu"
  64. "i686-w64-mingw32"
  65. "x86_64-linux-gnu"))))
  66. (concatenate-manifests (list native-builds cross-builds))