default.nix 974 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. { pkgs ? (import <nixpkgs> {}) }:
  2. let
  3. env = with pkgs.haskellPackages; [
  4. pandoc
  5. pandoc-crossref
  6. (pkgs.texlive.combine {
  7. inherit (pkgs.texlive)
  8. scheme-basic
  9. amsfonts
  10. amsmath
  11. lm
  12. ifxetex
  13. ifluatex
  14. eurosym
  15. listings
  16. fancyvrb
  17. # longtable
  18. booktabs
  19. # no graphics...
  20. # graphicx
  21. # grffile
  22. hyperref
  23. ulem
  24. geometry
  25. setspace
  26. babel
  27. subfig
  28. caption
  29. # optionals
  30. upquote
  31. microtype
  32. csquotes
  33. # We have no citation support
  34. # natbib
  35. # biblatex
  36. # bibtex
  37. # biber
  38. # some more, not listed in the pandoc docs
  39. mathtools
  40. enumitem
  41. ;
  42. })
  43. pkgs.lmodern
  44. pkgs.which
  45. ];
  46. in
  47. pkgs.stdenv.mkDerivation rec {
  48. name = "imag-doc";
  49. src = ./.;
  50. version = "0.0.0";
  51. buildInputs = [ env ];
  52. }