default.nix 363 B

12345678910111213141516171819202122232425262728293031
  1. { pkgs ? (import <nixpkgs> {}) }:
  2. let
  3. env = with pkgs.rustStable; [
  4. rustc
  5. cargo
  6. ];
  7. dependencies = with pkgs; [
  8. bundler
  9. cmake
  10. curl
  11. gcc
  12. libpsl
  13. openssl
  14. pkgconfig
  15. which
  16. zlib
  17. ];
  18. in
  19. pkgs.stdenv.mkDerivation rec {
  20. name = "imag";
  21. src = ./.;
  22. version = "0.0.0";
  23. buildInputs = env ++ dependencies;
  24. }