httpd.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524
  1. %define contentdir /var/www
  2. %define suexec_caller apache
  3. %define mmn 20051115
  4. %define mpms worker event
  5. Summary: Apache HTTP Server
  6. Name: httpd
  7. Version: 2.2.15
  8. Release: 1
  9. URL: http://httpd.apache.org/
  10. Vendor: Apache Software Foundation
  11. Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
  12. License: Apache License, Version 2.0
  13. Group: System Environment/Daemons
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildPrereq: apr-devel, apr-util-devel, openldap-devel, db4-devel, expat-devel, findutils, perl, pkgconfig, pcre-devel >= 5.0
  16. BuildPrereq: /usr/bin/apr-1-config, /usr/bin/apu-1-config
  17. Requires: apr >= 1.2.0, apr-util >= 1.2.0, pcre >= 5.0, gawk, /usr/share/magic.mime, /usr/bin/find, openldap
  18. Prereq: /sbin/chkconfig, /bin/mktemp, /bin/rm, /bin/mv
  19. Prereq: sh-utils, textutils, /usr/sbin/useradd
  20. Provides: webserver
  21. Provides: httpd-mmn = %{mmn}
  22. Conflicts: thttpd
  23. Obsoletes: apache, secureweb, mod_dav
  24. %description
  25. Apache is a powerful, full-featured, efficient, and freely-available
  26. Web server. Apache is also the most popular Web server on the
  27. Internet.
  28. %package devel
  29. Group: Development/Libraries
  30. Summary: Development tools for the Apache HTTP server.
  31. Obsoletes: secureweb-devel, apache-devel
  32. Requires: libtool, httpd = %{version}
  33. Requires: apr-devel >= 1.2.0, apr-util-devel >= 1.2.0
  34. %description devel
  35. The httpd-devel package contains the APXS binary and other files
  36. that you need to build Dynamic Shared Objects (DSOs) for Apache.
  37. If you are installing the Apache HTTP server and you want to be
  38. able to compile or develop additional modules for Apache, you need
  39. to install this package.
  40. %package manual
  41. Group: Documentation
  42. Summary: Documentation for the Apache HTTP server.
  43. Obsoletes: secureweb-manual, apache-manual
  44. %description manual
  45. The httpd-manual package contains the complete manual and
  46. reference guide for the Apache HTTP server. The information can
  47. also be found at http://httpd.apache.org/docs/.
  48. %package -n mod_ssl
  49. Group: System Environment/Daemons
  50. Summary: SSL/TLS module for the Apache HTTP server
  51. BuildPrereq: openssl-devel
  52. Prereq: openssl, dev, /bin/cat
  53. Requires: httpd, make, httpd-mmn = %{mmn}
  54. %description -n mod_ssl
  55. The mod_ssl module provides strong cryptography for the Apache Web
  56. server via the Secure Sockets Layer (SSL) and Transport Layer
  57. Security (TLS) protocols.
  58. %prep
  59. %setup -q
  60. # Safety check: prevent build if defined MMN does not equal upstream MMN.
  61. vmmn=`echo MODULE_MAGIC_NUMBER_MAJOR | cpp -include include/ap_mmn.h | sed -n '
  62. /^2/p'`
  63. if test "x${vmmn}" != "x%{mmn}"; then
  64. : Error: Upstream MMN is now ${vmmn}, packaged MMN is %{mmn}.
  65. : Update the mmn macro and rebuild.
  66. exit 1
  67. fi
  68. %build
  69. # forcibly prevent use of bundled apr, apr-util, pcre
  70. rm -rf srclib/{apr,apr-util,pcre}
  71. # Before configure; fix location of build dir in generated apxs
  72. %{__perl} -pi -e "s:\@exp_installbuilddir\@:%{_libdir}/httpd/build:g" \
  73. support/apxs.in
  74. function mpmbuild()
  75. {
  76. mpm=$1; shift
  77. mkdir $mpm; pushd $mpm
  78. ../configure \
  79. --prefix=%{_sysconfdir}/httpd \
  80. --with-apr=/usr/bin/apr-1-config \
  81. --with-apr-util=/usr/bin/apu-1-config \
  82. --with-pcre=/usr/bin/pcre-config \
  83. --exec-prefix=%{_prefix} \
  84. --bindir=%{_bindir} \
  85. --sbindir=%{_sbindir} \
  86. --mandir=%{_mandir} \
  87. --libdir=%{_libdir} \
  88. --sysconfdir=%{_sysconfdir}/httpd/conf \
  89. --includedir=%{_includedir}/httpd \
  90. --libexecdir=%{_libdir}/httpd/modules \
  91. --datadir=%{contentdir} \
  92. --with-installbuilddir=%{_libdir}/httpd/build \
  93. --with-mpm=$mpm \
  94. --enable-suexec --with-suexec \
  95. --with-suexec-caller=%{suexec_caller} \
  96. --with-suexec-docroot=%{contentdir} \
  97. --with-suexec-logfile=%{_localstatedir}/log/httpd/suexec.log \
  98. --with-suexec-bin=%{_sbindir}/suexec \
  99. --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
  100. --enable-pie \
  101. --with-pcre \
  102. $*
  103. make %{?_smp_mflags}
  104. popd
  105. }
  106. # Build everything and the kitchen sink with the prefork build
  107. mpmbuild prefork \
  108. --enable-mods-shared=all \
  109. --enable-ssl --with-ssl --enable-distcache \
  110. --enable-proxy \
  111. --enable-cache \
  112. --enable-disk-cache \
  113. --enable-ldap --enable-authnz-ldap \
  114. --enable-cgid \
  115. --enable-authn-anon --enable-authn-alias \
  116. --disable-imagemap
  117. # For the other MPMs, just build httpd and no optional modules
  118. for f in %{mpms}; do
  119. mpmbuild $f --enable-mods-shared=all
  120. done
  121. %install
  122. rm -rf $RPM_BUILD_ROOT
  123. pushd prefork
  124. make DESTDIR=$RPM_BUILD_ROOT install
  125. popd
  126. # install alternative MPMs
  127. for f in %{mpms}; do
  128. install -m 755 ${f}/httpd $RPM_BUILD_ROOT%{_sbindir}/httpd.${f}
  129. done
  130. # for holding mod_dav lock database
  131. mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
  132. # create a prototype session cache
  133. mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
  134. touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
  135. # move the build directory to within the library directory
  136. mv $RPM_BUILD_ROOT%{contentdir}/build $RPM_BUILD_ROOT%{_libdir}/httpd/build
  137. # Make the MMN accessible to module packages
  138. echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/httpd/.mmn
  139. # docroot
  140. mkdir $RPM_BUILD_ROOT%{contentdir}/html
  141. # Set up /var directories
  142. rmdir $RPM_BUILD_ROOT%{_sysconfdir}/httpd/logs
  143. mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/httpd
  144. mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/httpd/cache-root
  145. # symlinks for /etc/httpd
  146. ln -s ../..%{_localstatedir}/log/httpd $RPM_BUILD_ROOT/etc/httpd/logs
  147. ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/httpd/run
  148. ln -s ../..%{_libdir}/httpd/modules $RPM_BUILD_ROOT/etc/httpd/modules
  149. # install SYSV init stuff
  150. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
  151. install -m755 ./build/rpm/httpd.init \
  152. $RPM_BUILD_ROOT/etc/rc.d/init.d/httpd
  153. install -m755 ./build/rpm/htcacheclean.init \
  154. $RPM_BUILD_ROOT/etc/rc.d/init.d/htcacheclean
  155. # install log rotation stuff
  156. mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
  157. install -m644 ./build/rpm/httpd.logrotate \
  158. $RPM_BUILD_ROOT/etc/logrotate.d/httpd
  159. # Remove unpackaged files
  160. rm -rf $RPM_BUILD_ROOT%{_libdir}/httpd/modules/*.exp \
  161. $RPM_BUILD_ROOT%{contentdir}/htdocs/* \
  162. $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
  163. # Make suexec a+rw so it can be stripped. %%files lists real permissions
  164. chmod 755 $RPM_BUILD_ROOT%{_sbindir}/suexec
  165. %pre
  166. # Add the "apache" user
  167. /usr/sbin/useradd -c "Apache" -u 48 \
  168. -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
  169. %post
  170. # Register the httpd service
  171. /sbin/chkconfig --add httpd
  172. /sbin/chkconfig --add htcacheclean
  173. %preun
  174. if [ $1 = 0 ]; then
  175. /sbin/service httpd stop > /dev/null 2>&1
  176. /sbin/service htcacheclean stop > /dev/null 2>&1
  177. /sbin/chkconfig --del httpd
  178. /sbin/chkconfig --del htcacheclean
  179. fi
  180. %post -n mod_ssl
  181. umask 077
  182. if [ ! -f %{_sysconfdir}/httpd/conf/ssl.key/server.key ] ; then
  183. %{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/httpd/conf/ssl.key/server.key 2> /dev/null
  184. fi
  185. FQDN=`hostname`
  186. if [ "x${FQDN}" = "x" ]; then
  187. FQDN=localhost.localdomain
  188. fi
  189. if [ ! -f %{_sysconfdir}/httpd/conf/ssl.crt/server.crt ] ; then
  190. cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/httpd/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/httpd/conf/ssl.crt/server.crt 2>/dev/null
  191. --
  192. SomeState
  193. SomeCity
  194. SomeOrganization
  195. SomeOrganizationalUnit
  196. ${FQDN}
  197. root@${FQDN}
  198. EOF
  199. fi
  200. %check
  201. # Check the built modules are all PIC
  202. if readelf -d $RPM_BUILD_ROOT%{_libdir}/httpd/modules/*.so | grep TEXTREL; then
  203. : modules contain non-relocatable code
  204. exit 1
  205. fi
  206. # Verify that the same modules were built into the httpd binaries
  207. ./prefork/httpd -l | grep -v prefork > prefork.mods
  208. for mpm in %{mpms}; do
  209. ./${mpm}/httpd -l | grep -v ${mpm} > ${mpm}.mods
  210. if ! diff -u prefork.mods ${mpm}.mods; then
  211. : Different modules built into httpd binaries, will not proceed
  212. exit 1
  213. fi
  214. done
  215. %clean
  216. rm -rf $RPM_BUILD_ROOT
  217. %files
  218. %defattr(-,root,root)
  219. %doc ABOUT_APACHE README CHANGES LICENSE NOTICE
  220. %dir %{_sysconfdir}/httpd
  221. %{_sysconfdir}/httpd/modules
  222. %{_sysconfdir}/httpd/logs
  223. %{_sysconfdir}/httpd/run
  224. %dir %{_sysconfdir}/httpd/conf
  225. %config(noreplace) %{_sysconfdir}/httpd/conf/httpd.conf
  226. %config(noreplace) %{_sysconfdir}/httpd/conf/magic
  227. %config(noreplace) %{_sysconfdir}/httpd/conf/mime.types
  228. %config(noreplace) %{_sysconfdir}/httpd/conf/extra/httpd-autoindex.conf
  229. %config(noreplace) %{_sysconfdir}/httpd/conf/extra/httpd-dav.conf
  230. %config(noreplace) %{_sysconfdir}/httpd/conf/extra/httpd-default.conf
  231. %config(noreplace) %{_sysconfdir}/httpd/conf/extra/httpd-info.conf
  232. %config(noreplace) %{_sysconfdir}/httpd/conf/extra/httpd-languages.conf
  233. %config(noreplace) %{_sysconfdir}/httpd/conf/extra/httpd-manual.conf
  234. %config(noreplace) %{_sysconfdir}/httpd/conf/extra/httpd-mpm.conf
  235. %config(noreplace) %{_sysconfdir}/httpd/conf/extra/httpd-multilang-errordoc.conf
  236. %config(noreplace) %{_sysconfdir}/httpd/conf/extra/httpd-userdir.conf
  237. %config(noreplace) %{_sysconfdir}/httpd/conf/extra/httpd-vhosts.conf
  238. %config(noreplace) %{_sysconfdir}/httpd/conf/original/extra/httpd-autoindex.conf
  239. %config(noreplace) %{_sysconfdir}/httpd/conf/original/extra/httpd-dav.conf
  240. %config(noreplace) %{_sysconfdir}/httpd/conf/original/extra/httpd-default.conf
  241. %config(noreplace) %{_sysconfdir}/httpd/conf/original/extra/httpd-info.conf
  242. %config(noreplace) %{_sysconfdir}/httpd/conf/original/extra/httpd-languages.conf
  243. %config(noreplace) %{_sysconfdir}/httpd/conf/original/extra/httpd-manual.conf
  244. %config(noreplace) %{_sysconfdir}/httpd/conf/original/extra/httpd-mpm.conf
  245. %config(noreplace) %{_sysconfdir}/httpd/conf/original/extra/httpd-multilang-errordoc.conf
  246. %config(noreplace) %{_sysconfdir}/httpd/conf/original/extra/httpd-userdir.conf
  247. %config(noreplace) %{_sysconfdir}/httpd/conf/original/extra/httpd-vhosts.conf
  248. %config(noreplace) %{_sysconfdir}/httpd/conf/original/httpd.conf
  249. %config %{_sysconfdir}/logrotate.d/httpd
  250. %config %{_sysconfdir}/rc.d/init.d/httpd
  251. %config %{_sysconfdir}/rc.d/init.d/htcacheclean
  252. %{_sbindir}/ab
  253. %{_sbindir}/htcacheclean
  254. %{_sbindir}/htdbm
  255. %{_sbindir}/htdigest
  256. %{_sbindir}/htpasswd
  257. %{_sbindir}/logresolve
  258. %{_sbindir}/httpd
  259. %{_sbindir}/httpd.worker
  260. %{_sbindir}/httpd.event
  261. %{_sbindir}/httxt2dbm
  262. %{_sbindir}/apachectl
  263. %{_sbindir}/rotatelogs
  264. %attr(4510,root,%{suexec_caller}) %{_sbindir}/suexec
  265. %dir %{_libdir}/httpd
  266. %dir %{_libdir}/httpd/modules
  267. # everything but mod_ssl.so:
  268. %{_libdir}/httpd/modules/mod_[a-r]*.so
  269. %{_libdir}/httpd/modules/mod_s[petu]*.so
  270. %{_libdir}/httpd/modules/mod_[t-z]*.so
  271. %dir %{contentdir}
  272. %dir %{contentdir}/cgi-bin
  273. %dir %{contentdir}/html
  274. %dir %{contentdir}/icons
  275. %dir %{contentdir}/error
  276. %dir %{contentdir}/error/include
  277. %{contentdir}/icons/*
  278. %{contentdir}/error/README
  279. %config(noreplace) %{contentdir}/error/*.var
  280. %config(noreplace) %{contentdir}/error/include/*.html
  281. %attr(0700,root,root) %dir %{_localstatedir}/log/httpd
  282. %attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
  283. %attr(0700,apache,apache) %dir %{_localstatedir}/cache/httpd/cache-root
  284. %{_mandir}/man1/*
  285. %{_mandir}/man8/ab*
  286. %{_mandir}/man8/rotatelogs*
  287. %{_mandir}/man8/logresolve*
  288. %{_mandir}/man8/suexec*
  289. %{_mandir}/man8/apachectl.8*
  290. %{_mandir}/man8/httpd.8*
  291. %{_mandir}/man8/htcacheclean.8*
  292. %files manual
  293. %defattr(-,root,root)
  294. %{contentdir}/manual
  295. %{contentdir}/error/README
  296. %files -n mod_ssl
  297. %defattr(-,root,root)
  298. %{_libdir}/httpd/modules/mod_ssl.so
  299. %config(noreplace) %{_sysconfdir}/httpd/conf/original/extra/httpd-ssl.conf
  300. %config(noreplace) %{_sysconfdir}/httpd/conf/extra/httpd-ssl.conf
  301. %attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
  302. %attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
  303. %attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
  304. %attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
  305. %files devel
  306. %defattr(-,root,root)
  307. %{_includedir}/httpd
  308. %{_sbindir}/apxs
  309. %{_sbindir}/checkgid
  310. %{_sbindir}/dbmmanage
  311. %{_sbindir}/envvars*
  312. %{_mandir}/man8/apxs.8*
  313. %dir %{_libdir}/httpd/build
  314. %{_libdir}/httpd/build/*.mk
  315. %{_libdir}/httpd/build/instdso.sh
  316. %{_libdir}/httpd/build/config.nice
  317. %{_libdir}/httpd/build/mkdir.sh
  318. %changelog
  319. * Mon Mar 27 2006 Graham Leggett <minfrin@apache.org> 2.2.1-dev
  320. - Update dependancies on apr and apr-util to at least v1.2.0.
  321. - Add the missing file-cache module to the cache build.
  322. * Fri Aug 26 2005 Graham Leggett <minfrin@apache.org> 2.1.7
  323. - Deleting the xml doc files is no longer necessary.
  324. - Add httxt2dbm to the sbin directory
  325. * Sat Jul 2 2005 Graham Leggett <minfrin@apache.org> 2.1.7-dev
  326. - Fixed complaints about unpackaged files with new config file changes.
  327. * Thu Dec 16 2004 Graham Leggett <minfrin@apache.org> 2.1.3-dev
  328. - Changed build to use external apr and apr-util
  329. * Thu May 20 2004 Graham Leggett <minfrin@apache.org> 2.0.50-dev
  330. - Changed default dependancy to link to db4 instead of db3.
  331. - Fixed complaints about unpackaged files.
  332. * Sat Apr 5 2003 Graham Leggett <minfrin@apache.org> 2.0.46-dev
  333. - Moved mime.types back to the default location.
  334. - Added mod_ldap and friends, mod_cache and friends.
  335. - Added openldap dependancy.
  336. * Sun Mar 30 2003 Graham Leggett <minfrin@apache.org> 2.0.45-1
  337. - Created generic Apache rpm spec file from that donated by Redhat.
  338. - Removed Redhat specific patches and boilerplate files.
  339. - Removed SSL related Makefiles.
  340. * Mon Feb 24 2003 Joe Orton <jorton@redhat.com> 2.0.40-21
  341. - add security fix for CAN-2003-0020; replace non-printable characters
  342. with '!' when printing to error log.
  343. - disable debuginfo on IA64.
  344. * Tue Feb 11 2003 Joe Orton <jorton@redhat.com> 2.0.40-20
  345. - disable POSIX semaphores to support 2.4.18 kernel (#83324)
  346. * Wed Jan 29 2003 Joe Orton <jorton@redhat.com> 2.0.40-19
  347. - require xmlto 0.0.11 or later
  348. - fix apr_strerror on glibc2.3
  349. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.40-18
  350. - rebuilt
  351. * Thu Jan 16 2003 Joe Orton <jorton@redhat.com> 2.0.40-17
  352. - add mod_cgid and httpd binary built with worker MPM (#75496)
  353. - allow choice of httpd binary in init script
  354. - pick appropriate CGI module based on loaded MPM in httpd.conf
  355. - source /etc/sysconfig/httpd in apachectl to get httpd choice
  356. - make "apachectl status" fail gracefully when links isn't found (#78159)
  357. * Mon Jan 13 2003 Joe Orton <jorton@redhat.com> 2.0.40-16
  358. - rebuild for OpenSSL 0.9.7
  359. * Fri Jan 3 2003 Joe Orton <jorton@redhat.com> 2.0.40-15
  360. - fix possible infinite recursion in config dir processing (#77206)
  361. - fix memory leaks in request body processing (#79282)
  362. * Thu Dec 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-14
  363. - remove unstable shmht session cache from mod_ssl
  364. - get SSL libs from pkg-config if available (Nalin Dahyabhai)
  365. - stop "apxs -a -i" from inserting AddModule into httpd.conf (#78676)
  366. * Wed Nov 6 2002 Joe Orton <jorton@redhat.com> 2.0.40-13
  367. - fix location of installbuilddir in apxs when libdir!=/usr/lib
  368. * Wed Nov 6 2002 Joe Orton <jorton@redhat.com> 2.0.40-12
  369. - pass libdir to configure; clean up config_vars.mk
  370. - package instdso.sh, fixing apxs -i (#73428)
  371. - prevent build if upstream MMN differs from mmn macro
  372. - remove installed but unpackaged files
  373. * Wed Oct 9 2002 Joe Orton <jorton@redhat.com> 2.0.40-11
  374. - correct SERVER_NAME encoding in i18n error pages (thanks to Andre Malo)
  375. * Wed Oct 9 2002 Joe Orton <jorton@redhat.com> 2.0.40-10
  376. - fix patch for CAN-2002-0840 to also cover i18n error pages
  377. * Wed Oct 2 2002 Joe Orton <jorton@redhat.com> 2.0.40-9
  378. - security fixes for CAN-2002-0840 and CAN-2002-0843
  379. - fix for possible mod_dav segfault for certain requests
  380. * Tue Sep 24 2002 Gary Benson <gbenson@redhat.com>
  381. - updates to the migration guide
  382. * Wed Sep 4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
  383. - link httpd with libssl to avoid library loading/unloading weirdness
  384. * Tue Sep 3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
  385. - add LoadModule lines for proxy modules in httpd.conf (#73349)
  386. - fix permissions of conf/ssl.*/ directories; add Makefiles for
  387. certificate management (#73352)
  388. * Mon Sep 2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
  389. - provide "httpd-mmn" to manage module ABI compatibility
  390. * Sun Sep 1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
  391. - fix SSL session cache (#69699)
  392. - revert addition of LDAP support to apr-util
  393. * Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
  394. - set SIGXFSZ disposition to "ignored" (#69520)
  395. - make dummy connections to the first listener in config (#72692)
  396. * Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
  397. - allow "apachectl configtest" on a 1.3 httpd.conf
  398. - add mod_deflate
  399. - enable LDAP support in apr-util
  400. - don't package everything in /var/www/error as config(noreplace)
  401. * Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
  402. - add trigger (#68657)
  403. * Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
  404. - update to 2.0.40
  405. * Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
  406. - improve comment on use of UserDir in default config (#66886)
  407. * Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
  408. - use /sbin/nologin as shell for apache user (#68371)
  409. - add patch from CVS to fix possible infinite loop when processing
  410. internal redirects
  411. * Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
  412. - modify init script to detect 1.3.x httpd.conf's and direct users
  413. to the migration guide
  414. * Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
  415. - patch apachectl to detect 1.3.x httpd.conf's and direct users
  416. to the migration guide
  417. - ship the migration guide
  418. * Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
  419. - move /etc/httpd2 back to /etc/httpd
  420. - add noindex.html page and poweredby logo; tweak default config
  421. to load noindex.html if no default "/" page is present.
  422. - add patch to prevent mutex errors on graceful restart
  423. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
  424. - automated rebuild
  425. * Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
  426. - add patch to fix SSL mutex handling
  427. * Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
  428. - improved config directory patch
  429. * Mon May 20 2002 Joe Orton <jorton@redhat.com>
  430. - initial build; based heavily on apache.spec and mod_ssl.spec
  431. - fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245