SameBoy.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126
  1. #!/bin/sh
  2. # Slackware build script for SameBoy
  3. # Copyright 2017-2020 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=SameBoy
  23. LIBNAM=$(printf %s $PRGNAM | tr 'A-Z' 'a-z')_libretro
  24. SRCNAM=${LIBNAM%%_*}
  25. VERSION=${VERSION:-0.12.3}
  26. RGBVERS=${RGBVERS:-0.3.9}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. CWD=$(pwd)
  37. TMP=${TMP:-/tmp/SBo}
  38. PKG=$TMP/package-$PRGNAM
  39. OUTPUT=${OUTPUT:-/tmp}
  40. LIBDIRSUFFIX=
  41. [ "$ARCH" = x86_64 ] && LIBDIRSUFFIX=64
  42. set -eu
  43. if pkg-config --exists sdl2; then
  44. STANDALONE="${STANDALONE:-yes}"
  45. else
  46. STANDALONE=no
  47. fi
  48. if [ "${LIBRETRO:=yes}" != yes ] && [ "$STANDALONE" != yes ]; then
  49. printf %s\\n 'ERROR: Both the SDL2 and Libretro builds are disabled.' >&2
  50. exit 1
  51. fi
  52. rm -rf $PKG
  53. mkdir -p $TMP $PKG $OUTPUT
  54. cd $TMP
  55. rm -rf $PRGNAM-$VERSION
  56. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  57. cd $PRGNAM-$VERSION
  58. tar xvf $CWD/rgbds-$RGBVERS.tar.gz
  59. chown -R root:root .
  60. find -L . \
  61. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  62. -o -perm 511 \) -exec chmod 755 {} \; -o \
  63. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  64. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  65. if [ "${DEBUG:=0}" != 0 ]; then
  66. CONF=debug
  67. DEBUG=1
  68. else
  69. CONF=release
  70. fi
  71. PATH="$TMP/$PRGNAM-$VERSION/rgbds-$RGBVERS/bin:$PATH"
  72. make -C rgbds-$RGBVERS Q=
  73. make -C rgbds-$RGBVERS install Q= \
  74. PREFIX=. \
  75. DESTDIR=./
  76. if [ "$STANDALONE" = yes ]; then
  77. make CONF=$CONF DATA_DIR=/usr/share/games/$SRCNAM/
  78. mkdir -p $PKG/usr/games $PKG/usr/share/games
  79. cp -av build/bin/SDL $PKG/usr/share/games/$SRCNAM
  80. rm -f $PKG/usr/share/games/$SRCNAM/LICENSE
  81. mv $PKG/usr/share/games/$SRCNAM/$SRCNAM $PKG/usr/games
  82. else
  83. make bootroms
  84. fi
  85. if [ "$LIBRETRO" = yes ]; then
  86. make -C libretro DEBUG=$DEBUG GIT_VERSION="${VERSION#*_}"
  87. install -Dm0644 build/bin/$LIBNAM.so \
  88. $PKG/usr/lib${LIBDIRSUFFIX}/libretro/$LIBNAM.so
  89. # sameboy_libretro.info from:
  90. # https://raw.githubusercontent.com/libretro/libretro-super/88176482b14e22b744b129bee84f27cb196936a9/dist/info/sameboy_libretro.info
  91. install -Dm0644 $CWD/$LIBNAM-info \
  92. $PKG/usr/lib${LIBDIRSUFFIX}/libretro/info/$LIBNAM.info
  93. fi
  94. if [ $DEBUG = 0 ]; then
  95. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  96. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  97. fi
  98. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  99. cp -a CHANGES.md LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
  100. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  101. mkdir -p $PKG/install
  102. cat $CWD/slack-desc > $PKG/install/slack-desc
  103. cd $PKG
  104. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}