RetroArch.SlackBuild 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195
  1. #!/bin/sh
  2. # Slackware build script for RetroArch
  3. # Copyright 2016-2019 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=RetroArch
  23. VERSION=${VERSION:-1.7.7}
  24. BUILD=${BUILD:-2}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ]; then
  38. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2 -fPIC"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -eu
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf $PRGNAM-$VERSION
  55. tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
  56. cd $PRGNAM-$VERSION
  57. chown -R root:root .
  58. find -L . \
  59. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  60. -o -perm 511 \) -exec chmod 755 {} \; -o \
  61. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  62. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  63. lib=
  64. if [ "${DEBUG:=0}" != 0 ]; then
  65. case "${ASAN:=}" in
  66. '' ) : ;;
  67. thread ) ASAN=thread ;;
  68. * ) ASAN=address ;;
  69. esac
  70. RELEASE=debug
  71. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0 -g/')"
  72. lib="${lib} --enable-debug"
  73. else
  74. ASAN=
  75. RELEASE=release
  76. fi
  77. [ "${DISCORD:-no}" = no ] && lib="${lib} --disable-discord"
  78. if [ "${GLES:-0}" != 0 ]; then
  79. lib="${lib} --enable-opengles"
  80. elif [ "${GLES3:-0}" != 0 ]; then
  81. lib="${lib} --enable-opengles --enable-opengles3"
  82. fi
  83. pkg-config --exists caca && lib="${lib} --enable-caca"
  84. pkg-config --exists flac && lib="${lib} --disable-builtinflac"
  85. pkg-config --exists libsixel && lib="${lib} --enable-sixel"
  86. [ -d /usr/include/mbedtls ] && lib="${lib} --disable-builtinmbedtls"
  87. [ -d /usr/include/miniupnpc ] && lib="${lib} --disable-builtinminiupnpc"
  88. [ "${PYTHON:-no}" != no ] && lib="${lib} --enable-python"
  89. [ "${MENU:-yes}" != yes ] && lib="${lib} --disable-menu"
  90. [ "${PULSE:-yes}" != yes ] && lib="${lib} --disable-pulse"
  91. [ "${QT:-yes}" != yes ] && lib="${lib} --disable-qt"
  92. [ "${GLUI:-yes}" != yes ] && lib="${lib} --disable-materialui"
  93. [ "${OZONE:-yes}" != yes ] && lib="${lib} --disable-ozone"
  94. [ "${RGUI:-yes}" != yes ] && lib="${lib} --disable-rgui"
  95. [ "${XMB:-yes}" != yes ] && lib="${lib} --disable-xmb"
  96. # Disable downloading cores with the online updater
  97. # https://github.com/libretro/RetroArch/issues/3237
  98. SED_CORE=; SED_INFO=; SED_MENU=
  99. if [ "${BUILDBOT:-0}" = 0 ]; then
  100. libdir="/usr/lib${LIBDIRSUFFIX}/libretro"
  101. infodir="${libdir}/info"
  102. SED_CORE="s|# libretro_directory =|libretro_directory = $libdir|"
  103. SED_INFO="s|# libretro_info_path =|libretro_info_path = $infodir|"
  104. SED_MENU='s|# menu_show_core_updater = true|menu_show_core_updater = false|'
  105. fi
  106. filter_dir="/usr/lib${LIBDIRSUFFIX}/retroarch/filters"
  107. # Set the default directories to be consistent with the installation.
  108. sed -e "s|# audio_filter_dir =|audio_filter_dir = ${filter_dir}/audio|" \
  109. -e "s|# video_filter_dir =|video_filter_dir = ${filter_dir}/video|" \
  110. -e "$SED_CORE;$SED_INFO;$SED_MENU" \
  111. -i retroarch.cfg
  112. # Fix qt5 support with 14.2.
  113. sed -i 's/-fPIC/-fPIC -std=c++11/' qb/qb.moc.sh
  114. # Fix --enable-opengles and --enable-opengles3
  115. # https://github.com/libretro/RetroArch/pull/8749
  116. # https://github.com/libretro/RetroArch/commit/1a3f16ded122bf3928aeb9beb71b594bf24ce01a
  117. patch -p1 < $CWD/gles.patch
  118. # Set $lib to a portable array
  119. eval "set -- $lib"
  120. CFLAGS="$SLKCFLAGS" \
  121. CXXFLAGS="$SLKCFLAGS" \
  122. ./configure \
  123. --prefix=/usr \
  124. --bindir=/usr/games \
  125. --mandir=/usr/man \
  126. --docdir=/usr/doc/$PRGNAM-$VERSION \
  127. --with-assets_dir=/usr/share/games \
  128. --disable-update_assets \
  129. --build=$ARCH-slackware-linux \
  130. "$@"
  131. make SANITIZER=$ASAN
  132. make install DESTDIR=$PKG
  133. for filter in audio video; do
  134. case $filter in
  135. audio )
  136. EXT=dsp
  137. DIR="libretro-common/$filter/dsp_filters"
  138. ;;
  139. video )
  140. EXT=filt
  141. DIR="gfx/${filter}_filters"
  142. ;;
  143. esac
  144. ( cd $DIR ; make build=$RELEASE )
  145. mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/retroarch/filters/$filter
  146. cp $DIR/*.$EXT $DIR/*.so $PKG/usr/lib${LIBDIRSUFFIX}/retroarch/filters/$filter
  147. chmod 0644 $PKG/usr/lib${LIBDIRSUFFIX}/retroarch/filters/$filter/*
  148. done
  149. mv $PKG/etc/retroarch.cfg $PKG/etc/retroarch.cfg.new
  150. if [ "$DEBUG" = 0 ]; then
  151. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  152. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  153. fi
  154. find $PKG/usr/man -type f -exec gzip -9 {} \;
  155. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  156. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  157. cp -a CHANGES.md CONTRIBUTING.md README-* $PKG/usr/doc/$PRGNAM-$VERSION
  158. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  159. mkdir -p $PKG/install
  160. cat $CWD/slack-desc > $PKG/install/slack-desc
  161. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  162. cd $PKG
  163. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}