mupen64plus-libretro.SlackBuild 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108
  1. #!/bin/sh
  2. # Slackware build script for mupen64plus-libretro
  3. # Copyright 2017-2018 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=mupen64plus-libretro
  23. LIBNAM=$(printf %s "$PRGNAM" | tr - _)
  24. VERSION=${VERSION:-2018.10.31_bb64262}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. if [ -z "$ARCH" ]; then
  28. case "$( uname -m )" in
  29. i?86) ARCH=i586 ;;
  30. arm*) ARCH=arm ;;
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. CWD=$(pwd)
  35. TMP=${TMP:-/tmp/SBo}
  36. PKG=$TMP/package-$PRGNAM
  37. OUTPUT=${OUTPUT:-/tmp}
  38. LIBDIRSUFFIX=
  39. [ "$ARCH" = x86_64 ] && LIBDIRSUFFIX=64
  40. set -eu
  41. rm -rf $PKG
  42. mkdir -p $TMP $PKG $OUTPUT
  43. cd $TMP
  44. rm -rf $PRGNAM-$VERSION
  45. tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
  46. cd $PRGNAM-$VERSION
  47. chown -R root:root .
  48. find -L . \
  49. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  50. -o -perm 511 \) -exec chmod 755 {} \; -o \
  51. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  52. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  53. [ "${DEBUG:=0}" != 0 ] && DEBUG=1
  54. [ "${GLES:=0}" != 0 ] && GLES=1
  55. [ "${GLES3:=0}" != 0 ] && GLES3=1
  56. make DEBUG=$DEBUG \
  57. FORCE_GLES=$GLES \
  58. FORCE_GLES3=$GLES3 \
  59. GIT_VERSION="${VERSION#*_}"
  60. install -Dm0644 $LIBNAM.so $PKG/usr/lib${LIBDIRSUFFIX}/libretro/$LIBNAM.so
  61. install -Dm0644 $LIBNAM.info $PKG/usr/lib${LIBDIRSUFFIX}/libretro/info/$LIBNAM.info
  62. if [ $DEBUG = 0 ]; then
  63. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  64. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  65. fi
  66. PLUGIN='GLideN64 mupen64plus-core mupen64plus-rsp-cxd4 mupen64plus-rsp-hle'
  67. DOCS='gpl-2.0.txt COPYING INSTALL LICENSES LICENSE README.md README RELEASE'
  68. for DOCDIR in $PLUGIN; do
  69. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/$DOCDIR
  70. if [ "$DOCDIR" = GLideN64 ]; then
  71. for DIR in GlideHQ Glow gles2n64; do
  72. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/$DOCDIR/$DIR
  73. for file in $DOCS; do
  74. if [ -f $DOCDIR/licenses/$DIR/$file ]; then
  75. cp -a $DOCDIR/licenses/$DIR/$file $PKG/usr/doc/$PRGNAM-$VERSION/$DOCDIR/$DIR
  76. fi
  77. done
  78. done
  79. fi
  80. for file in $DOCS; do
  81. if [ -f $DOCDIR/$file ]; then
  82. cp -a $DOCDIR/$file $PKG/usr/doc/$PRGNAM-$VERSION/$DOCDIR
  83. fi
  84. done
  85. done
  86. cp -a *.md LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
  87. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  88. mkdir -p $PKG/install
  89. cat $CWD/slack-desc > $PKG/install/slack-desc
  90. cd $PKG
  91. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}