visualboyadvance-m.SlackBuild 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135
  1. #!/bin/sh
  2. # Slackware build script for visualboyadvance-m
  3. # Copyright 2017-2019 orbea
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=visualboyadvance-m
  23. LIBNAM=vbam_libretro
  24. BRANCH=${BRANCH:-master}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_git}
  27. if [ -z "$ARCH" ]; then
  28. case "$( uname -m )" in
  29. i?86) ARCH=i586 ;;
  30. arm*) ARCH=arm ;;
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. CWD=$(pwd)
  35. TMP=${TMP:-/tmp/SBo}
  36. PKG=$TMP/package-$PRGNAM
  37. OUTPUT=${OUTPUT:-/tmp}
  38. if [ "$ARCH" = "i586" ]; then
  39. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  40. LIBDIRSUFFIX=""
  41. elif [ "$ARCH" = "i686" ]; then
  42. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  43. LIBDIRSUFFIX=""
  44. elif [ "$ARCH" = "x86_64" ]; then
  45. SLKCFLAGS="-O2 -fPIC"
  46. LIBDIRSUFFIX="64"
  47. else
  48. SLKCFLAGS="-O2"
  49. LIBDIRSUFFIX=""
  50. fi
  51. set -eu
  52. rm -rf $PKG
  53. mkdir -p $TMP $PKG $OUTPUT
  54. cd $TMP
  55. rm -rf $PRGNAM
  56. git clone --depth=1 -b $BRANCH https://github.com/$PRGNAM/$PRGNAM
  57. cd $PRGNAM
  58. HEAD="$(git rev-parse --short HEAD)"
  59. DATE="$(git show -s --format=%ad --date=format:%Y.%m.%d)"
  60. VERSION="${DATE}_$HEAD"
  61. chown -R root:root .
  62. find -L . \
  63. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  64. -o -perm 511 \) -exec chmod 755 {} \; -o \
  65. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  66. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  67. if [ "${DEBUG:=0}" != 0 ]; then
  68. DEBUG=1
  69. RELEASE=Debug
  70. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0/')"
  71. else
  72. RELEASE=Release
  73. fi
  74. WXCONF="/usr/lib$LIBDIRSUFFIX/wx/config/gtk2-unicode-3.0"
  75. # ffmpeg support is "horribly broken" and has build issues
  76. # https://github.com/visualboyadvance-m/visualboyadvance-m/issues/179
  77. mkdir -p build
  78. cd build
  79. cmake \
  80. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  81. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  82. -DCMAKE_INSTALL_PREFIX=/usr \
  83. -DCMAKE_INSTALL_BINDIR=games \
  84. -DCMAKE_INSTALL_DATADIR=share/games \
  85. -DCMAKE_INSTALL_MANDIR=man \
  86. -DwxWidgets_CONFIG_EXECUTABLE="$WXCONF" \
  87. -DENABLE_FFMPEG=OFF \
  88. -DCMAKE_BUILD_TYPE=$RELEASE ..
  89. make
  90. make install DESTDIR=$PKG
  91. cd ..
  92. (
  93. cd src/libretro
  94. make DEBUG=$DEBUG
  95. install -Dm0644 $LIBNAM.so \
  96. $PKG/usr/lib${LIBDIRSUFFIX}/libretro/$LIBNAM.so
  97. )
  98. curl --create-dirs -o $PKG/usr/lib${LIBDIRSUFFIX}/libretro/info/$LIBNAM.info \
  99. https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/$LIBNAM.info
  100. find $PKG/usr/lib${LIBDIRSUFFIX}/libretro -mindepth 1 -type d -exec chmod 755 {} \;
  101. if [ $DEBUG = 0 ]; then
  102. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  103. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  104. fi
  105. find $PKG/usr/man -type f -exec gzip -9 {} \;
  106. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  107. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  108. cp -a README.md todo.md doc/* $PKG/usr/doc/$PRGNAM-$VERSION
  109. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  110. mkdir -p $PKG/install
  111. cat $CWD/slack-desc > $PKG/install/slack-desc
  112. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  113. cd $PKG
  114. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}