123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101 |
- #!/bin/sh
- # Slackware build script for html2ps
- # Copyright 2012-2014 Robby Workman, Northport, Alabama, USA
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- PRGNAM=html2ps
- VERSION=${VERSION:-1.0b7}
- BUILD=${BUILD:-3}
- TAG=${TAG:-_SBo}
- ARCH=noarch
- CWD=$(pwd)
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- # We'll default to "letter"
- PAPER=${PAPER:-letter}
- # Paper type choices are:
- # A0, A1, A2, A3, A4, A5, A6, A7, A8, A9, A10,
- # B0, B1, B2, B3, B4, B5, B6, B7, B8, B9, B10,
- # letter, legal, arche, archd, archc, archb, archa,
- # flsa, flse, halfletter, 11x17, ledger, other
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
- cd $PRGNAM-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
- # Create the skeleton directory
- mkdir -p \
- $PKG/usr/bin \
- $PKG/usr/man/man1 \
- $PKG/usr/man/man5 \
- $PKG/usr/share/html2ps \
- $PKG/usr/doc/$PRGNAM-$VERSION
- # get rid of 'Use of assignment to $[ is deprecated' warning
- patch -p1 < $CWD/no_deprecated_assignment.diff
- # hardcode the answers to all the questions it wants to ask
- patch -p1 < $CWD/noninteractive_install.diff
- # noninteractive_install needs these
- export PKG VERSION
- ./install
- # Install xhtml2ps stuff
- mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
- cp -a contrib/xhtml2ps/xhtml2ps $PKG/usr/bin
- cat $CWD/xhtml2ps.desktop > $PKG/usr/share/applications/xhtml2ps.desktop
- cat $CWD/xhtml2ps.png > $PKG/usr/share/pixmaps/xhtml2ps.png
- # Now filter out the "$PKG" strings:
- sed -i "s,$PKG,,g" $(find $PKG -type f -print)
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/xhtml2ps/
- cp -a COPYING README html2ps.ps $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a contrib/xhtml2ps/LICENSE $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE.xhtml2ps
- cp -a contrib/xhtml2ps/README $PKG/usr/doc/$PRGNAM-$VERSION/README.xhtml2ps
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cat $CWD/doinst.sh > $PKG/install/doinst.sh
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|