ruby-gist.SlackBuild 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125
  1. #!/bin/sh
  2. #
  3. # Slackware build script for ruby-gist.
  4. #
  5. # Copyright 2016-2017 Edinaldo P. Silva, Rio de Janeiro, Brazil.
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. PRGNAM=ruby-gist
  25. SRCNAM=gist
  26. VERSION=${VERSION:-4.6.1}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. CWD=$(pwd)
  37. TMP=${TMP:-/tmp/SBo}
  38. PKG=$TMP/package-$PRGNAM
  39. OUTPUT=${OUTPUT:-/tmp}
  40. if [ "$ARCH" = "i586" ]; then
  41. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "i686" ]; then
  44. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  45. LIBDIRSUFFIX=""
  46. elif [ "$ARCH" = "x86_64" ]; then
  47. SLKCFLAGS="-O2 -fPIC"
  48. LIBDIRSUFFIX="64"
  49. else
  50. SLKCFLAGS="-O2"
  51. LIBDIRSUFFIX=""
  52. fi
  53. set -e
  54. rm -rf $PKG
  55. mkdir -p $TMP $PKG $OUTPUT
  56. cd $TMP
  57. rm -rf $PRGNAM-$VERSION
  58. mkdir $PRGNAM-$VERSION
  59. cd $PRGNAM-$VERSION
  60. chown -R root:root .
  61. find -L . \
  62. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  63. -o -perm 511 \) -exec chmod 755 {} \; -o \
  64. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  65. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  66. DESTDIR=$( ruby -r rbconfig -e '
  67. include RbConfig
  68. printf("%s/%s/gems/%s\n",
  69. CONFIG["libdir"],
  70. CONFIG["RUBY_INSTALL_NAME"],
  71. CONFIG["ruby_version"]
  72. )
  73. ')
  74. gem specification $CWD/$SRCNAM-$VERSION.gem | \
  75. ruby -r yaml -r rbconfig -e '
  76. c = RbConfig::CONFIG
  77. path = sprintf("%s/%s/gems/%s",
  78. c["libdir"],
  79. c["RUBY_INSTALL_NAME"],
  80. c["ruby_version"])
  81. sys_gemspecs = Dir.glob(path + "/specifications/**/*.gemspec").map {|g| gs = Gem::Specification.load(g); gs.name }
  82. obj = Gem::Specification.from_yaml($stdin)
  83. obj.dependencies.each {|dep|
  84. if not(dep.type == :runtime)
  85. next
  86. end
  87. if not(sys_gemspecs.include?(dep.name))
  88. $stderr.write("WARNING: #{dep.name} gem not found\n")
  89. sleep 0.5
  90. end
  91. }'
  92. gem install \
  93. --local \
  94. --no-update-sources \
  95. --ignore-dependencies \
  96. --backtrace \
  97. --install-dir $PKG/$DESTDIR \
  98. --bindir $PKG/usr/bin \
  99. $CWD/$SRCNAM-$VERSION.gem
  100. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  101. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  102. rm -rf $PKG/$DESTDIR/cache
  103. rmdir $PKG/$DESTDIR/{build_info,extensions}
  104. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  105. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  106. mkdir -p $PKG/install
  107. cat $CWD/slack-desc > $PKG/install/slack-desc
  108. cd $PKG
  109. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}