123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105 |
- #!/bin/sh
- # Slackware build script for Telegram
- # Marco Ferraioli marcoferraioli@live.com
- # Willy Sudiarto Raharjo <willysr@slackbuilds.org>
- # Modified by Vasily Sora <khronosschoty@posteo.org>
- # This program is free software: you can redistribute it and/or modify
- # it under the terms of the GNU General Public License as published by
- # the Free Software Foundation; either version 3 of the License, or
- # (at your option) any later version, with the following exception:
- # the text of the GPL license may be omitted.
- # This program is distributed in the hope that it will be useful, but
- # without any warranty; without even the implied warranty of
- # merchantability or fitness for a particular purpose. Compiling,
- # interpreting, executing or merely reading the text of the program
- # may result in lapses of consciousness and/or very being, up to and
- # including the end of all existence and the Universe as we know it.
- # See the GNU General Public License for more details.
- # You may have received a copy of the GNU General Public License along
- # with this program (most likely, a file named COPYING). If not, see
- # <http://www.gnu.org/licenses/>.
- # Modified by Mario Preksavec <mario@slackware.hr>
- PRGNAM=telegram
- SRCNAM=tsetup
- SRCDIR=Telegram
- URLSRC=${URLSRC:-https://telegram.org/dl/desktop/linux}
- # VERSION=${VERSION:-2.1.10}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- CWD=$(pwd)
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- case "$ARCH" in
- x86_64)
- SRC="${SRCNAM}"
- LIBDIRSUFFIX="64"
- ;;
- i586)
- SRC="${SRCNAM}32"
- LIBDIRSUFFIX=""
- ;;
- *)
- echo "$ARCH is not supported."
- exit 1
- ;;
- esac
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $SRCDIR
- wget -c --content-disposition -P $CWD $URLSRC
- SRCNAM=$(ls -t $CWD/${SRCNAM}* | head -1)
- VERSION=$(echo $SRCNAM | cut -d '.' -f2-4)
- tar xvf $SRCNAM
- cd $SRCDIR
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- mkdir -p $PKG/opt/$PRGNAM
- cp -a * $PKG/opt/$PRGNAM
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- mkdir -p $PKG/usr/bin
- ln -sf /opt/$PRGNAM/Telegram $PKG/usr/bin
- mkdir -p $PKG/usr/share/applications
- cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
- mkdir -p $PKG/usr/share/pixmaps
- cp $CWD/$PRGNAM.png $PKG/usr/share/pixmaps
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cat $CWD/doinst.sh > $PKG/install/doinst.sh
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|